summarylogtreecommitdiffstats
path: root/verbose-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'verbose-build.patch')
-rw-r--r--verbose-build.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/verbose-build.patch b/verbose-build.patch
new file mode 100644
index 000000000000..d218c7d45d62
--- /dev/null
+++ b/verbose-build.patch
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -148,18 +148,16 @@
+ cp $(PGDIR)/src/test/regress/sql/*.sql ./test/sql/postgres_regress/
+
+ .c.o:
+- @$(ECHO) compiling $(<)
+- @$(CC) $(CPPFLAGS) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ -c $<
+
+ .cc.o:
+- @$(ECHO) compiling $(<)
+- @$(CXX) $(CXXFLAGS) -o $@ -c $<
++ $(CXX) $(CXXFLAGS) -o $@ -c $<
+
+ $(ARLIB): $(OBJ_FILES) Makefile
+- @$(AR) $@ $(OBJ_FILES)
++ $(AR) $@ $(OBJ_FILES)
+
+ $(SOLIB): $(OBJ_FILES) Makefile
+- @$(CC) $(CFLAGS) -shared -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
++ $(CC) $(CFLAGS) -shared -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(OBJ_FILES) $(LIBS)
+
+ protobuf/pg_query.pb-c.c protobuf/pg_query.pb-c.h: protobuf/pg_query.proto
+ ifneq ($(shell which protoc-gen-c), )