summarylogtreecommitdiffstats
path: root/vla-warning.patch
diff options
context:
space:
mode:
Diffstat (limited to 'vla-warning.patch')
-rw-r--r--vla-warning.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/vla-warning.patch b/vla-warning.patch
new file mode 100644
index 000000000000..d036868c579a
--- /dev/null
+++ b/vla-warning.patch
@@ -0,0 +1,34 @@
+From a06cd41fcf96c7af62a0263e30a0a1cf962fc1ec Mon Sep 17 00:00:00 2001
+From: Andrew Walsh <awalsh@redhat.com>
+Date: Fri, 14 Jun 2019 12:25:12 -0400
+Subject: [PATCH] Ignored VLA warnings in the build for UDS and KVDO
+
+---
+ uds/Makefile | 1 +
+ vdo/Makefile | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/uds/Makefile b/uds/Makefile
+index abe679b..5d640d3 100644
+--- a/uds/Makefile
++++ b/uds/Makefile
+@@ -10,6 +10,7 @@ EXTRA_CFLAGS = -std=gnu99 \
+ -Werror \
+ -Wframe-larger-than=400 \
+ -Wno-declaration-after-statement \
++ -Wno-vla \
+ -DUDS_VERSION=\"$(UDS_VERSION)\" \
+ $(INCLUDES)
+
+diff --git a/vdo/Makefile b/vdo/Makefile
+index 02e488b..1835cac 100644
+--- a/vdo/Makefile
++++ b/vdo/Makefile
+@@ -14,6 +14,7 @@ EXTRA_CFLAGS = -std=gnu99 \
+ -Werror \
+ -Wframe-larger-than=400 \
+ -Wno-declaration-after-statement \
++ -Wno-vla \
+ -DVDO_VERSION_MAJOR=$(VDO_VERSION_MAJOR) \
+ -DVDO_VERSION_MINOR=$(VDO_VERSION_MINOR) \
+ -DVDO_VERSION_MICRO=$(VDO_VERSION_MICRO) \