summarylogtreecommitdiffstats
path: root/vmmon.patch
diff options
context:
space:
mode:
Diffstat (limited to 'vmmon.patch')
-rw-r--r--vmmon.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/vmmon.patch b/vmmon.patch
new file mode 100644
index 000000000000..b44cd19ad7c3
--- /dev/null
+++ b/vmmon.patch
@@ -0,0 +1,22 @@
+--- a/vmmon/Makefile
++++ b/vmmon/Makefile
+@@ -43,7 +43,11 @@ INCLUDE += -I$(SRCROOT)/shared
+ endif
+
+
++ifdef KVERSION
++VM_UNAME = $(KVERSION)
++else
+ VM_UNAME = $(shell uname -r)
++endif
+
+ # Header directory for the running kernel
+ ifdef LINUXINCLUDE
+@@ -137,7 +137,7 @@
+ endif
+
+ # Add Spectre options when available
+-CC_OPTS += $(call vm_check_gcc,-mindirect-branch=thunk -mindirect-branch-register,)
++CC_OPTS += $(call vm_check_gcc,-mindirect-branch-register,)
+
+ include $(SRCROOT)/Makefile.kernel