summarylogtreecommitdiffstats
path: root/waveedit-makefile-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'waveedit-makefile-flags.patch')
-rw-r--r--waveedit-makefile-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/waveedit-makefile-flags.patch b/waveedit-makefile-flags.patch
new file mode 100644
index 000000000000..99ee545d36af
--- /dev/null
+++ b/waveedit-makefile-flags.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index b961d79..51e79f9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,11 +22,14 @@ SOURCES = \
+ include Makefile-arch.inc
+ ifeq ($(ARCH),lin)
+ # Linux
+- FLAGS += -DARCH_LIN $(shell pkg-config --cflags gtk+-2.0)
++ FLAGS += -DARCH_LIN \
++ $(shell pkg-config --cflags gtk+-2.0) \
++ $(shell pkg-config --cflags sdl2)
+ LDFLAGS += -static-libstdc++ -static-libgcc \
+ -lGL -lpthread \
+- -Ldep/lib -lSDL2 -lsamplerate -lsndfile -ljansson -lcurl \
+- -lgtk-x11-2.0 -lgobject-2.0
++ -Ldep/lib -lsamplerate -lsndfile -ljansson -lcurl \
++ $(shell pkg-config --libs sdl2) \
++ $(shell pkg-config --libs gtk+-2.0)
+ SOURCES += ext/osdialog/osdialog_gtk2.c
+ else ifeq ($(ARCH),mac)
+ # Mac