summarylogtreecommitdiffstats
path: root/without_qiprobe.patch
diff options
context:
space:
mode:
Diffstat (limited to 'without_qiprobe.patch')
-rw-r--r--without_qiprobe.patch110
1 files changed, 110 insertions, 0 deletions
diff --git a/without_qiprobe.patch b/without_qiprobe.patch
new file mode 100644
index 000000000000..1f59edee2030
--- /dev/null
+++ b/without_qiprobe.patch
@@ -0,0 +1,110 @@
+Only in libqi-2.1.3: BUILD
+diff -puZ -r libqi-2.1.3old/CMakeLists.txt libqi-2.1.3/CMakeLists.txt
+--- libqi-2.1.3old/CMakeLists.txt 2014-11-13 19:07:49.000000000 +0100
++++ libqi-2.1.3/CMakeLists.txt 2015-03-26 17:40:29.294386931 +0100
+@@ -28,12 +28,17 @@ qi_add_optional_package(BOOST_LOCALE "En
+ enable_testing()
+ include(CMakeDependentOption)
+
+-find_package(qiprobes)
+-qiprobes_create_probe(tp_qi
+- src/tp_qi.in.h
+- PROVIDER_NAME qi_qi)
+-qiprobes_instrument_files(tp_qi
+- src/eventloop.cpp)
++if (WITH_PROBES)
++ find_package(qiprobes)
++ qiprobes_create_probe(tp_qi
++ src/tp_qi.in.h
++ PROVIDER_NAME qi_qi)
++ qiprobes_instrument_files(tp_qi
++ src/eventloop.cpp)
++ set(_tp_qi "tp_qi")
++else()
++ set(_tp_qi "")
++endif()
+
+ set(H
+ qi/details/eventloop.hxx
+@@ -157,7 +162,7 @@ list(APPEND C ${_out})
+ include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
+ include_directories("${CMAKE_CURRENT_SOURCE_DIR}/external")
+
+-qi_create_lib(qi ${_libtype} ${H} ${C} SUBMODULE tp_qi)
++qi_create_lib(qi ${_libtype} ${H} ${C} SUBMODULE ${_tp_qi})
+
+ if (WITH_QT_QTCORE)
+ qi_use_lib(qi QT_QTCORE)
+Only in libqi-2.1.3/examples/qitranslate/po: share
+diff -puZ -r libqi-2.1.3old/src/eventloop.cpp libqi-2.1.3/src/eventloop.cpp
+--- libqi-2.1.3old/src/eventloop.cpp 2014-11-13 19:07:49.000000000 +0100
++++ libqi-2.1.3/src/eventloop.cpp 2015-03-26 17:40:29.294386931 +0100
+@@ -16,7 +16,11 @@
+ #include <qi/future.hpp>
+
+ #include "eventloop_p.hpp"
+-#include "tp_qi.h"
++#ifdef WITH_PROBES
++# include "tp_qi.h"
++#else
++# define tracepoint(...)
++#endif
+
+ qiLogCategory("qi.eventloop");
+
+diff -puZ -r libqi-2.1.3old/tests/CMakeLists.txt libqi-2.1.3/tests/CMakeLists.txt
+--- libqi-2.1.3old/tests/CMakeLists.txt 2014-11-13 19:07:49.000000000 +0100
++++ libqi-2.1.3/tests/CMakeLists.txt 2015-03-26 18:13:47.511017563 +0100
+@@ -1,29 +1,31 @@
+ ## Copyright (c) 2012 Aldebaran Robotics. All rights reserved.
+ ## Use of this source code is governed by a BSD-style license that can be
+ ## found in the COPYING file.
+-if(${QIBUILD_VERSION} VERSION_GREATER "3.1")
+- qi_create_test_helper(testlaunch testlaunch.cpp)
+- qi_create_test_helper(testlaunchloop testlaunchloop.cpp)
+- qi_create_test_helper(check_env check_env.cpp)
+- qi_create_test_helper(check_machineid check_machineid.cpp)
+- qi_create_test_helper(test_application test_application.cpp)
+-else()
+- qi_create_bin(testlaunch NO_INSTALL testlaunch.cpp)
+- qi_create_bin(testlaunchloop NO_INSTALL testlaunchloop.cpp)
+- qi_create_bin(check_env NO_INSTALL check_env.cpp)
+- qi_create_bin(check_machineid NO_INSTALL check_machineid.cpp)
+- qi_create_bin(test_application NO_INSTALL test_application.cpp)
+-endif()
++if(QI_WITH_TESTS)
++ if(${QIBUILD_VERSION} VERSION_GREATER "3.1")
++ qi_create_test_helper(testlaunch testlaunch.cpp)
++ qi_create_test_helper(testlaunchloop testlaunchloop.cpp)
++ qi_create_test_helper(check_env check_env.cpp)
++ qi_create_test_helper(check_machineid check_machineid.cpp)
++ qi_create_test_helper(test_application test_application.cpp)
++ else()
++ qi_create_bin(testlaunch NO_INSTALL testlaunch.cpp)
++ qi_create_bin(testlaunchloop NO_INSTALL testlaunchloop.cpp)
++ qi_create_bin(check_env NO_INSTALL check_env.cpp)
++ qi_create_bin(check_machineid NO_INSTALL check_machineid.cpp)
++ qi_create_bin(test_application NO_INSTALL test_application.cpp)
++ endif()
+
+-qi_use_lib(testlaunchloop QI)
+-qi_use_lib(check_env QI)
+-qi_use_lib(check_machineid QI)
+-qi_use_lib(test_application QI)
++ qi_use_lib(testlaunchloop QI)
++ qi_use_lib(check_env QI)
++ qi_use_lib(check_machineid QI)
++ qi_use_lib(test_application QI)
+
+-set_target_properties(testlaunch PROPERTIES FOLDER tests)
+-set_target_properties(testlaunchloop PROPERTIES FOLDER tests)
+-set_target_properties(check_env PROPERTIES FOLDER tests)
+-set_target_properties(test_application PROPERTIES FOLDER tests)
++ set_target_properties(testlaunch PROPERTIES FOLDER tests)
++ set_target_properties(testlaunchloop PROPERTIES FOLDER tests)
++ set_target_properties(check_env PROPERTIES FOLDER tests)
++ set_target_properties(test_application PROPERTIES FOLDER tests)
++endif()
+
+ qi_create_gtest(test_qiclock SRC test_qiclock.cpp DEPENDS QI GTEST)
+ qi_create_gtest(test_qipath SRC test_qipath.cpp ../src/utils.cpp DEPENDS QI GTEST)