summarylogtreecommitdiffstats
path: root/wsjtx.patch
diff options
context:
space:
mode:
Diffstat (limited to 'wsjtx.patch')
-rw-r--r--wsjtx.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/wsjtx.patch b/wsjtx.patch
index 9b8e043ab3dd..41db48728059 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -21,3 +21,22 @@ diff -ur /CMakeLists.txt /CMakeLists.txt
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
+
+--- a/qt_helpers.hpp 2019-11-26 09:22:32.000000000 -0500
++++ b/qt_helpers.hpp 2020-02-03 11:30:07.488214336 -0500
+@@ -83,6 +83,7 @@
+ // std::hash<> specialization for QString based on the dbj2
+ // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
+ // is poor on 64-bit platforms due to being a 32-bit hash value
++ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+ template<>
+ struct hash<QString>
+ {
+@@ -96,6 +97,7 @@
+ return hash;
+ }
+ };
++#endif
+ }
+
+ // Register some useful Qt types with QMetaType