summarylogtreecommitdiffstats
path: root/wxGTK-collision.patch
diff options
context:
space:
mode:
Diffstat (limited to 'wxGTK-collision.patch')
-rw-r--r--wxGTK-collision.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/wxGTK-collision.patch b/wxGTK-collision.patch
new file mode 100644
index 000000000000..36d8acf26bec
--- /dev/null
+++ b/wxGTK-collision.patch
@@ -0,0 +1,81 @@
+diff -Naur wxPython-src-2.8.12.1.orig/build/bakefiles/wx.bkl wxPython-src-2.8.12.1/build/bakefiles/wx.bkl
+--- wxPython-src-2.8.12.1.orig/build/bakefiles/wx.bkl 2014-01-04 22:28:16.491774907 -0500
++++ wxPython-src-2.8.12.1/build/bakefiles/wx.bkl 2014-01-04 22:37:39.610020870 -0500
+@@ -128,7 +128,7 @@
+ <using module="gettext"/>
+ <gettext-catalogs id="locale">
+ <srcdir>$(SRCDIR)/locale</srcdir>
+- <catalog-name>wxstd</catalog-name>
++ <catalog-name>wxstd$(WX_RELEASE_NODOT)</catalog-name>
+ <linguas>
+ ca cs da de el es fi fr hu id it ja nl pl ru sl sv tr uk
+ zh zh_CN zh_TW
+diff -Naur wxPython-src-2.8.12.1.orig/Makefile.in wxPython-src-2.8.12.1/Makefile.in
+--- wxPython-src-2.8.12.1.orig/Makefile.in 2014-01-04 22:28:16.545107766 -0500
++++ wxPython-src-2.8.12.1/Makefile.in 2014-01-04 22:40:27.191813403 -0500
+@@ -11695,9 +11695,11 @@
+
+ install: $(__install_wxregex___depname) $(__install_wxzlib___depname) $(__install_wxpng___depname) $(__install_wxjpeg___depname) $(__install_wxtiff___depname) $(__install_wxodbc___depname) $(__install_wxexpat___depname) $(__install_monodll___depname) $(__install_monolib___depname) $(__install_basedll___depname) $(__install_baselib___depname) $(__install_netdll___depname) $(__install_netlib___depname) $(__install_coredll___depname) $(__install_corelib___depname) $(__install_advdll___depname) $(__install_advlib___depname) $(__install_mediadll___depname) $(__install_medialib___depname) $(__install_odbcdll___depname) $(__install_odbclib___depname) $(__install_dbgriddll___depname) $(__install_dbgridlib___depname) $(__install_htmldll___depname) $(__install_htmllib___depname) $(__install_qadll___depname) $(__install_qalib___depname) $(__install_xmldll___depname) $(__install_xmllib___depname) $(__install_xrcdll___depname) $(__install_xrclib___depname) $(__install_auidll___depname) $(__install_auilib___depname) $(__install_richtextdll___depname) $(__install_richtextlib___depname) $(__install_gldll___depname) $(__install_gllib___depname) $(__install_sound_sdl___depname) $(__install_wxrc___depname) install-wxconfig locale_install locale_msw_install $(__cocoa_res_install___depname)
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/aclocal
+- (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal)
++ (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal/wxwin2.8.m4)
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/bakefile/presets
+- (cd $(srcdir)/build/bakefiles/wxpresets/presets ; $(INSTALL_DATA) wx.bkl wx_unix.bkl wx_win32.bkl $(DESTDIR)$(datadir)/bakefile/presets)
++ (cd $(srcdir)/build/bakefiles/wxpresets/presets ; \
++ for i in wx.bkl wx_unix.bkl wx_win32.bkl ; do \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(datadir)/bakefile/presets/wx$(WX_RELEASE_NODOT)$${i##wx} ; done)
+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx
+ for f in setup.h $(RCDEFS_H); do \
+ if test ! -d $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx/`dirname $$f` ; then \
+@@ -12455,7 +12456,8 @@
+ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/config
+ $(INSTALL_PROGRAM) lib/wx/config/$(TOOLCHAIN_FULLNAME) $(DESTDIR)$(libdir)/wx/config
+- (cd $(DESTDIR)$(bindir) && rm -f wx-config && $(LN_S) $(libdir)/wx/config/$(TOOLCHAIN_FULLNAME) wx-config)
++ (cd $(DESTDIR)$(bindir) && rm -f wx-config-$(WX_RELEASE) \
++ && $(LN_S) ../lib/wx/config/$(TOOLCHAIN_FULLNAME) wx-config-$(WX_RELEASE))
+
+ locale_install:
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale
+@@ -12463,7 +12465,8 @@
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
+ if test -f $(srcdir)/locale/$$l.mo ; then \
+- $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd.mo ; \
++ $(INSTALL_DATA) $(srcdir)/locale/$$l.mo \
++ $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd$(WX_RELEASE_NODOT).mo ; \
+ fi ; \
+ done
+
+@@ -12480,7 +12483,7 @@
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
+ if test -f $(srcdir)/locale/msw/$$l.mo ; then \
+- $(INSTALL_DATA) $(srcdir)/locale/msw/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxmsw.mo ; \
++ $(INSTALL_DATA) $(srcdir)/locale/msw/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxmsw$(WX_RELEASE_NODOT).mo ; \
+ fi ; \
+ done
+
+diff -Naur wxPython-src-2.8.12.1.orig/src/common/intl.cpp wxPython-src-2.8.12.1/src/common/intl.cpp
+--- wxPython-src-2.8.12.1.orig/src/common/intl.cpp 2014-01-04 22:28:16.675106608 -0500
++++ wxPython-src-2.8.12.1/src/common/intl.cpp 2014-01-04 22:47:49.523526232 -0500
+@@ -1597,7 +1597,7 @@
+ bool bOk = true;
+ if ( bLoadDefault )
+ {
+- bOk = AddCatalog(wxT("wxstd"));
++ bOk = AddCatalog(wxT("wxstd" wxSTRINGIZE(wxMAJOR_VERSION) wxSTRINGIZE(wxMINOR_VERSION)));
+
+ // there may be a catalog with toolkit specific overrides, it is not
+ // an error if this does not exist
+diff -Naur wxPython-src-2.8.12.1.orig/utils/wxrc/Makefile.in wxPython-src-2.8.12.1/utils/wxrc/Makefile.in
+--- wxPython-src-2.8.12.1.orig/utils/wxrc/Makefile.in 2014-01-04 22:28:16.335109635 -0500
++++ wxPython-src-2.8.12.1/utils/wxrc/Makefile.in 2014-01-04 22:37:34.410068493 -0500
+@@ -120,7 +120,6 @@
+ @COND_USE_XRC_1@ rm -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT) $(DESTDIR)$(bindir)/wxrc-$(WX_RELEASE)
+ @COND_USE_XRC_1@ $(INSTALL_PROGRAM) wxrc$(EXEEXT) $(DESTDIR)$(bindir)
+ @COND_USE_XRC_1@ mv -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT) $(DESTDIR)$(bindir)/wxrc-$(WX_RELEASE)
+-@COND_USE_XRC_1@ (cd $(DESTDIR)$(bindir) && $(LN_S) wxrc-$(WX_RELEASE) wxrc$(EXEEXT))
+
+ @COND_USE_XRC_1@uninstall_wxrc:
+ @COND_USE_XRC_1@ rm -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT)