summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2019-05-06upgpkg: slurm-llnl-dev 19.05.0.0rc1-1Gordian Edenhofer
upgpkg: slurm-llnl-git 19.05.0.0rc1.r6.g1d5470a09c-1
2019-03-08upgpkg: slurm-llnl 18.08.6.2-1Gordian Edenhofer
Deprecate `autogen.sh` in favor of `autoreconf` which was made available in the recent -dev and -git release. upgpkg: slurm-llnl-dev 19.05.0.0pre3-1 upgpkg: slurm-llnl-git 19.05.0.0pre3.r28.g3816940ca5-1
2018-10-19upgpkg: slurm-llnl 18.08.2.1-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 19.05.0.0pre1-1 upgpkg: slurm-llnl-git 19.05.0.0pre1.r14.g33c9f38a48-1
2018-08-23upgpkg: slurm-llnl-dev 18.08.0.0rc1-1Gordian Edenhofer
upgpkg: slurm-llnl-git 18.08.0.0rc1.r93.g50248e98a9-1
2018-08-03upgpkg: slurm-llnl-dev 18.08.0.0pre2-1Gordian Edenhofer
upgpkg: slurm-llnl-git 18.08.0.0pre2.r1.g96c0a5ffaa-1
2018-04-19upgpkg: slurm-llnl 17.11.5.1-1Gordian Edenhofer
Add 'pmix' to the list of optdepends as it is required to support Open MPI applications which use PMIx. upgpkg: slurm-llnl-dev 18.08.0.0pre1-1 upgpkg: slurm-llnl-git 18.08.0.0pre1.r309.g2f50e2e177-1
2018-02-13upgpkg: slurm-llnl-dev 18.08.0.0pre1-1Gordian Edenhofer
upgpkg: slurm-llnl-git 18.08.0.0pre1.r2.g5de320145e-1
2018-02-08upgpkg: slurm-llnl 17.11.3.2-1Gordian Edenhofer
Relax CFLAGS further by stripping '-fno-plt'. upgpkg: slurm-llnl-dev 17.11.3.2-1 upgpkg: slurm-llnl-git 17.11.3.2.r303.gd5f98518f1-1
2018-01-08upgpkg: slurm-llnl 17.11.2.1-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.2.1-1 upgpkg: slurm-llnl-git 17.11.1.2.r205.g489b01de6a-1
2017-12-28upgpkg: slurm-llnl 17.11.1.2-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.1.2-1 upgpkg: slurm-llnl-git 17.11.0.1.r229.ge6b0f9f392-1
2017-12-28upgpkg: slurm-llnl 17.11.1.1-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.1.1-1
2017-12-07upgpkg: slurm-llnl 17.11.0.1-2Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.0.1-2 upgpkg: slurm-llnl-git 17.11.0.1.r116.g6862e2f2dc-1
2017-11-19upgpkg: slurm-llnl 17.02.9.1-2Gordian Edenhofer
Fix runtime bug related to the usage of a hardened build environment by removing '-z,now' from the LDFLAGS and CFLAGS environment variable. upgpkg: slurm-llnl-dev 17.11.0.0rc3-2 upgpkg: slurm-llnl-git 17.11.0.0pre2.r1285.g9f8f68e3cb-1
2017-11-11*.install: Instead of fancy `msg` use plain `echo`Gordian Edenhofer
Instead of relying on makepkg's built-in `msg` function simply use `echo` without any coloring or similar beatifications.
2017-11-10upgpkg: slurm-llnl-dev 17.11.0.0rc3-1Gordian Edenhofer
2017-11-01upgpkg: slurm-llnl 17.02.9.1-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.0.0rc2-1 upgpkg: slurm-llnl-git 17.11.0.0pre2.r1181.g7394fb21f2-1
2017-10-29slurm-llnl: Add armv7h to 'arch' arrayGordian Edenhofer
Upon the request of a user and some preliminary testing amend the 'arch' array to include 'armv7h' as a working architecture. slurm-llnl-dev slurm-llnl-git
2017-10-29slurm-llnl: Add gtk2 to makedependsGordian Edenhofer
Despite not being required at runtime, GTK2 is still necessary for compiling the source successfully. slurm-llnl-dev slurm-llnl-git
2017-10-25upgpkg: slurm-llnl-dev 17.11.0.0rc1-1Gordian Edenhofer
2017-10-19upgpkg: slurm-llnl 17.02.8.1-1Gordian Edenhofer
* Cleanup bash code in .install * Replace `echo -e` with makepkg's internal `msg` function * Streamline commenting style upgpkg: slurm-llnl-dev 17.11.0.0pre2-1 upgpkg: slurm-llnl-git 17.11.0.0pre2.r1028.gb10c33df25-1
2017-08-17upgpkg: slurm-llnl 17.02.7.1-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.0.0pre2-1 upgpkg: slurm-llnl-git 17.11.0.0pre2.r29.ga74e8eefd6-1
2017-07-12upgpkg: slurm-llnl 17.02.6.1-1Gordian Edenhofer
Fix directory name which changed due to switching the source to GitHub. upgpkg: slurm-llnl-dev 17.11.0.0pre1-1 upgpkg: slurm-llnl-git 17.11.0.0pre1.r185.gc7fe6d1451-1
2017-07-06upgpkg: slurm-llnl 17.02.6.1-1Gordian Edenhofer
Switch source to the official GitHub page and update the schema for invoking `${pkgver}` accordingly. upgpkg: slurm-llnl-dev 17.11.0.0pre1-1 upgpkg: slurm-llnl-git 17.11.0.0pre1.r184.g81ea1cb037-1
2017-06-26upgpkg: slurm-llnl 17.02.5-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.11.0_0pre1-1 upgpkg: slurm-llnl-git 17.11.0.0pre1.r107.g3adc7ba74a-1
2017-06-07upgpkg: slurm-llnl 17.02.4-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.4-1 upgpkg: slurm-llnl-git 17.02.1.1.r1083.gf3ccff5cee-1
2017-05-11upgpkg: slurm-llnl 17.02.3-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.3-1 upgpkg: slurm-llnl-git 17.02.1.1.r835.g4fa4f65e1b-1
2017-04-10upgpkg: slurm-llnl 17.02.2-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.2-1 upgpkg: slurm-llnl-git 17.02.1.1.r610.g6057523118-1
2017-03-03upgpkg: slurm-llnl 17.02.1_2-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.1_2-1 upgpkg: slurm-llnl-git 17.02.1.1.r255.g118db07672-1
2017-02-24upgpkg: slurm-llnl 17.02.0-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.0-1 upgpkg: slurm-llnl-git 17.02.0.0pre2.r1358.g99c6646ce2-1
2017-02-01upgpkg: slurm-llnl 16.05.9-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.0_0rc1-1 upgpkg: slurm-llnl-git 17.02.0.0pre2.r1058.gb31bb72a49-1
2017-01-24upgpkg: slurm-llnl-* 17.02.0_0pre4-1Gordian Edenhofer
Remove unneeded entries from conflict field. upgpkg: slurm-llnl-git 17.02.0.0pre2.r683.g4589be047d-1
2017-01-05upgpkg: slurm-llnl 16.05.8-1Gordian Edenhofer
Use https wherever possible in url and comment fields. upgpkg: slurm-llnl-dev 17.02.0_0pre4-1 upgpkg: slurm-llnl-git 17.02.0.0pre2.r683.g4589be047d-1
2016-12-09upgpkg: slurm-llnl 16.05.7-1Gordian Edenhofer
Switch from http to https and from md5sum to sha512sum for additional security. upgpkg: slurm-llnl-dev 17.02.0_0pre3-2 upgpkg: slurm-llnl-git 17.02.0.0pre2.r538.g8e7b7db-1
2016-10-29upgpkg: slurm-llnl 16.05.6-2Gordian Edenhofer
Move pid files in systemd services to /run instead of using a subfolder. Skip the creation of /var/log/slurm in systemd-tmpfiles since the log location is /var/log/slurm-llnl and install the tmpfile to /usr/lib instead of /etc/ . upgpkg: slurm-llnl-dev 17.02.0_0pre3-2 upgpkg: slurm-llnl 16.05.6-1
2016-10-28upgpkg: slurm-llnl 16.05.6-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 17.02.0_0pre3-1 upgpkg: slurm-llnl-git 17.02.0.0pre2.r292.g3fa5a23-1
2016-10-03upgpkg: slurm-llnl 16.05.5-1Gordian Edenhofer
Streamline systemd service files with upstream templates. upgpkg: slurm-llnl-dev 17.02.0_0pre2-1 upgpkg: slurm-llnl-git 17.02.0.0pre2.r9.ga9934d4-1
2016-09-30upgpkg: slurm-llnl-dev 17.02.0_0pre2-1Gordian Edenhofer
2016-07-27upgpkg: slurm-llnl-dev 17.02.0_0pre1-1Gordian Edenhofer
2016-07-16upgpkg: slurm-llnl 16.05.2-1Gordian Edenhofer
upgpkg: slurm-llnl-dev 16.05.2-1 upgpkg: slurm-llnl-git 16.05.2.1.r255.gd371bed-1
2016-06-30upgpkg: slurm-llnl 16.05.1-1Gordian Edenhofer
Delete slurm user after (!) changing the ownership of crucial files. upgpkg: slurm-llnl-dev 16.05.1-1 upgpkg: slurm-llnl-git 16.05.1.1.r182.ge0e89bb-1
2016-06-02upgpkg: slurm-llnl-dev 16.05.0-1Gordian Edenhofer
2016-05-13upgpkg: slurm-llnl-dev 16.05.0_0rc2-1Gordian Edenhofer
2016-05-04upgpkg: slurm-llnl-dev 16.05.0_0rc1-2Gordian Edenhofer
2016-05-01Change email address to GmailGordian Edenhofer
Gmail has been my main email address for a couple of years and the yahoo.de address is merely my spam mail. Since I trust Google spam filers and have a certain aversion for yahoo mail, I am switching.
2016-04-18Upgpkg: 16.05.0_0pre2-2Gordian Edenhofer
Mention pkgver in provides field for better dependency handling.
2016-04-18Upgpkg: 16.05.0_0pre2-2Gordian Edenhofer
Set some more configure flags to compile more libraries into the final package in the hope that users do not have to recompile after installing a new optdep. Trigger autogen.sh for an up-to-date ./configure script. Escape possible spaces in variables.
2016-03-30Upgpkg: 16.05.0_0pre2-1Gordian Edenhofer
Remove blcr from depends array since it is not provided in the AUR and needs heavy patching because according to the project page its latest supported kernel is 3.7.
2016-02-19Upgpkg: 16.05.0_0pre1-1Gordian Edenhofer
2016-02-06Upgpkg: 15.08.7-1Gordian Edenhofer
On post-remove make dirs formerly belonging to the slurm user be picked up by root.
2016-01-21Upgpkg: 15.08.7-1Gordian Edenhofer
Add etc/default/slurm-llnl to backup array.