summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2020-12-27upgpkg: xiphos-git 14.2.1.r5.gece84a4-2Caleb Maclennan
Rebuild for new ICU
2020-09-17add dbus-glib dependencyhaawda
2020-05-26remove .so dephaawda
2020-05-12Depend on package name as well as library moduleCaleb Maclennan
* upgpkg: xiphos 4.2.1-2 * upgpkg: xiphos-git 14.2.1-1 Add dependency on package name as well as library SO module. The SO module does the versioning trick we need correctly, but it makes it hard for AUR helpers (looking at you Manjaro) to resolve dependencies. Specifying the main package name likely to provide them bridges the gap. Also it looks like some Arch core packages do this (see e.g. harfbuzz / freetype) so it must be an okay hack.
2020-04-28upgpkg: xiphos-git 14.1.0.r112.g4e92215-1Caleb Maclennan
Be more careful about what tags we reference from
2020-04-28upgpkg: xiphos-git 14.1.0.r112.g4e92215-1Caleb Maclennan
Add new build dependency
2020-04-18Add new dependencyCaleb Maclennan
2020-04-17Update dependenciesCaleb Maclennan
2020-04-16Add missing makedepends, drop obsolete version requirementCaleb Maclennan
2020-03-17Drop gconf dependency, removed upstreamCaleb Maclennan
2020-03-14Normalize shell quoting using `shellharden`Caleb Maclennan
2020-03-14Overhaul packagingCaleb Maclennan
* Use pkgver() function that won't break if upstream tags something with a dash such as 4.2.0-rc1. * Correct version of license. * Sort depends/makedepends arrays and PKGBUILD keys in general. * Depend on biblesync via SO name to get first class support for version matching (e.g. needs to be rebuilt if SO version changes). * Cleanup use of `cmake` a little.
2019-08-26Cleanup bash shell quoting using shellhardenCaleb Maclennan
2019-07-30add appstream-glib as makedependancyhaawda
2019-05-13switch to cmake build systemhaawda
2019-01-14avoid gconf dependencyhaawda
2018-10-10bump pkgrelhaawda
2018-10-10add some quotinghaawda
2018-09-01Update .gitignore file for easy bulk repository managementCaleb Maclennan
2018-08-11add makedep to dcobook-utilshaawda
2018-04-20depend on sword 1.8.1 or greaterhaawda
2018-04-08dependancy sword is too old, must be sword-svnhaawda
2017-12-19Updated version (r3992 -> r3993).AUR Update Bot
2017-12-14Updated version (r3990 -> r3992).AUR Update Bot
2017-12-12Updated version (r3989 -> r3990).AUR Update Bot
2017-12-09updatehaawda
2017-11-18Updated version (r3986 -> r3987).haawda
2017-11-13Updated version (r3985 -> r3986).haawda
2017-11-07Updated version (r3983 -> r3985).haawda
2017-11-06Updated version (r3979 -> r3983).haawda
2017-11-04Updated version (r3978 -> r3979).haawda
2017-11-04updatehaawda
2017-11-04Updated version (r3974 -> r3977).haawda
2017-11-01updatehaawda
2017-09-18Updated version (r3968 -> r3970).haawda
2017-09-15Updated version (r3966 -> r3968).haawda
2017-09-14Updated version (r3964 -> r3966).haawda
2017-09-12Updated version (r3961 -> r3964).haawda
2017-09-09Updated version (r3960 -> r3961).haawda
2017-09-06Updated version (r3959 -> r3960).haawda
2017-09-04Updated version (r3956 -> r3959).haawda
2017-09-03Updated version (r3954 -> r3956).haawda
2017-08-29Updated version (r3952 -> r3954).haawda
2017-08-27Updated version (r3951 -> r3952).haawda
2017-08-26Updated version (r3950 -> r3951).haawda
2017-08-23Updated version (r3949 -> r3950).haawda
2017-08-21Updated version (r3943 -> r3949).haawda
2017-08-20Updated version (r3941 -> r3943).haawda
2017-08-13Updated version (r3940 -> r3941).haawda
2017-08-12Updated version (r3938 -> r3940).haawda