summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2020-10-15upgpkg: 0.97.1Kevin Brodsky
2020-09-29upgpkg: 0.97-2Kevin Brodsky
New upstream release, but without any announcement or updated hash on the forum...
2020-09-25upgpkg: 0.97.0Kevin Brodsky
2020-08-21Don't try to remove non-existing libfreetypeKevin Brodsky
libfreetype has been removed from 0.96.5, remove the workaround.
2020-08-21upgpkg: 0.96.5Kevin Brodsky
2020-07-01upgpkg: 0.96.4Kevin Brodsky
2020-06-25upgpkg: 0.96.3Kevin Brodsky
2020-05-08upgpkg: 0.96.2Kevin Brodsky
THe SHA256 doesn't match the one given by https://newsgroup.xnview.com/viewtopic.php?f=82&t=40411&p=162833#p162797, for now I've put the actual sum.
2020-04-23upgpkg: 0.96.1 + switch to SHA256Kevin Brodsky
Use SHA256 now available upstream: https://newsgroup.xnview.com/viewtopic.php?f=82&t=40314
2020-03-21upgpkg: 0.96Kevin Brodsky
2020-02-04upgpkg: 0.95-3Kevin Brodsky
Setting QT_QPA_PLATFORMTHEME should now be working again.
2020-01-28upgpkg: 0.95-2Kevin Brodsky
2020-01-26upgpkg: 0.95Kevin Brodsky
libfreetype is now shipped in the archive, but we need to remove it because it is not compatible with the system libfontconfig. Additionally, the shipped platformthemes libs don't seem to have been updated for the new Qt libs (5.12.6), so setting QT_QPA_PLATFORMTHEME triggers: Cannot mix incompatible Qt library (version 0x50907) with this library (version 0x50c06) Not much can be done about this, short of using the system Qt libs (which is what my xnviewmp-system-libs package does).
2020-01-15upgpkg: 0.94.3Kevin Brodsky
2019-12-25upgpkg: 0.94.2Kevin Brodsky
And merry Christmas!
2019-11-25upgpkg: 0.94.1-2Kevin Brodsky
Bump for the previous fixes.
2019-11-22Fix stupid copy-pasteKevin Brodsky
Copying from one package to another is evil...
2019-11-21Fix permissionsKevin Brodsky
The latest release has broken permissions for XnView, fix that, and xnview_2.png as well while at it.
2019-11-21upgpkg: 0.94.1Kevin Brodsky
2019-11-14upgpkg: 0.94Kevin Brodsky
2019-03-16updpkg: 0.93.1-2Kevin Brodsky
2019-03-09Fix error removing XnView.desktop~Kevin Brodsky
Looks like it is no longer in the archive, so there's nothing to remove!
2019-03-08updpkg: 0.93.1 + cleanupKevin Brodsky
Drop the 32-bit package, it hasn't been updated for a year now. Also update the optdepends for trash support (gio is now used instead of the defunct gvfs-trash).
2019-01-31updpkg: 0.93Kevin Brodsky
2018-09-21updpkg: 0.92Kevin Brodsky
2018-09-19updpkg: 0.91-2Kevin Brodsky
2018-09-14updpkg: 0.91Kevin Brodsky
2018-03-08updpkg: 0.90Kevin Brodsky
2018-01-17updpkg: 0.89Kevin Brodsky
2017-11-04updpkg: 0.88Kevin Brodsky
2017-09-07updpkg: 0.87Kevin Brodsky
2017-04-27updpkg: 0.86Kevin Brodsky
2017-04-04updpkg: 0.85Kevin Brodsky
2017-02-08updpkg: 0.84-4 [new 0.84 release]Kevin Brodsky
2017-01-24Version source archivesKevin Brodsky
Add the version number to the downloaded source archives. This talks makepkg into redownloading the sources when there is a new release, instead of keeping the old archive and failing the checksum. This also has the nice side-effect of keeping previous source versions, should one want to downgrade the package. Since upstream does not always bump the version number when releasing new sources, I had to use a trick to make it work. "-rel$srcrel" is appended to the filename, and if new sources of the same version are released, srcrel is incremented (and then reset to 1 when a new version is released). Not beautiful, but it should do the job.
2017-01-21Some PKGBUILD clean-upKevin Brodsky
* Remove unnecessary dependencies (the qt5 packages already depend on all the needed libraries). * Add xnviewmp.desktop as a source. * Remove xnviewmp.install which was not used anyway.
2017-01-21updpkg: 0.84-3Kevin Brodsky
The second release of 0.84 doesn't have libcu 54 at all... Thanks fuan_k for reporting this!
2017-01-20updpkg: 0.84-2Kevin Brodsky
New upstream release. It fixes the libicu issue (and now provides both 54 and 56, just in case...). Some people complained about font issues when using the system Qt libs, so let's revert to using the bundled ones, now that they work again.
2017-01-17updpkg: 0.84 + remove bundled libsKevin Brodsky
The bundled libs are broken in 0.84, some Qt 5 libraries are 5.6.1 and others 5.6.2, the former depending on icu 54 and the latter on icu 56, which is not even provided. Since it actually works with the system libs, let's remove all that mess. It may break at some point, but at least for now it's the easiest option (and it's also much better to use the system libs). Also added some cleanup (we use our own desktop file).
2016-10-09updpkg: 0.83Kevin Brodsky
Adopted the package and bumped to 0.83.
2016-07-19bump to 0.81Martin Poljak
2016-04-01gitignoreMartin Poljak
2016-04-01forgotten .srcinfo updateMartin Poljak
2016-04-01bump to 0.79Martin Poljak
2016-03-29package version bumpMartin Poljak
2016-03-29fixed according to grayich@mail.ru suggestionMartin Poljak
2016-02-23updated to 0.78Evan Penner
2015-11-02Updated checksumsEvan Penner
2015-10-28update to 0.76.1Evan Penner
2015-10-28Updated PKGBUILDBlack Forest