summarylogtreecommitdiffstats
path: root/.SRCINFO
blob: 67e7e6c6fb6212845dd83fa428c18d5e48f73e8d (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
pkgbase = llvm-git
	pkgver = 11.0.0_r351360.edbb27ccb63
	pkgrel = 1
	url = https://llvm.org/
	arch = x86_64
	license = custom:Apache 2.0 with LLVM Exception
	checkdepends = python-psutil
	makedepends = git
	makedepends = cmake
	makedepends = ninja
	makedepends = libffi
	makedepends = libedit
	makedepends = ncurses
	makedepends = libxml2
	makedepends = python-sphinx
	makedepends = ocaml
	makedepends = ocaml-ctypes
	makedepends = ocaml-findlib
	makedepends = python-sphinx
	makedepends = python-recommonmark
	makedepends = swig
	makedepends = python
	makedepends = python-six
	makedepends = z3
	makedepends = lua
	options = staticlibs
	source = llvm-project::git+https://github.com/llvm/llvm-project.git
	source = llvm-config.h
	md5sums = SKIP
	md5sums = 295c343dcd457dc534662f011d7cff1a
	sha512sums = SKIP
	sha512sums = 75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd

pkgname = llvm-git
	pkgdesc = LLVM development version. includes clang and many other tools
	depends = llvm-libs-git=11.0.0_r351360.edbb27ccb63-1
	depends = perl
	depends = python-six
	optdepends = python: for scripts
	optdepends = python-setuptools: for using lit = LLVM Integrated Tester
	provides = aur-llvm-git
	provides = compiler-rt-git
	provides = clang-git
	provides = lld-git
	provides = lldb-git
	provides = polly-git
	provides = compiler-rt
	provides = clang
	provides = lld
	provides = lldb
	provides = polly
	conflicts = llvm
	conflicts = compiler-rt
	conflicts = clang
	conflicts = lld
	conflicts = lldb
	conflicts = polly

pkgname = llvm-libs-git
	pkgdesc = runtime libraries for llvm-git
	depends = gcc-libs
	depends = zlib
	depends = libffi
	depends = libedit
	depends = ncurses
	depends = libxml2
	provides = aur-llvm-libs-git
	provides = llvm-libs
	conflicts = llvm-libs

pkgname = llvm-ocaml-git
	pkgdesc = OCaml bindings for LLVM
	depends = llvm-git=11.0.0_r351360.edbb27ccb63-1
	depends = ocaml
	depends = ocaml-ctypes
	provides = llvm-ocaml
	conflicts = llvm-ocaml