Package Details: 2mandvd 1.8.5-2

Git Clone URL: https://aur.archlinux.org/2mandvd.git (read-only, click to copy)
Package Base: 2mandvd
Description: DVD Authoring Maker In Linux Environnement
Upstream URL: http://2mandvd.tuxfamily.org/
Licenses: GPL
Provides: 2mandvd
Submitter: None
Maintainer: versipellis
Last Packager: ValHue
Votes: 59
Popularity: 0.000000
First Submitted: 2009-02-16 20:07 (UTC)
Last Updated: 2015-06-09 10:50 (UTC)

Latest Comments

micwoj92 commented on 2021-05-13 07:24 (UTC)

Hello, could you update links to https?

ArnaudNux commented on 2019-10-01 22:22 (UTC)

make: [Makefile:1109: obj/main.o] Error 1 make: Waiting for unfinished jobs.... mainfrm.cpp: In member function 'void mainfrm::f_delete_menuth(menu_th)': mainfrm.cpp:6645:45: warning: operation on '((mainfrm)this)->mainfrm::table_hdl_menuth[(((mainfrm)this)->mainfrm::wg_int_002 + 1)]->menu_th::is_first' may be undefined [-Wsequence-point] 6645 | table_hdl_menuth[wg_int_002+1]->is_first = table_hdl_menuth[wg_int_002+1]->is_first--; | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ mainfrm.cpp: In member function 'void mainfrm::f_select_menuth_step_2()': mainfrm.cpp:7012:66: warning: implicitly-declared 'QStringList& QStringList::operator=(const QStringList&)' is deprecated [-Wdeprecated-copy] 7012 | wl_explode = wl_str_001.split(";",QString::KeepEmptyParts); | ^ In file included from /usr/include/qt4/QtCore/QtCore:65, from /usr/include/qt4/QtGui/QtGui:3, from mainfrm.cpp:23: /usr/include/qt4/QtCore/qstringlist.h:71:12: note: because 'QStringList' has user-provided 'QStringList::QStringList(const QStringList&)' 71 | inline QStringList(const QStringList &l) : QList<QString>(l) { } | ^~~~~~~~~~~ make: ** [Makefile:1173: obj/mainfrm.o] Error 1 ==> ERROR: A failure occurred in build(). Aborting...

brice83 commented on 2018-09-11 18:09 (UTC)

anyone manage to install this package now?

ValHue commented on 2014-10-01 08:13 (UTC)

@osc Just needed to repackage. But I used to clean PKGBUILD

ValHue commented on 2014-10-01 07:26 (UTC)

@osc can you tell me where is the new version? is not the same as you have a problem, mark it as outdated. The latest version is 1.8.5 http://2mandvd.tuxfamily.org/ I will study your problem. You could be missing some dependency.

osc commented on 2014-09-30 14:24 (UTC)

Getting this error: 2ManDVD: error while loading shared libraries: libavformat.so.55: cannot open shared object file: No such file or directory

ValHue commented on 2013-08-13 16:43 (UTC)

Since no one has adopted this package, I'll take over. I hope your help and your support. Thank you.

ValHue commented on 2013-03-04 09:52 (UTC)

Now it works perfectly fine. Although 2mandvd.desktop and 2mandvd.sh not needed as sources in PKGBUILD

mrbit commented on 2013-03-03 14:23 (UTC)

agg in the pkgbuild qmake-qt4 2ManDVD.pro sed -i "41s|#ifdef|//#ifdef|" videowrapper.cpp sed -i '42i #if LIBAVFORMAT_VERSION_MAJOR >= 53' videowrapper.cpp make

mrbit commented on 2013-03-03 13:59 (UTC)

ok, solved: in the videowrapper.cpp -41 +42 41 // #ifdef avformat_open_input 42 + #if LIBAVFORMAT_VERSION_MAJOR >= 53 compila.!!

t3ddy commented on 2013-03-03 13:11 (UTC)

Sorry, but I don't have time to make a patch for this issue :(

ValHue commented on 2013-03-03 09:38 (UTC)

@mrbit and @t3ddy; to compile 2mandvd is necessary the downgrade proposed by @grunewald. I really worked well. Once installed, the system updates these packages, can be upgraded smoothly because 2mandvd still works. Although I had to make the symlinks I propose down. Can you think of a patch to fix this?

mrbit commented on 2013-03-02 18:35 (UTC)

videowrapper.cpp: In member function ‘void videowrapper::delete_videowrapper()’: videowrapper.cpp:34:5: warning: ‘void av_close_input_file(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1680) [-Wdeprecated-declarations] videowrapper.cpp:34:35: warning: ‘void av_close_input_file(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1680) [-Wdeprecated-declarations] videowrapper.cpp: In member function ‘int videowrapper::load_video(QString)’: videowrapper.cpp:45:81: error: ‘av_open_input_file’ was not declared in this scope videowrapper.cpp:53:8: warning: ‘int av_find_stream_info(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1504) [-Wdeprecated-declarations] videowrapper.cpp:53:38: warning: ‘int av_find_stream_info(AVFormatContext*)’ is deprecated (declared at /usr/include/libavformat/avformat.h:1504) [-Wdeprecated-declarations] videowrapper.cpp:67:35: warning: comparison between signed and unsigned integer expressions [-Wsign-compare] videowrapper.cpp:93:8: warning: ‘int avcodec_open(AVCodecContext*, AVCodec*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3674) [-Wdeprecated-declarations] videowrapper.cpp:93:38: warning: ‘int avcodec_open(AVCodecContext*, AVCodec*)’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3674) [-Wdeprecated-declarations] make: *** [obj/videowrapper.o] Errore 1 make: *** Attesa dei processi non terminati.... frame_th_trans.cpp:70:6: warning: unused parameter ‘event’ [-Wunused-parameter] idea..?!?

mrbit commented on 2013-03-02 13:13 (UTC)

sorry , please change qmake4 (command not found) to qmake-qt4

mrbit commented on 2013-03-01 15:32 (UTC)

please update qt4 and change qmake4

ValHue commented on 2012-11-19 10:34 (UTC)

Solved by: sudo ln -s /usr/lib/ffmpeg-compat/libavformat.so.53 /usr/lib/libavformat.so.53 sudo ln -s /usr/lib/ffmpeg-compat/libavcodec.so.53 /usr/lib/libavcodec.so.53

commented on 2012-11-05 05:23 (UTC)

Downgrade two packages and you'll be able to build the project without any issues. But after upgrading, libavcodec and libavformat dependencies will be broken. These packages are: ffmpeg and x264. http://arm.konnichi.com/2012/06/27/extra/os/i686/ # pacman -U /var/cache/pacman/pkg/ffmpeg-20120509-1-i686.pkg.tar.xz # pacman -U /var/cache/pacman/pkg/x264-20120204-1-i686.pkg.tar.xz

osc commented on 2012-10-15 21:50 (UTC)

getting this error: 2ManDVD: error while loading shared libraries: libavformat.so.53: cannot open shared object file: No such file or directory

philou24 commented on 2012-09-20 12:41 (UTC)

I have exactly the same errors than zerodahero

zerodahero commented on 2012-08-13 22:48 (UTC)

videowrapper.cpp: In member function 'void videowrapper::delete_videowrapper()': videowrapper.cpp:34:5: warning: 'void av_close_input_file(AVFormatContext*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1533) [-Wdeprecated-declarations] videowrapper.cpp:34:35: warning: 'void av_close_input_file(AVFormatContext*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1533) [-Wdeprecated-declarations] videowrapper.cpp: In member function 'int videowrapper::load_video(QString)': videowrapper.cpp:45:81: error: 'av_open_input_file' was not declared in this scope videowrapper.cpp:53:8: warning: 'int av_find_stream_info(AVFormatContext*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1357) [-Wdeprecated-declarations] videowrapper.cpp:53:38: warning: 'int av_find_stream_info(AVFormatContext*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1357) [-Wdeprecated-declarations] videowrapper.cpp:67:35: warning: comparison between signed and unsigned integer expressions [-Wsign-compare] videowrapper.cpp:93:8: warning: 'int avcodec_open(AVCodecContext*, AVCodec*)' is deprecated (declared at /usr/include/libavcodec/avcodec.h:3380) [-Wdeprecated-declarations] videowrapper.cpp:93:38: warning: 'int avcodec_open(AVCodecContext*, AVCodec*)' is deprecated (declared at /usr/include/libavcodec/avcodec.h:3380) [-Wdeprecated-declarations] make: *** [obj/videowrapper.o] Error 1

t3ddy commented on 2012-07-12 20:24 (UTC)

You should report this to the author, or you can make a patch. Now I don't have time.

osc commented on 2012-07-12 13:18 (UTC)

2ManDVD: error while loading shared libraries: libavformat.so.53: cannot open shared object file: No such file or directory

mrbit commented on 2012-06-02 12:00 (UTC)

please update...thanks

t3ddy commented on 2010-11-05 19:50 (UTC)

Updated to 1.4.4 I've added the appeal to donation made by the programmer to .install file

commented on 2010-10-27 20:12 (UTC)

Thanks for the update.

commented on 2010-10-27 11:35 (UTC)

The 1.4.3 version is now available to download: http://2mandvd.tuxfamily.org/?q=node/305

commented on 2010-10-25 07:27 (UTC)

It's strange, a new version was announced on the 2mandvd website. Sorry.

t3ddy commented on 2010-10-24 19:30 (UTC)

It's not yet released

commented on 2010-10-24 15:35 (UTC)

A new version (1.4.3) was released.

t3ddy commented on 2010-10-12 08:31 (UTC)

Maybe you should check the maintainer of that pkgbuild... and also the date

commented on 2010-10-12 08:12 (UTC)

You have to use Exif from AUR and you will have no problem.

t3ddy commented on 2010-10-02 15:25 (UTC)

I've tried also that, I think I've tried all of them, getting ever the same message.

commented on 2010-10-02 13:01 (UTC)

t3ddy: perl-exiftool perhaps ? http://www.archlinux.org/packages/extra/any/perl-exiftool/

t3ddy commented on 2010-10-02 12:47 (UTC)

Even with libexif installed 2mandvd still says "missing dependency: exif"

commented on 2010-10-02 07:48 (UTC)

http://archlinux.org/packages/search/?q=libexif

t3ddy commented on 2010-10-01 17:46 (UTC)

Anyone knows what package supply the dependency of exif, needed for the new version of 2mandvd?

t3ddy commented on 2010-09-04 10:09 (UTC)

done :)

commented on 2010-09-04 09:02 (UTC)

Tiny mistake in optdepends formatting: http://aur.pastebin.com/ZtDyDyuy Greek for the desktop entry: http://aur.pastebin.com/4FqW9h2B