Package Details: catalyst-total-pxp 15.5-1

Git Clone URL: https://aur.archlinux.org/catalyst-total-pxp.git (read-only)
Package Base: catalyst-total-pxp
Description: AMD/ATI drivers with powerXpress support. catalyst-hook + catalyst-utils + lib32-catalyst-utils. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libcl, nvidia, nvidia-utils
Provides: catalyst=15.5, catalyst-hook=15.5, catalyst-libgl=15.5, catalyst-utils=15.5, dri, libatical=15.5, libcl, libgl, libtxc_dxtn, opencl-catalyst=15.5
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 21
Popularity: 0.000674
First Submitted: 2012-08-04 14:48
Last Updated: 2015-06-08 18:34

Dependencies (20)

Required by (615)

Sources (29)

  • 20-catalystpxp.conf
  • arch-fglrx-authatieventsd_new.patch
  • atieventsd.service
  • atieventsd.sh
  • ati_make.sh
  • catalyst-hook.service
  • catalyst.conf
  • catalyst.sh
  • catalystpxp.sh
  • catalyst_build_module
  • cold-fglrx-3.14-current_euid.patch
  • fglrx_3.17rc6-no_hotplug.patch
  • fglrx_gpl_symbol.patch
  • hook-fglrx
  • http://www2.ati.com/drivers/linux/amd-catalyst-omega-15.5-linux-run-installers.zip
  • kolasa-3.19-get_cpu_var.patch
  • kolasa_4.0-cr4-strn.patch
  • kolasa_4.1_remove-IRQF_DISABLED.patch
  • lano1106_fglrx-13.8_proc.patch
  • lano1106_fglrx_intel_iommu.patch
  • lano1106_kcl_agp_13_4.patch
  • lib32-catalyst.sh
  • lib32-catalystpxp.sh
  • makefile_compat.patch
  • pxp_switch_catalyst
  • switchlibGL
  • switchlibglx
  • temp-links-catalyst.service
  • temp_links_catalyst

Latest Comments

Vi0L0 commented on 2015-08-26 08:47

ssfdust has found[1] that this package stopped working.
ATM I don't have time to fix this, so please switch to standard catalyst package(s) (which also supports pxp switching) for now.
Note that i'm slowly dropping dedicated -pxp packages and left only one of them. Anyway will look at this problem probably in the next week and let you know about any findings.
I am flagging it out of date for now.

[1]
https://bbs.archlinux.org/viewtopic.php?pid=1556543#p1556543

Sarotar commented on 2015-07-28 17:33

Thank you very much for answering so quickly.

I will try it when I got time for it.

Vi0L0 commented on 2015-07-25 19:10

catalyst 15.5 doesn't support xserver 1.17. catalyst 15.7 does, but it has some ugly bugs, like no tty. The more time I think about it I'm getting closer and closer to update stable packages to 15.7 anyway. So it may soon happen.

Meanwhile you can use catalyst-test, which is in version 15.7 and also has pxp support, just solved in other (better maybe, closer to arch for sure) way.

Sarotar commented on 2015-07-24 22:38

Hi There,

i just tried to install this driver over the repository from Vi0L0 and from the Tarball listed here.

It still do not install the driver when x server 1.17.x is in use.

Will there be a solution for this in the future?

Thanks!

Sarotar

yash commented on 2015-06-10 12:00

Hey Vi0L0, I checked `http://catalyst.wirephire.com/repo/catalyst/x86_64` and I don't see any catalyst-utils-pxp-15.x do I have to manually build this?

Can I install catalyst-hook and catalyst-libgl from repo and build catalyst-utils-pxp alone manually?

Vi0L0 commented on 2015-06-04 13:21

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- i've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5)
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx


@windler47:
it tells pacman that you can't use it with xorg-server newer than 1.16.x and older than 1.7.x

windler47 commented on 2015-05-29 17:36

Sorry for maybe stupid question, but what is the point of
xorg-server>=1.7.0
xorg-server<1.17.0
in dependencies ?

Vi0L0 commented on 2015-05-04 18:31

14.12-3:
- 4.0 kernel support (thanks to kolasa for patch)

fzerorubigd commented on 2015-05-03 19:51

Out of date? since the linux 4.0 is out :/

Vi0L0 commented on 2015-03-08 13:41

14.12-2:
- using kolasa's patch to cover 3.19 kernel support

All comments