Package Details: catalyst-total 15.9-12

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libcl, libgl, mesa-libgl, mesa-libgl-git
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libcl, libgl, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 126
Popularity: 0.087861
First Submitted: 2009-11-11 05:59
Last Updated: 2016-06-13 17:16

Dependencies (22)

Required by (671)

Sources (26)

  • 4.2-amd-from_crimson_15.11.patch
  • 4.3-gentoo-mtrr.patch
  • 4.3-kolasa-seq_printf.patch
  • 4.4-manjaro-xstate.patch
  • 4.6-arch-get_user_pages-page_cache_release.patch
  • arch-fglrx-authatieventsd_new.patch
  • ati-powermode.sh
  • atieventsd.service
  • atieventsd.sh
  • catalyst.conf
  • catalyst.sh
  • crimson_i686_xg.patch
  • dkms.conf
  • fglrx_gpl_symbol.patch
  • grsec_arch.patch
  • http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
  • lano1106_fglrx_intel_iommu.patch
  • lano1106_kcl_agp_13_4.patch
  • lib32-catalyst.sh
  • makefile_compat.patch
  • makesh-dont-check-gcc-version.patch
  • pxp_switch_catalyst
  • switchlibGL
  • switchlibglx
  • temp-links-catalyst.service
  • temp_links_catalyst

Latest Comments

Vi0L0 commented on 2016-06-13 17:17

thanks, silently changed

lordmocha commented on 2016-06-12 23:19

There seem to be non-UTF8 characters in the contributors' names in the PKGBUILD. Can those characters be changed/removed? They are breaking AUR helpers. Specifically the ü at position 1073.

Neije commented on 2016-04-13 19:54

Whith the opensource driver, the problem is that some cards does not work that well. And it's difficult to be sure until you tested. The later cards works pretty fine with "normal" games. Which model you can check on the wiki.

I have been experiencing the opensource driver for a while now and do not find any fluctuation. Sometimes I get glitches. But I had actually worse with the catalyst blob. So ... a bit less performance but much better compatibility and very easier update process xD

Am playing on linux, but my games does not demand that much ... so I can't tell for AAA games.

Vi0L0 commented on 2016-04-13 07:18

pre-GCN was dropped in later catalyst release, 5xxx should work just fine with this catalyst-total one.
Even in newer releases it's good to check out if its really not working, and if its not take (IIRC) /etc/ati/control file from catalyst 15.9 version and overwrite newer one with it.

Trist commented on 2016-04-13 07:07

@Neije
I know this is late but I haven't felt like trying again up to this point. Are all 5XXX devices just not supported anymore? What version should I look for if I want support? hd234k? I think this information should find it's way into the OP because the error itself doesn't present itself until its already installed and fucked up everything to the point where it would just be easier to reinstall

I want to use the open source drivers but I want a replacement for Windows entirely and while it does just work it gives me terrible performance. Even after turning off vsync, no matter what I do the opensource drivers will fluctuate in framerate rapidly. I know it is not a problem with my card because it will fluctuate at 60 fps down to 50, yet will allow me to raise my FPS to even 250 and fluctuate down to only 140ish which is playable but this isn't an option in most games

@arp12
You will need to downgrade your xorg-server
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

arp12 commented on 2016-04-04 19:55

How can I install this package without compatible xorg-server?

Neije commented on 2016-02-29 21:32

If I'm not mistaking your card is not supported anymore by catalyst. Just use the opensource driver ... or you must use and older version of catalyst+xorg.

But the opensource driver just works.

Trist commented on 2016-02-29 17:36

I am using an HD 5870 and this will not install on my system. First off I installed through the repositories, though the files should be the same. It gives an error saying my card is not supported. I don't remember the error message, I may try reinstalling again for debug info in the forums, but I figured this should be mentioned here since this is where I read that my card should still work with it in the first place.

Also this package will mess with your BIOS configuration and try overclocking your card among other changes without any user intervention so be warned.

Freso commented on 2016-02-08 12:43

@lordmocha If you're using the Catalyst drivers, be prepared to pretty much always be at least one version behind on both X.org and Linux kernel. The Catalyst drivers simply won't work on the newest releases due to the way AMD builds them.

lordmocha commented on 2016-02-08 05:40

The dependency `xorg-server` demands version `<1.18.0`, but the most recent version is `1.18.0-4`.

Any chance of an updated catalyst-total? Thanks.

All comments