Package Details: firestarter 1.0.3-15

Git Clone URL: https://aur.archlinux.org/firestarter.git (read-only)
Package Base: firestarter
Description: GUI front-end for iptables
Upstream URL: http://www.fs-security.com/
Licenses: GPL2
Submitter: fukawi2
Maintainer: fukawi2
Last Packager: fukawi2
Votes: 148
Popularity: 1.940675
First Submitted: 2009-06-10 23:35
Last Updated: 2015-06-08 23:47

Required by (0)

Sources (8)

Latest Comments

no111 commented on 2016-03-08 13:32

Installs and works fine. Thanks!

sacarde commented on 2015-10-17 18:26

building it I have this error:

[code]
/usr/lib/libgnutls.so.30: undefined reference to `asn1_der_decoding2@LIBTASN1_0_3'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_modules_load_and_initialize'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpn_cnd_sub_n'
/usr/lib/libgnutls.so.30: undefined reference to `asn1_decode_simple_ber@LIBTASN1_0_3'
/usr/lib/libgnutls.so.30: undefined reference to `asn1_delete_structure2@LIBTASN1_0_3'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpz_limbs_finish'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpz_limbs_read'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_release'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_load'
/usr/lib/gcc/i686-pc-linux-gnu/5.2.0/../../../libpangoft2-1.0.so: undefined reference to `hb_buffer_set_cluster_level'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpz_limbs_modify'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_config_option'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpz_roinit_n'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_get_flags'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_finalize'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpn_cnd_add_n'
/usr/lib/libhogweed.so.4: undefined reference to `__gmpz_limbs_write'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_initialize'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_uri_get_pin_value'
/usr/lib/libgnutls.so.30: undefined reference to `p11_kit_module_get_name'
[/code]

I solved installing:
harfbuzz
gnutls
nettle
pango
p11-kit
libtasn1
gmp
harfbuzz

fukawi2 commented on 2013-05-28 01:43

-14 adds systemd unit file

fukawi2 commented on 2012-12-10 01:51

Sorry, it does work, but your change also pulls out the subnet mask and broadcast address:

~ $ /sbin/ifconfig eth0 | grep inet | tr -s ' ' | cut -d \\ -f 3
inet 172.31.0.21 netmask 255.255.255.128 broadcast 172.31.0.127

~ $ /sbin/ifconfig eth0 | grep inet | tr -s ' ' | cut -d \\ -f 3 | grep -oE "[0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*"
172.31.0.21
255.255.255.128
172.31.0.127

katta commented on 2012-12-10 00:30

No, the regex work great with all ip, I'm sure, but, I know that firestarter have a lot of other problem.

katta commented on 2012-12-10 00:25

@DrTError
Install And run syslog-ng

fukawi2 commented on 2012-12-09 23:23

@katta
That patch doesn't help; the regex you've added only matches IP addresses where all octets are 2 digits, which excludes the majority of IPv4, and all IPv6.

firestarter has been abandoned for years, and does not support IPv6, so I would suggest starting to look for an alternative.

katta commented on 2012-12-09 17:06

@DrTError
Install And run syslog-ng

DrTError commented on 2012-12-09 16:36

Hy there
Cant read logfiles..any idea?

katta commented on 2012-11-27 00:25

exactly, I replaced 20-net-tools-ifconfig-format-change.patch whith this: https://dl.dropbox.com/u/103959213/firestarter/20-net-tools-ifconfig-format-change.patch
(md5sum: 39355330fdead64896204a0a1af550fe )

All comments