Package Details: kwin-lowlatency 5.19.4-1

Git Clone URL: https://aur.archlinux.org/kwin-lowlatency.git (read-only, click to copy)
Package Base: kwin-lowlatency
Description: the compositor, with added stutter/latency reductions
Upstream URL: https://github.com/tildearrow/kwin-lowlatency
Licenses: LGPL
Groups: plasma
Conflicts: kwin
Provides: kwin
Submitter: tildearrow
Maintainer: tildearrow
Last Packager: tildearrow
Votes: 37
Popularity: 2.54
First Submitted: 2019-03-28 06:53
Last Updated: 2020-07-28 17:11

Required by (48)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

tildearrow commented on 2020-07-28 17:00

@kokoko3k Hmmm... but those are already in the package (bar hwdata). Can you try deleting your build directory?

kokoko3k commented on 2020-07-28 07:07

It seems to me thaere are missing dependancies: https://pastebin.com/SEFy1Reb

  • hwdata, https://github.com/vcrhonek/hwdata Runtime-only dependency needed for mapping monitor hardware vendor IDs to full names
  • QtQuick.Controls-QMLModule, QML module 'QtQuick.Controls' is a runtime dependency.
  • QtQuick.VirtualKeyboard-QMLModule, QML module 'QtQuick.VirtualKeyboard' is a runtime dependency.

tildearrow commented on 2020-07-10 21:41

@Aberts10 That is odd. May I see your build log?

Aberts10 commented on 2020-07-10 21:33

@tildearrow I'm on Arch with Plasma 5.19.3

tildearrow commented on 2020-07-10 19:34

@Aberts10 Did you try with the Manjaro-specific PKGBUILD? They have not updated to 5.19.

https://github.com/tildearrow/kwin-lowlatency-manjaro

Aberts10 commented on 2020-07-10 19:26

==> Entering fakeroot environment... ==> Starting package()... -- Install configuration: "Debug" CMake Error at build/cmake_install.cmake:52 (file): file INSTALL cannot find "/var/tmp/pamac-build-brian/kwin-lowlatency/src/build/bin/libkwin.so.5.19.3": No such file or directory.

==> ERROR: A failure occurred in package(). Aborting...

tildearrow commented on 2020-06-10 18:37

@Max-P @ShayBox Package updated to match upstream PKGBUILD.

Please ensure you have installed Plasma 5.19 (vanilla KWin included) prior to building, and remember to make a clean build.

ShayBox commented on 2020-06-10 02:38

Broken with 5.19

Max-P commented on 2020-06-09 22:49

Needs kwayland-server as a dependency as of plasma 5.19.

There's a few other changes made in the stock kwin PKGBUILD that probably should be ported over as well: https://git.archlinux.org/svntogit/packages.git/commit/trunk/PKGBUILD?h=packages/kwin&id=b6de251557407d7c8bfe54aeb870db72015375b4

tildearrow commented on 2020-06-01 19:21

This package only follows stable versions. For unstable/beta versions, PKGBUILDs are available from the Releases section on GitHub.