Package Details: pkgbuilder 4.3.1-2

Git Clone URL: https://aur.archlinux.org/pkgbuilder.git (read-only, click to copy)
Package Base: pkgbuilder
Description: A Python AUR helper/library.
Upstream URL: https://github.com/Kwpolska/pkgbuilder
Keywords: aur aur4 download helper pkgbuild pkgbuilder
Licenses: BSD
Submitter: Kwpolska
Maintainer: Kwpolska
Last Packager: Kwpolska
Votes: 39
Popularity: 0.012284
First Submitted: 2011-09-20 14:46 (UTC)
Last Updated: 2021-12-23 11:48 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

gauthma commented on 2021-04-06 16:34 (UTC) (edited on 2021-04-06 16:35 (UTC) by gauthma)

Updated to the latest and greatest, but "$ pkgbuilder -Syu" fails like so:

:: Proceed with installation? [Y/n] 
==> Building python-pymupdf...
  -> aur/python-pymupdf 1.18.10-1 (6 votes) [installed: 1.18.9-1]
  ->     Python bindings for MuPDF
==> Cloning the git repository...
Already up to date.
==> Checking dependencies...
Traceback (most recent call last):
  File "/usr/bin/pkgbuilder", line 33, in <module>
    sys.exit(load_entry_point('pkgbuilder==4.3.0', 'console_scripts', 'pkgbuilder')())
  File "/usr/lib/python3.9/site-packages/pkgbuilder/__main__.py", line 356, in main
    out = pkgbuilder.build.auto_build(pkgname, DS.depcheck,
  File "/usr/lib/python3.9/site-packages/pkgbuilder/build.py", line 56, in auto_build
    build_result = build_runner(pkgname, performdepcheck, pkginstall, pkgbuild_edit)
  File "/usr/lib/python3.9/site-packages/pkgbuilder/build.py", line 516, in build_runner
    deps = depcheck(depends, pkg)
  File "/usr/lib/python3.9/site-packages/pkgbuilder/build.py", line 264, in depcheck
    syncpkgs = functools.reduce(lambda x, y: x + y, syncpkgs)
TypeError: reduce() of empty sequence with no initial value

If more information is required, just ask. Thanks.

Kwpolska commented on 2017-07-13 10:26 (UTC)

@FirefighterBlu3 thanks, fixed in v4.2.14.

FirefighterBlu3 commented on 2017-07-13 03:19 (UTC)

seems to be a problem in current release if there's nothing to do. $ pb -Syu :: Synchronizing package databases... core is up to date extra is up to date community is up to date archlinuxfr is up to date :: Starting full system upgrade... there is nothing to do :: Synchronizing package databases... :: Starting full system upgrade... there is nothing to do Traceback (most recent call last): File "/usr/bin/pb", line 11, in <module> load_entry_point('pkgbuilder==4.2.13', 'console_scripts', 'pb')() File "/usr/lib/python3.6/site-packages/pkgbuilder/wrapper.py", line 34, in main pkgbuilder.wrapper.wrapper() File "/usr/lib/python3.6/site-packages/pkgbuilder/wrapper.py", line 291, in wrapper info = pkgbuilder.utils.info(pkgnames) File "/usr/lib/python3.6/site-packages/pkgbuilder/utils.py", line 37, in info aur_pkgs = RPC.multiinfo(pkgnames) File "/usr/lib/python3.6/site-packages/pkgbuilder/aur.py", line 125, in multiinfo response['resultcount'] = len(results) UnboundLocalError: local variable 'response' referenced before assignment

garyvdm commented on 2014-07-29 17:14 (UTC)

Please add python-setuptools as a dependency. Without it the console script entry points don't get created. Without this pkgbuilder cant be run.

Kwpolska commented on 2014-05-28 12:12 (UTC)

@gauthma: AUR has updated their API in a way that is incompatible with PKGBUILDer v3.2.0. v3.3.0 (experimental!) should be out later today.

gauthma commented on 2014-05-27 22:12 (UTC)

I seem to have stumbled to another bug... though I'm not sure, because two days ago it worked fine... In any case, when running pkgbuilder -Syu I get: :: Synchronizing package databases... ==> ERROR: AURDict has an unknown PackageBase key (Package: AURPackage.from_aurdict()) Is this a legitimate problem, or has something in my system gone haywire? (I've just updated and rebooted -- to no avail, the problem remains)

Kwpolska commented on 2014-03-25 13:49 (UTC)

@gauthma oh. sorry. found the cause, should be working in next release (later today).

gauthma commented on 2014-03-24 21:06 (UTC)

Attempting to upgrade with $ pkgbuilder -u yields this error: $ pkgbuilder -u ==> Synchronizing package databases... ==> Starting full system upgrade... Traceback (most recent call last): File "/usr/bin/pkgbuilder", line 12, in <module> pkgbuilder.main.main() File "/usr/lib/python3.3/site-packages/pkgbuilder/main.py", line 215, in main upnames = pkgbuilder.upgrade.auto_upgrade(dodowngrade, args.vcsup) File "/usr/lib/python3.3/site-packages/pkgbuilder/upgrade.py", line 149, in auto_upgrade '({2})').format(**i) TypeError: format() argument after ** must be a mapping, not list --- If the debug output is required, let me know in a comment.

silvergeko commented on 2014-01-22 17:16 (UTC)

@Kwpolska: Ok works great. thanks

Kwpolska commented on 2014-01-22 17:01 (UTC)

3rd*, even better.