Package Details: abcl 1.9.0-1

Git Clone URL: https://aur.archlinux.org/abcl.git (read-only, click to copy)
Package Base: abcl
Description: Full implementation of the Common Lisp language in the JVM
Upstream URL: https://common-lisp.net/project/armedbear/
Licenses: GPL
Provides: common-lisp
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 13
Popularity: 0.48
First Submitted: 2010-11-02 15:59 (UTC)
Last Updated: 2022-04-30 12:49 (UTC)

Dependencies (5)

Required by (29)

Sources (2)

Latest Comments

random-nick commented on 2022-07-04 10:46 (UTC)

Checksum fail on abcl-src-1.9.0.tar.gz

elderica commented on 2021-02-22 05:00 (UTC)

Checksum fail on abcl-src-1.8.0.tar.gz

yitzi commented on 2020-07-16 00:35 (UTC)

Checksum fail on abcl-src-1.7.0.tar.gz

shinmera commented on 2018-03-19 12:02 (UTC)

Arch has rolled out Java 9, but unfortunately ABCL is currently only Java 8 compatbile. The script should be updated to use an older Java version if necessary.

hav3lock commented on 2013-05-02 20:54 (UTC)

You're welcome, and thank you.

haawda commented on 2013-05-02 18:45 (UTC)

Did so, thanks.

hav3lock commented on 2013-05-02 03:56 (UTC)

please add provides=('common-lisp')

hav3lock commented on 2013-03-13 07:08 (UTC)

Thanks for taking care of that, Stefan.

hav3lock commented on 2013-03-12 17:30 (UTC)

/usr/bin/abcl doesn't accept command-line options, or it doesn't recognize them. Honestly, I'm tempted to just repackage abcl myself. If I were yall, then I'd just have the /usr/bin/abcl file contain something like this: #!/bin/sh java -jar /path/to/abcl/.jar/file/abcl.jar "$@" because the above actually allows the abcl.jar file to do its job, that is start Armed Bear Common Lisp and receive command-line args.

haawda commented on 2012-01-11 20:42 (UTC)

Update

haawda commented on 2011-10-25 00:58 (UTC)

update

haawda commented on 2011-06-17 22:04 (UTC)

That is a known feature. After installing apache-ant you have to relogin or run a certain script under /etc/profile.d (apache-ant.sh or apache-ant.csh, depending on your shell). A similar issue arises if you change from jre to openjdk or vice versa.

commented on 2011-06-15 04:43 (UTC)

apache-ant does not seem to install an ant executable in the standard PATH. I had to use /usr/share/java/apache-ant/bin/ant for the build to work.

haawda commented on 2011-01-23 01:46 (UTC)

Another version bump

haawda commented on 2010-12-05 15:40 (UTC)

version bump