Package Details: abcl 1.3.3-1

Git Clone URL: https://aur.archlinux.org/abcl.git (read-only)
Package Base: abcl
Description: Full implementation of the Common Lisp language in the JVM
Upstream URL: http://common-lisp.net/project/armedbear/
Licenses: GPL
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 10
Popularity: 0.002955
First Submitted: 2010-11-02 15:59
Last Updated: 2015-09-18 23:51

Latest Comments

hav3lock commented on 2013-05-02 20:54

You're welcome, and thank you.

haawda commented on 2013-05-02 18:45

Did so, thanks.

hav3lock commented on 2013-05-02 03:56

please add provides=('common-lisp')

hav3lock commented on 2013-03-13 07:08

Thanks for taking care of that, Stefan.

hav3lock commented on 2013-03-12 17:30

/usr/bin/abcl doesn't accept command-line options, or it doesn't recognize them. Honestly, I'm tempted to just repackage abcl myself.

If I were yall, then I'd just have the /usr/bin/abcl file contain something like this:

#!/bin/sh
java -jar /path/to/abcl/.jar/file/abcl.jar "$@"

because the above actually allows the abcl.jar file to do its job, that is start Armed Bear Common Lisp and receive command-line args.

hav3lock commented on 2013-03-12 17:24

/usr/bin/abcl doesn't accept command-line options, or it doesn't recognize them. Honestly, I'm tempted to just repackage abcl myself.

haawda commented on 2012-01-11 20:42

Update

haawda commented on 2011-10-25 00:58

update

haawda commented on 2011-06-17 22:04

That is a known feature. After installing apache-ant you have to relogin or run a certain script under /etc/profile.d (apache-ant.sh or apache-ant.csh, depending on your shell). A similar issue arises if you change from jre to openjdk or vice versa.

Anonymous comment on 2011-06-15 04:43

apache-ant does not seem to install an ant executable in the standard PATH. I had to use /usr/share/java/apache-ant/bin/ant for the build to work.

All comments