Package Details: abook-git 0.6.0pre2.r71.gb83bcbf-1

Git Clone URL: https://aur.archlinux.org/abook-git.git (read-only)
Package Base: abook-git
Description: Text-based addressbook program designed to use with mutt mail client
Upstream URL: http://abook.sourceforge.net/
Licenses: GPL
Conflicts: abook
Provides: abook
Submitter: 2ion
Maintainer: parazyd
Last Packager: 2ion
Votes: 0
Popularity: 0.000000
First Submitted: 2015-05-02 15:39
Last Updated: 2015-06-08 18:53

Required by (2)

Sources (1)

Latest Comments

ephaeton commented on 2016-03-18 13:16

Imagine you want to use the current 0.6.1 development version.

There's certainly a better way to patch database.h?

$ diff -u abook-git/PKGBUILD abook-0.6.1/PKGBUILD
--- abook-git/PKGBUILD 2015-06-08 20:52:54.000000000 +0200
+++ abook-0.6.1/PKGBUILD 2016-03-18 13:58:06.351691080 +0100
@@ -1,6 +1,6 @@
# Maintainer: 2ion <dev@2ion.de>
pkgname=abook-git
-pkgver=0.6.0pre2.r71.gb83bcbf
+pkgver=0.6.1
pkgrel=1
pkgdesc="Text-based addressbook program designed to use with mutt mail client"
arch=('x86_64' 'i686')
@@ -10,7 +10,7 @@
makedepends=('git' 'autoconf' 'automake')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+git://git.code.sf.net/p/abook/git#branch=master")
+source=("${pkgname%-git}::git+git://git.code.sf.net/p/abook/git#tag=ver_0_6_1")
md5sums=('SKIP')

pkgver() {
@@ -20,6 +20,7 @@

build() {
cd "$srcdir/${pkgname%-git}"
+ sed -e 's,inline int field_id,int field_id,' < database.h > database.h.patched && mv -f database.h.patched database.h
autoreconf --force --install --symlink
./configure --prefix=/usr
make