Package Details: acroread 9.5.5-18

Git Clone URL: https://aur.archlinux.org/acroread.git (read-only, click to copy)
Package Base: acroread
Description: Adobe Acrobat Reader is a PDF file viewer
Upstream URL: http://www.adobe.com/products/reader/
Licenses: custom
Submitter: None
Maintainer: Geballin
Last Packager: Geballin
Votes: 857
Popularity: 0.45
First Submitted: 2008-05-15 19:18
Last Updated: 2021-06-08 19:27

Required by (2)

Sources (16)

Pinned Comments

tuckerboniface commented on 2018-08-26 18:48

I applied @olvie's patch to bundle the old harfbuzz and glib libs, acroread should work now.

fordprefect commented on 2016-05-17 19:35

There are reports about this software dying after 15s again.
known workarounds:
• use another pdf-reader whereever possible
• use acroread windows version in wine (HowTo: https://appdb.winehq.org/objectManager.php?sClass=version&iId=27093&iTestingId=92286)
• remove /opt/Adobe/Reader9/Reader/intellinux/plug_ins/EFS.api (this might have unknown consequences regarding your data and software functionality, especially related to internet connectivity)
• comment out the ipv6 line (::1) in /etc/hosts (this might impair your ipv6 connectivity and functionality of locally communicating programs)

This package *is not* out-of-date, it serves outdated software.

Latest Comments

« First ‹ Previous ... 33 34 35 36 37 38

heavyrail commented on 2010-09-30 14:04

At x86_64 it won't start without libxcb-render-util.so.0 which is in multilib/lib32-xcb-util package.
Please add the package to the dependencies list of 64-bit version.

archan.paul commented on 2010-09-28 13:33

Here is the PKGBUILD which is compatible with both i686 & x86_64.

[arp@arpd acroread]$ diff PKGBUILD.orig PKGBUILD
8c8
< arch=('i686')
---
> arch=('i686' 'x86_64')
11a12
> [ "$CARCH" = 'x86_64' ] && depends=('lib32-gtk2' 'lib32-mesa' 'lib32-libxml2')

jvalecillos commented on 2010-07-01 15:23

Updated!

silvik commented on 2010-06-30 21:17

Updated PKGBUILD below, it's a critical security release.
I used a faster, alternative download link. Maybe it makes it's way to official PKGBUILD version.

# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: Jose Valecillos <valecillosjg (at) gmail (dot) com>

pkgname=acroread
pkgver=9.3.3
pkgrel=1
pkgdesc="Adobe Reader is a PDF file viewer"
arch=('i686')
url="http://www.adobe.com/products/reader/"
license=('custom')
depends=('gtk2' 'mesa' 'desktop-file-utils')
options=('!strip')
install=acroread.install
source=(http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/$pkgver/enu/AdbeRdr$pkgver-1_i486linux_enu.tar.bz2)
md5sums=('927755485de99a4e76d80c0a2b4e52c9')

build() {
cd "$srcdir/AdobeReader"
bsdtar -xf COMMON.TAR || return 1
bsdtar -xf ILINXR.TAR || return 1
cd Adobe/Reader9

msg2 "Installing Main Files..."
mkdir -p "$pkgdir/usr/lib/acroread" || return 1
cp -a * "$pkgdir/usr/lib/acroread" || return 1
echo done

msg2 "Installing Bin Files..."
mkdir -p "$pkgdir/usr/bin" || return 1
ln -s /usr/lib/acroread/bin/acroread "$pkgdir/usr/bin" || return 1
install -Dm644 Resource/Shell/acroread.1.gz ${pkgdir}/usr/share/man/man1/acroread.1.gz || return 1
install -Dm644 Resource/Shell/acroread_tab ${pkgdir}/etc/bash_completion.d/acroread || return 1
echo done

msg2 "Installing Broswer Plugin..."
mkdir -p "$pkgdir/usr/lib/mozilla/plugins" || return 1
ln -s /usr/lib/acroread/Browser/intellinux/nppdf.so "$pkgdir/usr/lib/mozilla/plugins" || return 1
echo done

msg2 "Installing Icon Resource..."
install -D -m644 Resource/Support/AdobeReader.desktop \
"$pkgdir/usr/share/applications/acroread.desktop" || return 1
sed -i '/^Icon/s|AdobeReader9|acroread|' \
"$pkgdir/usr/share/applications/acroread.desktop"
install -D -m644 Resource/Icons/64x64/AdobeReader9.png \
"$pkgdir/usr/share/pixmaps/acroread.png" || return 1
echo done

msg2 "Installing License..."
install -D -m644 Reader/Legal/en_US/License.txt \
"$pkgdir/usr/share/licenses/acroread/License.txt" || return 1
echo done
}

solstice commented on 2010-06-14 11:27

this PKGBUILd is graved in stone and you'll never change a line or what ?

see my other coment below

sirmacik commented on 2010-04-29 07:03

Here You can find an updated (to latest version - 9.3.2-1) PKGBUILD:
http://aur.pastebin.com/6fLzfLGN

solstice commented on 2010-04-09 21:48

as all the comments are gone, I will repeat:
(1) all those return 1 are useless.
(2) there is a bug. it's
sed -i '/^Icon/s|AdobeReader9|acroread|' \
"$pkgdir/usr/share/applications/acroread.desktop"

Don't you ever notice the icon is missing in your menu ?