Package Details: adom-noteye 1.15.2-4

Git Clone URL: https://aur.archlinux.org/adom-noteye.git (read-only)
Package Base: adom-noteye
Description: roguelike game with a quest-centric, plot driven structure
Upstream URL: http://www.adom.de/home/index.html
Keywords: rogue
Licenses: custom: "adom"
Submitter: nuteater
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 10
Popularity: 0.258002
First Submitted: 2013-11-04 10:50
Last Updated: 2015-11-08 01:52

Latest Comments

TrialnError commented on 2016-07-23 19:21

It seems there is no public download currently.
The remaining download link requires an account on indiedb

Maksym commented on 2016-07-22 12:27

Seems package is outdated

==> Making package: adom-noteye 1.15.2-4 (Fri Jul 22 15:26:21 EEST 2016)
...
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading http://ams2.dl.dbolical.com/2015/08/23/adom_noteye_linux_ubuntu_64_r60_pub.tar.gz
Aborting...

val-amart commented on 2015-10-14 14:58

this is odd. lua51 from community repo *does* provide required libs and has not changed since 2013.

$ yaourt -Ql | grep liblua5.1.so.5.1
lua51 /usr/lib/liblua5.1.so.5.1
lua51 /usr/lib/liblua5.1.so.5.1.5
$ yaourt -Qi lua51 | grep -iE 'version|build'
Version : 5.1.5-4
Build Date : Sat 07 Dec 2013 12:51:55 PM EET

libncurses thing is on the libtinfo maintainer. he has moved this dependency between different packages that he maintains three times in the past couple of months, it appears to be in ncurses5-compat-libs now...

RazZziel commented on 2015-10-14 06:11

Dependency lua51 provides liblua5.1.so.5.1, but libnoteye.so needs liblua5.1.so.0

It also needs libncurses.so.5 which is not provided by any dep

TrialnError commented on 2015-10-05 14:15

Good, if it's doing that I will switch it back. Thanks for the intel

val-amart commented on 2015-10-03 23:22

please change the libtinfo-5 dependency back to libtinfo, it now provides the backwards-compatibility symlinks. libtinfo-5 doesn't even work as it requires ncurses<6.0 which doesn't exist AUR right now.

TrialnError commented on 2015-08-12 22:31

@val-amart: Wow.. long time conversation ;)
But thanks nontheless for the comment, If both versions can be installed side by side is a good thing. I will incorporate your changes

val-amart commented on 2015-08-10 15:53

@nuteater yes they seem to be mostly compatible, saves work both ways. there's a minor issue though: noteye and regular adom use different adom.kbd versioning scheme. here's a link to my bugreport: http://www.adom.de/forums/project.php?issueid=3790. basically this means that if you customise your keybindings, you would need to maintain two versions and copy over the one appropriate for your current client before firing it up. if you use default key bindings, you can ignore the startup message.

i've updated the pkguild i linked below to be based on your pre59 pkgbuild. here's just the patch if you are interested: https://www.yunak.eu/gene/pre59.patch

nuteater commented on 2014-05-25 09:46

I had to use some of the bundled libraries to get rid of a symbol lookup error for 'stdscr', but at last here is pre23 for you to enjoy!

nuteater commented on 2013-12-05 15:39

@val-amart: Are the configuration files and game saves also interchangeable? Installing both would be useful if there is no risk of conflicts.

All comments