Package Details: adwaita-qt 1.1.1-1

Git Clone URL: https://aur.archlinux.org/adwaita-qt.git (read-only, click to copy)
Package Base: adwaita-qt
Description: A style to bend Qt applications to look like they belong into GNOME Shell
Upstream URL: https://github.com/FedoraQt/adwaita-qt
Keywords: gnome qt theme
Licenses: GPL
Provides: adwaita-qt5
Submitter: jurf
Maintainer: iyanmv
Last Packager: iyanmv
Votes: 88
Popularity: 2.94
First Submitted: 2015-07-30 13:37
Last Updated: 2019-11-20 08:33

Dependencies (4)

Required by (2)

Sources (1)

Pinned Comments

major commented on 2019-06-07 14:33

Packages have been split. This package is intended for Qt5 applications. For Qt4 applications, have a look at this package.

Also, if you would like to use from the upstream directly have a look here.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

yochananmarqos commented on 2019-08-11 16:29

The upstream URL is now https://github.com/FedoraQt/adwaita-qt

major commented on 2019-07-29 16:01

v1.1.0 is up.

major commented on 2019-07-15 03:46

The package had to be downgraded from 1.0.90 to 1.0. I would like to apologize for the problems caused.

v1.0.90 and v1.0.91 are both pre-releases and cannot qualify as a release. Hence, the downgrade.

In order to downgrade the current build, it is recommended to use the PKGBUILD directly and then install it separately. How to do that? Follow this.

major commented on 2019-07-15 03:41

@ForeverZer0, you're right. 1.0 < 1.0.90 (the previous packaged version). However, v1.0.90 is a pre-release and it was my fault that I packaged it without having a proper look at it.

To downgrade the package, the package version had to be set as 1.0. Can you explain a bit more of what do you mean by "incrementing the minor revision part of the version ".

ForeverZer0 commented on 2019-07-15 02:09

Either way, the latest update does not seem to be versioned correctly, and is going to be interpreted as a lesser version than what is already installed.

Would not incrementing the minor revision part of the version be the proper course than resetting the minor part to a previous value? Or the latest release an actual regression to a lesser version?

major commented on 2019-07-14 19:26

@carloabelli v1.0.90 and v1.0.91 are both pre-releases and cannot be qualified as a release. This means they are still in a beta phase and may contain bugs. A two-year-old (v1.0) is necessary because it is a well-defined release. As soon as the pre-releases are marked as releases I will update the packages here.

carloabelli commented on 2019-07-14 18:49

Is there a reason this was moved to version 1.0 rather than 1.0.91? Seems that version 1.0 is over 2 years old.

major commented on 2019-06-17 14:59

@fikrillah sorry for replying so late. The notification email went directly to spam folder. It should not require qt4, as you can see from the above dependencies tab. Maybe you're running an older PKGBUILD. I would recommend you to clean your AUR Helper's cache. It might also solve the problem for PKGDEST. Do keep me posted.

fikrillah commented on 2019-06-12 12:00

i got this message: Could not find PKGDEST for: adwaita-qt

... and also why does it need qt4, it's for only qt5 right?

major commented on 2019-06-07 14:33

Packages have been split. This package is intended for Qt5 applications. For Qt4 applications, have a look at this package.

Also, if you would like to use from the upstream directly have a look here.