Package Details: aegisub-git 3.2.2.r293.0e8bc44-1

Git Clone URL: https://aur.archlinux.org/aegisub-git.git (read-only)
Package Base: aegisub-git
Description: A general-purpose subtitle editor with ASS/SSA support
Upstream URL: http://www.aegisub.org
Licenses: GPL, BSD
Conflicts: aegisub
Provides: aegisub
Submitter: alucryd
Maintainer: alucryd
Last Packager: alucryd
Votes: 23
Popularity: 0.054274
First Submitted: 2012-08-27 19:37
Last Updated: 2016-05-06 07:01

Latest Comments

alucryd commented on 2016-05-30 14:49

This is only a warning, the crash isn't due to this. Try parsing the logs in ~/.aegisub/log for clues, also try deleting ~/.aegisub and restart aegisub.

Sixsupersonic commented on 2016-05-26 13:23

It doesn't start for me and crashes with this.

08:19:10: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8)

tuankiet65 commented on 2016-04-30 03:24

Fair enough, I've asked them.
UPDATE: They did it, thanks for your suggestion!

alucryd commented on 2016-04-29 16:42

Or libass-git could provide libass.so.

tuankiet65 commented on 2016-04-29 13:31

Hello. Just want to say that in the dependencies list you should change 'libass.so' to 'libass' so that this package could be built with libass-git.

argo commented on 2015-05-26 10:13

Yes, confirming that.
Thx for the quick fix.

alucryd commented on 2015-05-26 08:28

Should build now.

argo commented on 2015-05-24 19:06

Does not build for me anymore, not sure if it's gcc 5 fault or something else to blame here.

alucryd commented on 2015-05-05 08:26

Nope, assdraw doesn't build, being 3 years old doesn't help. If somebody finds a way to make it compile, I'll gladly add it to this package.

Kcchouette commented on 2015-05-03 18:36

Has it the package assdraw compiled with aegisub?

alucryd commented on 2014-04-05 13:44

Just pushed a git ffms2 snapshot in [community] which will solve the audio issue.

argo commented on 2014-04-05 01:00

alucryd: np.
Another thing: AAC loading's currently broken with ffmpeg 2.2 and ffms 2.19, so for working audio we should either use ffms2-git or wait till FS#39748 got resolved.

argo commented on 2014-04-04 23:21

alucryd: np.
And another thing: looks like currently AAC's broken with ffmpeg 2.2 and ffms 2.19 (see https://github.com/FFMS/ffms2/commit/57ae96282eafec99153037423c33ebd29b40171a where it's got fixed) so the only way out till the next ffms release is to use ffms2-git from AUR.

alucryd commented on 2014-03-17 17:56

argo: Thx for the heads up, pkgbuild updated.

argo commented on 2014-03-13 23:01

Building is broken with current pkgbuild: '/home/user/yaourtbuild/aegisub-git/./PKGBUILD: line 29: cd: aegisub/aegisub: No such file or directory'
And i suspect that it's this commit's fault https://github.com/Aegisub/Aegisub/commit/33a4a056a42a9e9f27618a4c3d9bebba593f540e

alucryd commented on 2013-12-13 08:40

aegisub now requires wxgtk>=3.0.0, unfortunately wxgtk in our repos still hasn't been updated, so no nightlies before this happens.

sl1pkn07 commented on 2013-12-06 02:39

I know, the last bugreport was all a big failure on my part, I admit. I have spoken with who has given me (cutting off balls, because my friend is a jabber chat).

do not use the official PKGBUILDs not mean you can not help to resolve errors or reviews of the same

about version naming. I'm not one to criticize, if they have done so for nothing. just try, if possible, to conform to what they have agreed.

if he has taken it personally, sorry, not my intention

greetings

alucryd commented on 2013-12-05 19:25

It seems my deleting your last comment wasn't clear enough, so I'm gonna write it down so you can understand. Your comments are less than useless, please stop. And that also goes for dumb bug reports like the last one on our bug tracker.

Now if you think upstream is always right about versioning, I feel for you, all the more for something that goes like 'version that has nothing to do with current repo commit-branch that nobody cares about-at least some relevant sum'. If you're using your own PKGBUILD, why the fuck do you even care? Sure, you nagging me has nothing to do with me... And yeah, I sure hope you have nothing more to say, because I don't really take kindly to people wasting my time and any more comment will simply be obliterated.

sl1pkn07 commented on 2013-12-05 17:02

"What useful information does your pkgver provide?"

simple: use program naming for git releases (stable release use other version naming)

"feel free to use stable aegisub or write your own PKGBUILD"

since years ago

"Or better yet, nag upstream so they use proper git tags instead of nagging me."

this is applicable for you, no for me

Greetings and finish discussion(?)

PS: i see you don't like my gift :_(

sl1pkn07 commented on 2013-12-05 15:24

A little gift: http://i.imgur.com/ZGCaFiL.png

greetings :)

alucryd commented on 2013-12-05 08:40

sl1pkn07: So what? What useful information does your pkgver provide? Only the last commit sum... Mine provides the latest stable aegisub version, the last commit number and the last commit sum. Now if you think this pkgver is a complete heresy, feel free to use stable aegisub or write your own PKGBUILD. Or better yet, nag upstream so they use proper git tags instead of nagging me.

sl1pkn07 commented on 2013-12-04 19:19

but your code invents a version that does not match real version of program

program version:
http://i.imgur.com/oC2RjY0.png

your pkgver():
http://sl1pkn07.no-ip.com/paste/view/9198d094

my pkgver():
http://sl1pkn07.no-ip.com/paste/view/cff10786


6962 and 16cd907fe7482cb54a7374cd28b8501f138116be is a first commit/hash when move from SVN to GIT. version.sh use this for keep version naming

greetings

alucryd commented on 2013-12-04 17:28

sl1pkn07: Look at your command from version.sh, then at mine, I think it's pretty clear why.

alucryd commented on 2013-12-04 17:28

sl1pkn07: Look at your command from version.h, then at mine, I think it's pretty clear why.

sl1pkn07 commented on 2013-12-04 14:13

https://github.com/Aegisub/Aegisub/blob/master/aegisub/build/version.sh

then

pkgver() {
echo $(expr 6962 + $(git log --pretty=oneline 16cd907fe7482cb54a7374cd28b8501f138116be..HEAD 2>/dev/null | wc -l)).$(git symbolic-ref HEAD 2> /dev/null | sed 's|refs/heads/||g').$(git rev-parse --short HEAD)
}

greetings

sl1pkn07 commented on 2013-12-04 14:00

@Alucryd

why no use pkgver() with program version naming?

http://i.imgur.com/oC2RjY0.png

greetings

alucryd commented on 2013-09-15 22:38

Corubba: I know, I'm the one who updated it.

Corubba commented on 2013-09-15 16:07

ffmpegsource is now replaced by ffms2, please update the PKGBUILD accordingly.

alucryd commented on 2013-09-02 08:08

Fix backported in the [community] package. For those interested, I have set up an unofficial repository with nightly aegisub-git (and others) builds. See here: https://wiki.archlinux.org/index.php/Unofficial_User_Repositories#Unsigned_2
Repo name is [alucryd].

alucryd commented on 2013-09-02 08:08

Fix backported in the [community] package. For those interested, I have set up an unofficial repository with nightly aegisub-git (and others) builds. See here: https://wiki.archlinux.org/index.php/Unofficial_User_Repositories#Unsigned_2

argo commented on 2013-09-02 02:22

And it's finally fixed, thanks to Plorkyeran https://github.com/Aegisub/Aegisub/commit/1d7334c1290e9bab5a33890468c2b7216413115b ~

argo commented on 2013-08-22 19:59

...okay. On a more serious note - i reported that menu bug here http://devel.aegisub.org/ticket/1628 - in case that somebody actually cares about it.

alucryd commented on 2013-08-22 17:33

argo: Sorry I didn't update the package a split second after my patch was merged. Really.

argo commented on 2013-08-20 03:45

Could you please remove the patch since it's merged upstream and the building is (obviously) broken because of the duplicated code?

alucryd commented on 2013-08-12 23:32

Added a patch to fix building agains wxgtk 2.9.5 which will soon hit our repos. With this, it builds fine, but top menu is missing. I've created a ticket on the upstream bugtracker: http://devel.aegisub.org/ticket/1625#no1

sl1pkn07 commented on 2013-05-29 20:27

oks, thanks

alucryd commented on 2013-05-29 20:11

sl1pkn07: I don't think there's/can't find anything in our wiki about this. However, running namcap on your PKGBUILD and *.tar.xz packages will help you detect wrong permissions.
About shared libs, it depends on the distro, but in most cases either permission will do (see here for an in-depth explanation http://www.technovelty.org/linux/shared-libraries-and-execute-permissions.html).
As for 755 desktop files, this is useful if you wish to launch the program by double clicking its desktop file. Afaik namcap won't complain about this (that's why I didn't catch this one) and there's no absolute rule to have them at 644. Ultimately, it depends on the packager, I personally prefer to set 644 permissions on desktop files.

sl1pkn07 commented on 2013-05-29 19:29

@Alucryd:

any wiki or post in forum or "X" where I can look the rules to make file permissions in pkgbuild?

I'm looking my system, and I have losts of files with "strange" permissions (libs in /usr/lib without 755, .desktop in /usr/share/applications with 755 (like my report), etc

any info for that?

greetings

alucryd commented on 2013-05-29 18:49

sl1pkno7: No it isn't, I guess there's a problem with the shipped Makefile. I'll look into it as soon as I can. Thx for reporting.

sl1pkn07 commented on 2013-05-29 18:29

@Alucryd: this is normal?

-rwxr-xr-x 1 root root 346 may 26 01:57 aegisub.desktop (755)

greetings

alucryd commented on 2013-05-09 10:13

argo: It did indeed :)

argo commented on 2013-05-09 02:39

Maybe this commit https://github.com/Aegisub/Aegisub/commit/2db687cc314c8558684517e594f4a39fc36c4308 finally fixed the issue?

alucryd commented on 2013-04-04 17:59

Update for pacman 4.1 (does not solve the boost problem).

alucryd commented on 2013-02-24 12:21

I tried building boost 1.52 and 1.53 with -std=gnu++11 but both failed on my machine (1.53 fails even without enabling gnu++11 extensions). I don't really have time to debug right now but if someone feels up to it, here is a source tarball for the PKGBUILD: http://dl.dropbox.com/u/43076209/boost-c%2B%2B11-1.52.0-1.src.tar.gz

alucryd commented on 2013-02-22 22:52

You're right, I'll look into this.

MatejLach commented on 2013-02-22 20:43

"Plorkyeran wants to get rid of boost so I guess the best for now is to wait."

This could take a long time, but perhaps it will be possible to build boost using C++ 11 and publish it as a new package (boost++11?) and have it installed alongside regular boost.
(Thus not declaring provides 'boost' in the PKGBUILD).

alucryd commented on 2013-02-21 15:43

Thx for the link. I assume rebuilding boost as C++11 will break other packages. According to your link Plorkyeran wants to get rid of boost so I guess the best for now is to wait.

lae commented on 2013-02-21 15:01

Yeah, the ffms error happened because of an ffmpeg update on the 16th. Anyway, I asked Plorkyeran and he said that it's an issue with boost not being compiled as C++11. I also found this: http://forum.aegisub.org/viewtopic.php?f=10&t=65740

lae commented on 2013-02-21 01:46

Yeah, the ffms error happened because of an ffmpeg update on the 16th. Anyway, I asked Plorkyeran and he said that it's an issue with boost not being compiled as C++11. I also found this: http://forum.aegisub.org/viewtopic.php?f=10&t=65740

alucryd commented on 2013-02-18 22:12

Hmm, yeah I get that too, along with ffms errors, but I guess I'll get rid of the latter by rebuilding ffms. I'll update here when I know more.

lae commented on 2013-02-18 21:58

I'm running into the same issue, too.

sl1pkn07 commented on 2013-02-17 12:39

mm fail build in other instance

http://paste.ubuntu.com/1670612

have you this?

sl1pkn07 commented on 2013-02-17 11:32

okey, now build fine

greetings

alucryd commented on 2013-02-17 11:23

@sl1pkn07: The bug has been fixed upstream. You can try building again.

alucryd commented on 2013-02-16 23:44

@sl1pkn07: There doesn't seem to be a bug report about this on their bug tracker. I've filed one and will update as soon as I get an answer.

alucryd commented on 2013-02-16 20:20

@sl1pkn07: There doesn't seem to be a bug report about this on their bug tracker. I'll look into this tomorrow, don't have access to my arch box right now.

sl1pkn07 commented on 2013-02-16 18:29

fail build

http://paste.ubuntu.com/1664944

greetings

sl1pkn07 commented on 2012-12-31 06:58

according by this: http://devel.aegisub.org/ticket/1564

autogen.sh is deprecated (and fail if use new automake-1.13 from testing)

please use:

autoreconf -f
./configure --prefix=/usr --with-wxdir=/usr/include/wx-2.9 --with-wx-config=/usr/bin/wx-config-2.9

instead

greetings

alucryd commented on 2012-12-10 22:08

Change has been made upstream, it will now check for the correct lua library.

alucryd commented on 2012-12-10 21:42

Ok, turns out aegisub needs lua 5.1, not 5.2. Added it back and patched configure.ac to find the 5.1 lib instead of the 5.2 if you have both installed.

alucryd commented on 2012-12-10 17:58

Boost is now required, added dep. Also disable lua, doesn't build with it at the moment. I will file a bug report about that.

alucryd commented on 2012-08-27 19:44

@jackoneill: wxgtk is built with precompiled headers disabled, it seemed a good idea to do the same with aegisub (and it worked for a time), meaning people would recompile them with their own flags, but I guess it was a bad idea since they simply are not used at all... My bad.

Anyway thx for the tip, I've made a git package (https://aur.archlinux.org/packages.php?ID=62332), and removed the curl dependency, it compiled fine with precompiled headers. I'll ask a TU to merge this package into the git one.

jackoneill commented on 2012-08-27 19:20

Aegisub's source has moved to github: https://github.com/Aegisub/Aegisub
The servers hosting aegisub.org (including the svn repo) will shut down soon.

Regarding the dependency on curl: https://github.com/Aegisub/Aegisub/commit/54c4e4ab6e740d740fd94423d78c58349165e24f

Also, why on earth did you disable precompiled headers?

alucryd commented on 2012-08-03 09:11

Disabled GCC precompiled headers. Also, to build this latest svn, you'll need to recompile wxgtk2.9 from community with the --enable-compat28 switch.

alucryd commented on 2012-06-25 08:12

@vEX: The error is gone indeed.
I've changed the PKGBUILD to depend on the community wxgtk, also removed the automake patch as it is not needed anymore. Aegisub seems to work fine with wxgtk compiled without --disable-compat28, guess it's not a requirement anymore.

vEX commented on 2012-06-24 09:09

==> Leaving fakeroot environment.
==> Finished making: aegisub-svn 6918-1 (sun jun 24 11:07:39 CEST 2012)

It builds just fine for me and at starts as well so I guess they already fixed the problem you encountered.

alucryd commented on 2012-06-24 08:30

@jackoneill: Sure, will do as soon as I can.

jackoneill commented on 2012-06-24 07:45

Oops, forgot the link:
[1] http://devel.aegisub.org/

jackoneill commented on 2012-06-24 07:44

Please report any compilation errors, either at aegisub's trac[1], or in #aegisub on rizon.

alucryd commented on 2012-06-23 09:50

@sl1pkno7: I know, it came about a week ago into community, but I can't say it will work properly with aegisub yet because of a compilation error. Until then, I'll be using mine.

sl1pkn07 commented on 2012-06-22 10:57

wxgtk2.9 in community

http://www.archlinux.org/packages/?q=wxgtk2.9

greetings

jackoneill commented on 2012-05-13 06:35

Commenté par: sl1pkn07 sur Sat, 12 May 2012 20:55:54 +0000
> fail build for me
>
> http://paste.kde.org/476558
>
> greetngs

Temporary fix: http://sprunge.us/jaCi

alucryd commented on 2012-05-12 21:46

@vEX: Package updated, thx for the heads up!
@sl1pkno7: yeah, last time I tried (which would be 3 days ago) I got the same error, haven't had time to submit a bug upstream but feel free to do it, right now I only got a Windows so can't test any further.

alucryd commented on 2012-05-12 21:44

@vEX: Package updated, thx for the heads up!
@sl1pkno7: yea

sl1pkn07 commented on 2012-05-12 20:55

fail build for me

http://paste.kde.org/476558

greetngs

vEX commented on 2012-05-12 12:53

For the next PKGBUILD update you should require wxgtk >= 2.9.3 as it was bumped some time ago: http://devel.aegisub.org/changeset/6725

alucryd commented on 2012-04-16 07:58

@jackoneill: You're right, it is no longer a requirement. I've updated the PKGBUILD.

jackoneill commented on 2012-04-14 08:23

This package builds and runs without imagemagick.

alucryd commented on 2012-02-29 18:37

Bump version, also corrected dependencies and install file (thx to namcap).

alucryd commented on 2012-02-16 14:09

I took over the wxgtk package (thx to the aur mods who orphaned it). Now updated to the latest version. Tried to build aegisub, and got lua errors (works fine if you pass --disable-lua to ./autogen.sh).

alucryd commented on 2012-02-01 09:55

If using the extra repos, recent updates of libpng and libtiff require you to recompile wxgtk before building aegisub-svn. You can use this pkgbuild to build latest version of wxgtk-2.9, since the maintainer appears to be MIA : http://pastebin.com/emfsf8V5

alucryd commented on 2012-02-01 09:16

ffmpegsource stable version can be compiled again, switched dependencies.

alucryd commented on 2012-01-10 22:20

Yay, thx for the heads up. Confirmed, the video/audio loading bug is fixed too, may I say aegisub-svn is now fully functional again? So package updated (still no life signs from the owner of wxgtk-2.9 though).

jackoneill commented on 2012-01-10 21:29

Commenté par: Alucryd sur Mon, 09 Jan 2012 08:26:28 +0000
Just tested the latest revision, I got this: make[1]: *** [dialog_log.o] Error 1
Guess what we'll have to wait for another working revision.

Fixed now.

alucryd commented on 2012-01-09 08:26

Just tested the latest revision, I got this: make[1]: *** [dialog_log.o] Error 1
Guess what we'll have to wait for another working revision.

alucryd commented on 2012-01-08 19:51

Yes I saw that earlier today^^ I'll try to compile on my machine and see (for now you can append --holdver to makepkg with this pkgbuild, it worked for me on a x86_64 arch).

vEX commented on 2012-01-08 18:17

Your patches were merged in, yay!
http://devel.aegisub.org/ticket/1376#comment:2

Unfortunally the latest revision doesn't compile for me. :-/

alucryd commented on 2012-01-02 15:55

While you're at it, you can change the pkg number to 2.9.3 to get the latest wxgtk.

alucryd commented on 2012-01-02 15:54

At last a successful compilation, I made a set of patches to implement the DESTDIR parameter, will submit to the dev to remove them from the package. Aegisub works, but you cannot load both video and audio at the moment, clicking one of the tabs will mysteriously erase the loaded video or audio. BTW, I'll ask the maintainer of wxgtk-2.9 to add --disable-compat28 to .configure, in the meantime please edit his pkgbuild manually.

alucryd commented on 2012-01-02 15:04

Well, today I successfully compiled all the source code, however the DESTDIR argument isn't supported by their makefile, meaning I can't install in the pkgdir... I'm trying to find a workaround.

alucryd commented on 2011-12-23 09:07

A small update to say that most of the earlier problems were fixed (audio and lua compile fine). However, there is now a new linking error because of an undefined reference, hope it will be fixed soon. I'll update the pkgbuild when I get a successful compilation. Stay tuned.

alucryd commented on 2011-12-23 09:07

A small update to say that most of the earlier problems were fixed (audio and lua compile fine). However, there is now a new linking error because of an undefined reference, hope it will be fixed soon.

alucryd commented on 2011-11-11 19:56

Sorry I took so long to answer, unfortunately I can't test your pkgbuilds right now, I'm still awaiting a real internet connection and can't download large files like wxgtk. The problem undeniably comes from the source code, everything is not ported to wxgtk 2.9 yet, so unfortunately our best call is to wait for now. You can find builds for windows here http://plorkyeran.com/aegisub/, but they are horribly broken meaning the same will happen on arch even if we manage to compile successfully.

vEX commented on 2011-11-05 13:35

The following PKGBUILD fixes a whole bunch of compilation problems: http://pastebin.com/j8thg544
Unfortunally it dies horribly when trying to linking the executable. Perhaps someone else have any suggestions?

vEX commented on 2011-11-05 11:06

The following PKGBUILD will work with wxgtk-2.9 in AUR: http://pastebin.com/2UvUPn7S

However it dies in the compilation process for me so I guess trunk is a bit broken at the moment.

alucryd commented on 2011-10-03 21:10

Alright, I tried to compile the trunk, and horribly failed. As I said, it is a bit broken, not to mention I had to compile wxgtk 2.9.2, and the version from aur does not work because of the "can coexist with wxgtk" thing. I made my own version, but all audio player except pulse won't compile, auto4 is broken and an undeclared variable is here to deal the finishing blow. Will check later.

alucryd commented on 2011-10-01 08:57

That said, you're right about the fact that it can be confusing, so I might switch a bit earlier, when I have the time.

alucryd commented on 2011-10-01 08:52

Yes, that's exactly what I stated below. I plan to switch to 3.0 as soon as 2.1.9 is released, since 3.0 is not really usable at the time. Also I want pulseaudio because I can't listen to music while aegisub is using alsa, and I provide oss for nostalgic users. And I believe that building an already unstable package by nature is better using stable libraries. Now the choosing is up to you.

jackoneill commented on 2011-10-01 05:39

You're doing it wrong. This package is supposed to build the trunk version (what will become aegisub 3.0). Otherwise it's just a duplicate of aegisub-stable-svn with slightly different deps and features.

alucryd commented on 2011-09-30 22:57

Taking over the package. Differences with aegisub-stable-svn: pulseaudio and oss support, also relies on the stable version of ffmpegsource instead of the svn version.

Anonymous comment on 2010-11-11 00:12

Need to add intltool to dependencies:

...
checking for intltoolize >= 0.31 ...
You must have intltool installed to compile aegisub.
Get the latest version from
...

kevku commented on 2010-08-17 12:51

this is 3.0 dev version use at own risk