Package Details: aeskulap-bin 0.2.2_beta1-7

Git Clone URL: https://aur.archlinux.org/aeskulap-bin.git (read-only)
Package Base: aeskulap-bin
Description: Medical image viewer and DICOM client. Binary package and libs extracted from Debian.
Upstream URL: http://www.nongnu.org/aeskulap
Keywords: medical
Licenses: GPL
Conflicts: aeskulap
Provides: aeskulap=0.2.2_beta1
Submitter: swyter
Maintainer: swyter
Last Packager: swyter
Votes: 2
Popularity: 0.535433
First Submitted: 2015-12-04 14:15
Last Updated: 2015-12-04 14:19

Latest Comments

swyter commented on 2016-10-22 21:39

Probably glib or gtk incompatibilities as the Debian version is stuck at a fixed version while Arch keeps diverging as time goes by.

When I made the package it worked fine. Nowadays the best thing would be to bite the bullet and track down/compile the entire salad of dcmtk dependencies yourself.

I remember vividly how big of pain getting it to work was. I wasted an entire aftenoon. Good luck.

SwooshyCueb commented on 2016-10-22 18:40

Conflicts with libtiff4 and libwrap packages. Installing without the libtiff symlink and the bundled libwrap, then running the program gives me the following error:

aeskulap: /usr/lib/libtiff.so.4: no version information available (required by /usr/lib/libdcmimage.so.2)

(process:23277): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
Gnome::Conf::init()
fish: “aeskulap” terminated by signal SIGSEGV (Address boundary error)

The 'no version information available' messages can usually be safely ignored, but the glib/gobject assertion failure causes a segfault.

hellracer commented on 2016-01-01 20:20

I get following error message after installation:
aeskulap: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

If I link libpng.16.so to libpng12.so.0 following error message appears:
aeskulap: /usr/lib/libpng12.so.0: version `PNG12_0' not found (required by /usr/lib/libdcmimage.so.2)
aeskulap: /usr/lib/libtiff.so.4: no version information available (required by /usr/lib/libdcmimage.so.2)

Installing libpng12 from AUR fixes this error. Please add as dependency.
New error appearing:
aeskulap: /usr/lib/libtiff.so.4: no version information available (required by /usr/lib/libdcmimage.so.2)

(process:14220): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
Gnome::Conf::init()
Speicherzugriffsfehler (Speicherabzug geschrieben)

libtiff3 and libtiff4 from AUR are installed but not a requirement. Can you check the PKGBUILD?