Package Details: aftershotpro 2.4-1

Git Clone URL: https://aur.archlinux.org/aftershotpro.git (read-only)
Package Base: aftershotpro
Description: Professional Workflow and RAW Conversion
Upstream URL: http://www.aftershotpro.com/en/support/updates
Licenses: custom
Submitter: Carceri
Maintainer: Carceri
Last Packager: Carceri
Votes: 16
Popularity: 0.984857
First Submitted: 2015-08-12 08:52
Last Updated: 2016-01-25 20:25

Latest Comments

Carceri commented on 2016-05-13 08:33

@ava1ar I will merge this package to aftershotpro2.

ava1ar commented on 2016-05-13 08:10

I uploaded aftershot3 already - please check it out. Please note, looks like Coral dropped i386 support in version 3 - only 64-bit binaries are available.

@Carceri, I suggest you request merging of this package into aftershot2, so we will have aftershot2 and aftershot3 pacakges after it is completed. I am using 3rd version (already purchased upgrade), so I will maintain it.

Carceri commented on 2016-05-13 07:17

This is still the latest version of AfterShot Pro 2. Since version 3 requires a new license key many people might prefer to stick with version 2, so the right thing to do is probably to rename this package to aftershotpro2 and create a new aftershotpro3 package. Also, version 3 is, as far as I can see, only available in 64 bit versions.

greh commented on 2016-05-12 12:24

When will it be updated to version 3?

Moo-Crumpus commented on 2016-01-24 14:17

2.4.0.119

garibaldi commented on 2016-01-11 04:04

Note that these packages should be listed as dependencies:
- gstreamer0.10
- gstreamer0.10-base

Anonymous comment on 2015-10-23 12:28

It's not exactly about the package I think but someone may know what my problem is about... as my trial ended, I've followed the link and bought AfterShot (not Pro) 2. I've received license key but I can't type it into key fields... some letters, at some positions are just blocked to type in. Eg. I can't type "N" on second field but I can type it in first field... so the effect is that even as I copy-paste the key, it's not complete and the "unlock" key is not being activated. I have 30 days to return the key to Corel and cancel the order but I would like to use the software so if anyone knows what's wrong and if it's related to it being a Linux version, please let me know.

Carceri commented on 2015-10-15 09:43

I have added the 32-bit version. Unfortunately I cannot test it so feedback is welcome.

jose1711 commented on 2015-09-26 20:27

could you please add 32bit version? this is what it takes:

5c5
< pkgrel=1
---
> pkgrel=2
7c7
< arch=('x86_64')
---
> arch=('x86_64' 'i686')
11c11,12
< source=('http://dwnld.aftershotpro.com/updates/v2/2.2.1/AfterShotPro2_64bit.rpm' 'LICENSE.rtf')
---
> source_x86_64=('http://dwnld.aftershotpro.com/updates/v2/2.2.1/AfterShotPro2_64bit.rpm' 'LICENSE.rtf')
> source_i686=('http://dwnld.aftershotpro.com/updates/v2/2.2.1/AfterShotPro2_32bit.rpm' 'LICENSE.rtf')
25c26
< sha256sums=('b90ba08be6e419b1d1a6befcb8509257e2844b6c73efd1a70109e0be4e4591c6'
---
> sha256sums_x86_64=('b90ba08be6e419b1d1a6befcb8509257e2844b6c73efd1a70109e0be4e4591c6'
26a28,30
> sha256sums_i686=('2ac8a4b998b3a558af210c40edcfc2c93b4616d69cf31c95b4275d5cf98c0620'
> '45333ed8867b9f09226a4a19bf47ab966e3d735eb4f5dcbc4541a02eda88d2df')
>

thank you, jose

Anonymous comment on 2015-09-12 18:01

so how do I start it w/o the wrapper? I can't run it by desktop icon created by the installation process, I can't run it neither with "/opt/"AfterShot2(64-bit)"/bin/AfterShotPro" as it returns what it returned to @Moo-Crumpus:
"Fatal: This application failed to start because it could not find or load the Qt platform plugin "xcb"."
I have all Qt5 packages installed.

Carceri commented on 2015-08-27 09:15

You must run the program with the wrapper /usr/bin/AfterShot2X64? It sets LD_LIBRARY_PATH to use the included Qt5 libraries, as well as the Qt plugin path.

Gstreamer might be needed as a dependency though.

Carceri commented on 2015-08-27 06:42

Are you running the program with the wrapper /usr/bin/AfterShot2X64? It should set the LD_LIBRARY_PATH to use the included Qt5 libraries.

The gstreamer might be needed as a dependency though.

Moo-Crumpus commented on 2015-08-27 04:42

another one:
error while loading shared libraries: libgstreamer-0.10.so.0

Moo-Crumpus commented on 2015-08-26 16:02

Errors so far, 64bit
Fatal: This application failed to start because it could not find or load the Qt platform plugin "xcb".
error while loading shared libraries: libQt5Designer.so.5
error while loading shared libraries: libQt5Svg.so.5
error while loading shared libraries: libQt5WebKitWidgets.so.5

solved the last three ones installing
qt5-webkit qt5-svg qt5-tools

Moo-Crumpus commented on 2015-08-26 15:43

Trying to run
/opt/AfterShot2\(64-bit\)/bin/AfterShotPro

error while loading shared libraries: libQt5WebKitWidgets.so.5: cannot open shared object file: No such file or directory

Please check dependencies.