Package Details: afterstep 2.2.12-6

Git Clone URL: (read-only)
Package Base: afterstep
Description: A Window Manager based on NextStep Interface
Upstream URL:
Licenses: GPL
Submitter: ilpianista
Maintainer: FoolEcho
Last Packager: FoolEcho
Votes: 7
Popularity: 0.000000
First Submitted: 2010-11-13 14:44
Last Updated: 2016-08-16 16:32

Latest Comments

bidulock commented on 2016-08-16 04:09

Dependency 'dbus-core' needs to be changed to 'dbus' now.

FoolEcho commented on 2016-06-18 16:42

Ah yes I see... a problem from porting to gcc 5. :P
Fixed in the 2.2.12-5.


Chazza commented on 2016-06-18 09:27

Hi. Currently the build fails after many
warning: inline function ‘foo’ declared but never defined
type warnings.

You can fix this by adding:
export CFLAGS="-fgnu89-inline"
before calling configure.

FoolEcho commented on 2015-01-08 10:08

Mmmmm, true. Revised, thanks. :)

bidulock commented on 2015-01-08 02:51

Need to add 'staticlibs' to options=() now; otherwise, static libraries are removed by default.

FoolEcho commented on 2014-03-19 17:16

Done. Thanks. :-)

bidulock commented on 2014-03-19 06:24

AfterStep.desktop needs to go in /usr/share/xsessions rather than /etc/X11/sessions

FoolEcho commented on 2012-09-18 11:53

Adopted and patched for libpng 1.5.

ilpianista commented on 2010-11-13 14:44

* moved from [extra]