Package Details: air-video-server 2.4.6_beta3-8

Git Clone URL: https://aur.archlinux.org/air-video-server.git (read-only, click to copy)
Package Base: air-video-server
Description: A media server that can stream videos in almost any format from your PC to your iPhone, iPad and iPod touch
Upstream URL: http://www.inmethod.com/air-video/index.html
Licenses: custom
Submitter: biloky
Maintainer: biloky
Last Packager: biloky
Votes: 24
Popularity: 0.000000
First Submitted: 2010-03-08 08:33
Last Updated: 2015-07-01 07:12

Dependencies (9)

Required by (0)

Sources (11)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Anonymous comment on 2013-05-10 17:52

I've been looking for a way to configure this(since i dont know how to get a GUI to show), and cant seem to figure it out. I've checked in /etc/conf.d, but nothing's there for this...

blaenk commented on 2013-02-17 04:04

When you update to x264 20130206-1 be sure to rebuild this package before you use air-video. Otherwise, the thumbnail cache will become corrupted. The thumbnails you view within the window of upgrading x264 and re-building air-video-server will become corrupted from that point forward. What's more, the videos whose thumbnails become corrupt won't play at all. Thumbnails viewed after re-building air-video-server will work fine.

If this happens to you, after you rebuild this package simply delete the thumbnail database files from ~/.air-video-server and possibly also /root/.air-video-server (depending on which user runs air-video-server in your setup). This will force air-video to regenerate the thumbnail database.

Took me ages to figure out what was happening but after I realized it was probably a thumbnail cache issue, lsof quickly pointed me to the thumbnail caches to force regeneration.

blaenk commented on 2013-01-28 00:41

Just a heads up: Twice already, on headless servers, I've ended up needing the libcups package.

Thumbnails wouldn't load, and trying to view a video would give an error in the client, but no crash on the server. So I copied /etc/conf.d/air-video-server to ~/.air-video-server/air-video-server and ran air-video-server verbose. When viewing a video listing, this came up:

DEBUG: Thumbnail: Metadata:java.lang.UnsatisfiedLinkError: /usr/lib/jvm/ java-7-openjdk/jre/lib/amd64/headless/libmawt.so: libcups.so.2: cannot open shared object file: No such file or directory

Installing libcups resolved the issues. I imagine most people didn't encounter this issue because they already had libcups installed.

biloky commented on 2012-12-11 14:52

Package update (2.4.6-beta3_5):
1. added -Djava.awt.headless=true to java line in script (Thanks antoinemartin & discipulus)
2. added fontconfig to dependencies (Thanks discipulus)

Anonymous comment on 2012-12-03 04:08

Alright, I got it working. I had to add -Djava.awt.headless=true to the launch script (/usr/bin/air-video-server) and I needed to install fontconfig. Any chance you could add fontconfig to the dependencies list for those that are attempting to run this without a GUI? It would be helpful :-)

Anonymous comment on 2012-12-02 20:14

Can't get it working. I'm getting an error message about:
DEBUG: Thumbnail: Metadata:java.lang.RuntimeException: java.lang.NoClassDefFoundError: Could not initialize class java.awt.Toolkit

Any ideas?

biloky commented on 2012-09-30 13:35

@benwbooth: Finally migrated to pure systemd. Turns out, "Type=forking" is used for executables that are daemons in nature, ie. forks out after being run (eg. mysqld, httpd, etc), and not for regular executables like java, etc. Thanks for the heads up :)

jrussell commented on 2012-09-08 12:12

nevermind. Found it all in /etc/conf.d

jrussell commented on 2012-09-08 12:05

Could somebody tell me how to configure this? I cant seem to find a config file anywhere, Ive tried starting it as myself (jason), no config file in ~/.config, Ive run it as a daemon too, no luck.

xzy3186 commented on 2012-08-21 16:27

After recent update I found AVS stopped working on my laptop. Running
air-video-server in the terminal will return nothing (before there were
many debug messages showing up if I remembered correctly). When I launch
air-video from my iPhone, I can see the server but I can not play
anything as well as obtain thumbnail for any file. When I tried to play
a video, the app (iPhone) would show "unexpected error". Do you have any
idea to deal with it?