Package Details: airpwn 1.4-7

Git Clone URL: https://aur.archlinux.org/airpwn.git (read-only)
Package Base: airpwn
Description: A generic packet injection tool for 802.11 networks.
Upstream URL: http://airpwn.sourceforge.net
Licenses: GPL
Provides: lorcon-old-svn
Submitter: nofxx
Maintainer: larryhaja
Last Packager: larryhaja
Votes: 19
Popularity: 0.007303
First Submitted: 2008-02-04 14:02
Last Updated: 2016-01-02 03:30

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

vendforce commented on 2016-02-11 19:38

I used pacaur -S airpwn --force and it installed but I'm getting an error when typing airpwn in terminal

Segmentation fault (core dumped)

vendforce commented on 2016-01-25 13:39

Install error

error: failed to commit transaction (conflicting files)
airpwn: /usr/sbin exists in filesystem
Errors occurred, no packages were upgraded.

larryhaja commented on 2016-01-02 03:31

@test0, this has been fixed.

test0 commented on 2013-08-28 16:23

There is the problem: fake root is assigned only in package(), not build() (you can check it by launching makepkg with only 'id' commands in these functions and watch its output). So it can't access the 'pkg' directory during build: not 'make install' to it, nor make includes from it (-I).

Maybe this quick&dirty fix can help: http://pastebin.com/5xwh88gC

test0 commented on 2013-08-28 16:01

There is the problem: fake root is assigned only in package(), not build() (you can check it by launching makepkg with only 'id' commands in these functions and watch its output). So it can't access the 'pkg' directory during build: not 'make install' to it, nor make includes from it (-I).

test0 commented on 2013-08-28 16:00

There is the problem: fake root is assigned only in package(), not build(). So it can't access the 'pkg' directory during build: not 'make install' to it, nor make includes from it (-I).

larryhaja commented on 2013-01-06 04:53

Updated.

* Remove libcrypto patch
* Add libnl1 as a dependency
* Used internal lorcon package and removed it from the dependency list. Moved lorcon man page so it didn't conflict with man page from lorcon package
* Added !libtool to options
* Cleaned up the python version crud

Anonymous comment on 2012-03-26 20:08

Solution:
Install old version of lorcon manually.
svn co http://802.11ninja.net/svn/lorcon/branch/lorcon-old
cd lorcon-old && ./configure && make && sudo make install

Then run your usual "sudo yaourt -S airpwn" and edit the PKGBUILD by removing unsupported dependency "lorcon-old-svn".
Compile and install the package. It worked for me at least.

Stebalien commented on 2012-02-11 17:19

It won't build with the new lorcon2 (significant API change).

kang commented on 2012-02-11 17:06

require new deps:
:: Replace lorcon-old-svn with community/lorcon? [Y/n]
:: Replace pylorcon with community/python2-pylorcon? [Y/n]

All comments