Package Details: airvpn-git r260.bfecdbf-1

Git Clone URL: https://aur.archlinux.org/airvpn-git.git (read-only)
Package Base: airvpn-git
Description: AirVPN client "Eddie" based on OpenVPN
Upstream URL: https://airvpn.org/linux/
Keywords: openvpn vpn
Licenses: GPL3
Conflicts: airvpn, airvpn-beta-bin
Provides: airvpn
Submitter: Beini
Maintainer: Beini
Last Packager: Beini
Votes: 4
Popularity: 0.001280
First Submitted: 2015-09-26 00:30
Last Updated: 2016-10-08 11:14

Latest Comments

oberon2007 commented on 2017-10-20 09:51

updated package() :

package() {
cd "airvpn-client"
install -Dm755 "src/bin/$_pkgarch/Release/App.Forms.Linux.exe" "$pkgdir/usr/lib/AirVPN//AirVPN.exe"
install -Dm755 "src/bin/$_pkgarch/Release/App.CLI.Linux.exe" "$pkgdir/usr/lib/AirVPN/CLI.exe"
install -Dm644 "src/bin/$_pkgarch/Release/Lib.Common.dll" "$pkgdir/usr/lib/AirVPN/Lib.Common.dll"
install -Dm644 "src/bin/$_pkgarch/Release/Lib.Core.dll" "$pkgdir/usr/lib/AirVPN/Lib.Core.dll"
install -Dm644 "src/bin/$_pkgarch/Release/Lib.Forms.dll" "$pkgdir/usr/lib/AirVPN/Lib.Forms.dll"
install -Dm644 "src/bin/$_pkgarch/Release/Lib.Platform.Linux.dll" "$pkgdir/usr/lib/AirVPN/Lib.Platform.Linux.dll"
install -Dm644 "deploy/linux_$_pkgarch/libLib.Platform.Linux.Native.so" "$pkgdir/usr/lib/AirVPN/libLib.Platform.Linux.Native.so"
install -Dm755 "deploy/linux_$_pkgarch/update-resolv-conf" "$pkgdir/usr/lib/AirVPN/update-resolv-conf"
install -Dm755 "resources/debian/usr/bin/airvpn" "$pkgdir/usr/bin/airvpn"
install -Dm644 "resources/debian/usr/share/pixmaps/AirVPN.png" "$pkgdir/usr/share/pixmaps/airvpn.png"
install -Dm644 "common/cacert.pem" "$pkgdir/usr/share/AirVPN/cacert.pem"

cp "resources/debian/usr/share/applications/AirVPN.desktop" "$srcdir/airvpn.desktop"
desktop-file-install\
-m 644\
--set-comment="VPN service based on OpenVPN"\
--dir="$pkgdir/usr/share/applications/"\
--set-icon="/usr/share/pixmaps/airvpn.png"\
"$srcdir/airvpn.desktop"
}

oberon2007 commented on 2017-10-20 09:21

More changes are needed. I might share an updated PKGBUILD a little later...

oberon2007 commented on 2017-10-20 08:27

line 34 of PKGBUILD needs to be adjusted to:
xbuild /p:Configuration="Release" /p:Platform="$_pkgarch" src/Eddie2_VS2017_Linux.sln

plus the following changes needed in package() :
line 39:
install -Dm755 "src/bin/$_pkgarch/Release/App.CLI.Linux.exe" "$pkgdir/usr/lib/AirVPN//AirVPN.exe"

line 42:
install -Dm644 "src/bin/$_pkgarch/Release/Lib.Platform.Linux.dll" "$pkgdir/usr/lib/AirVPN/Lib.Platform.Linux.dll"

argymeg commented on 2017-03-29 09:53

As of the current revision (r371), airvpn builds fine but fails to launch with this error:

Unhandled Exception:
System.IO.FileNotFoundException: Could not load file or assembly 'Lib.Common, Version=2.12.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'Lib.Common, Version=2.12.0.0, Culture=neutral, PublicKeyToken=null'
[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'Lib.Common, Version=2.12.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'Lib.Common, Version=2.12.0.0, Culture=neutral, PublicKeyToken=null'

The pre-built package (airvpn-bin) works fine.

bepebe commented on 2016-12-31 08:33

@Beini - just an FYI
openvpn-2.4.0-2 breaks this install, cannot connect
Downgraded back to openvpn-2.3.14-1 and works fine

Beini commented on 2015-12-18 08:23

Hi @uncle . I can confirm it works fine with 4.2.1.

uncle commented on 2015-12-18 06:41

Greetings! Maintainer of the airvpn-bin and airvpn-beta-bin packages here, I had been working on putting together an airvpn-git package off and on for a while, but I see @Beini beat me to it :-D Has anyone tried running this package with mono 4.2.1? The airvpn binary packages won't work with mono 4.2.1, and it is necessary to downgrade to mono 4.0.4.