Package Details: akira-git r212.7bb31e7-1

Git Clone URL: https://aur.archlinux.org/akira-git.git (read-only)
Package Base: akira-git
Description: Native Linux App for UI and UX Design built in Vala and Gtk
Upstream URL: https://github.com/Alecaddd/Akira
Licenses: GPL3
Provides: akira
Submitter: flipflop97
Maintainer: flipflop97
Last Packager: flipflop97
Votes: 7
Popularity: 0.881144
First Submitted: 2018-03-19 21:53
Last Updated: 2019-02-21 10:45

Latest Comments

1 2 Next › Last »

btd1337 commented on 2019-10-08 20:58

../Akira/src/FileFormat/ZipArchiveHandler.vala:268.20-268.86: error: 1 extra arguments for `Archive.Result Archive.Read.read_data_block (out weak uint8[], out Archive.int64_t)'
            while (archive.read_data_block (out buffer, out buffer_length, out offset) == Archive.Result.OK) {
                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../Akira/src/FileFormat/ZipArchiveHandler.vala:269.49-269.54: error: Argument 1: Cannot convert from `void*' to `unowned uint8[]'
                if (extractor.write_data_block (buffer, buffer_length, offset) != Archive.Result.OK) {
                                                ^^^^^^
../Akira/src/FileFormat/ZipArchiveHandler.vala:269.21-269.78: error: 1 extra arguments for `ssize_t Archive.Write.write_data_block (uint8[], Archive.int64_t)'
                if (extractor.write_data_block (buffer, buffer_length, offset) != Archive.Result.OK) {
                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
../Akira/src/FileFormat/ZipArchiveHandler.vala:319.37-319.57: error: Argument 1: Cannot convert from `int64' to `Archive.int64_t'
                    entry.set_size (file_info.get_size ());
                                    ^^^^^^^^^^^^^^^^^^^^^
../Akira/src/FileFormat/ZipArchiveHandler.vala:321.37-321.40: error: Argument 1: Cannot convert from `int' to `Archive.FileType'
                    entry.set_perm (0644);
                                    ^^^^
../Akira/src/FileFormat/ZipArchiveHandler.vala:336.25-336.63: error: 1 extra arguments for `ssize_t Archive.Write.write_data (uint8[])'
                        archive.write_data (buffer, bytes_read);
                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation failed: 6 error(s), 0 warning(s)
ninja: build stopped: subcommand failed.
==> ERROR: Failed to build().

paco3346 commented on 2019-08-06 07:07

Just wanted to pop in and confirm that @jpcima's patch works beautifully.

jpcima commented on 2019-07-08 17:58

Hi. It needs the dependency elementary-icon-theme or icons will be missing. Also it needs a patch to permit the latest to build. This one has been suggested: https://github.com/akiraux/Akira/commit/854e0070cc9a3515950540036b34ece48004dee8.patch

jonian commented on 2019-05-25 19:07

Hi, please update the repository to https://github.com/akiraux/Akira.

gnacho commented on 2019-04-10 14:50

Any @admin to delete all this spam?

flipflop97 commented on 2019-02-21 11:40

Wat

flipflop97 commented on 2019-02-21 10:46

@alcom0rz

Added goocanvas as a dependency, thanks for noticing!

alcom0rz commented on 2019-02-20 19:53

Receiving the following error:

Dependency "goocanvas-2.0" not found, tried pkgconfig

flipflop97 commented on 2018-11-19 16:25

@btd1337 I've commented out the makepkg check for now so the package should build again.

btd1337 commented on 2018-11-18 08:05

Disable Vala Lint to build him: https://github.com/Alecaddd/Akira/issues/58