Package Details: akonadi-git r10357.7eb79ba-1

Git Clone URL: https://aur.archlinux.org/akonadi-git.git (read-only)
Package Base: akonadi-git
Description: PIM layer, which provides an asynchronous API to access all kind of PIM data. builds with PostgreSQL backend
Upstream URL: https://community.kde.org/KDE_PIM/akonadi
Licenses: LGPL
Conflicts: akonadi
Provides: akonadi
Submitter: None
Maintainer: None
Last Packager: jackrandom
Votes: 11
Popularity: 0.000076
First Submitted: 2010-11-16 11:03
Last Updated: 2016-01-27 11:09

Latest Comments

ImNtReal commented on 2016-06-21 18:02

Will you add akonadi-client to provides, so this can be installed without removing kdepim-runtime?

arojas commented on 2015-01-10 09:33

Fixed, thanks

anex commented on 2015-01-10 09:26

@ arojas , typo?

conflicts=("$_pkgname")

to

conflicts=("$_gitname")

anex commented on 2015-01-10 09:22

it already is

safaalfulaij commented on 2015-01-10 08:44

Add akonadi (https://www.archlinux.org/packages/extra/i686/akonadi/) as a conflict package...

sl1pkn07 commented on 2014-12-17 19:16

sed 's|${QT_PLUGINS_DIR}|${CMAKE_INSTALL_PLUGINDIR}|g' -i akonadi/src/qsqlite/CMakeLists.txt

and

-DINSTALL_QSQLITE_IN_QT_PREFIX=ON \
-DCMAKE_INSTALL_PLUGINDIR=lib/qt/plugins

no need anymore (swich to KDE_INSTALL_USE_QT_SYS_PATHS)

https://projects.kde.org/projects/kdesupport/akonadi/repository/revisions/d006a0f4402e2a8ca85b79de0fd0069e9d483dad

greetings

TZ86 commented on 2014-12-09 13:40

@arojas
Well, you have moved your kf5 packages to /usr already so there is no more sense to keep my in /opt.

arojas commented on 2014-12-09 09:37

Can this be merged in akonadi-git? Or is it still needed in /opt?

arojas commented on 2014-10-20 20:42

This has been ported to qt5, dependencies need to be updated

arojas commented on 2014-09-03 14:45

And now it's been merged in master again...

sl1pkn07 commented on 2014-08-28 14:07

kf5-akonadi-git: /opt/kf5/lib64/cmake/KF5Akonadi/KF5AkonadiTargets-release.cmake existe en el sistema de archivos
kf5-akonadi-git: /opt/kf5/lib64/cmake/KF5Akonadi/KF5AkonadiTargets.cmake existe en el sistema de archivos


conflicts with kdepimlibs-git

arojas commented on 2014-08-28 12:00

Hi, can you please switch to the frameworks branch? This is where development is taking place towards the future akonadi framework.

ilpianista commented on 2014-05-16 22:21

This package can be built without soprano

TZ86 commented on 2014-03-20 06:51

@ant32
Fixed.

ant32 commented on 2014-03-19 14:31

CMake Error at CMakeLists.txt:170 (message):
The command line XSLT processor program 'xsltproc' could not be found.
Please install xsltproc.

ant32 commented on 2014-03-13 05:27

please add libxslt to dependencies.

CMake Error at CMakeLists.txt:170 (message):
The command line XSLT processor program 'xsltproc' could not be found.
Please install xsltproc.

imraro commented on 2014-03-05 05:24

[ 83%] Building CXX object server/tests/unittest/CMakeFiles/akdbustest.dir/akdbustest_automoc.cpp.o
/var/abs/local/yaourtbuild/kf5-akonadi-git/src/build/server/tests/unittest/qrc_dbinitializertestdata.cpp:741:1: error: expected unqualified-id before ‘)’ token
)
^
server/tests/unittest/CMakeFiles/clientcapabilityaggregatortest.dir/build.make:94: recipe for target 'server/tests/unittest/CMakeFiles/clientcapabilityaggregatortest.dir/qrc_dbinitializertestdata.cpp.o' failed
make[2]: *** [server/tests/unittest/CMakeFiles/clientcapabilityaggregatortest.dir/qrc_dbinitializertestdata.cpp.o] Error 1
CMakeFiles/Makefile2:2153: recipe for target 'server/tests/unittest/CMakeFiles/clientcapabilityaggregatortest.dir/all' failed
make[1]: *** [server/tests/unittest/CMakeFiles/clientcapabilityaggregatortest.dir/all] Error 2
/var/abs/local/yaourtbuild/kf5-akonadi-git/src/build/server/tests/unittest/qrc_dbinitializertestdata.cpp:741:1: error: expected unqualified-id before ‘)’ token
)
^
server/tests/unittest/CMakeFiles/akdbustest.dir/build.make:94: recipe for target 'server/tests/unittest/CMakeFiles/akdbustest.dir/qrc_dbinitializertestdata.cpp.o' failed
make[2]: *** [server/tests/unittest/CMakeFiles/akdbustest.dir/qrc_dbinitializertestdata.cpp.o] Error 1
CMakeFiles/Makefile2:1944: recipe for target 'server/tests/unittest/CMakeFiles/akdbustest.dir/all' failed
make[1]: *** [server/tests/unittest/CMakeFiles/akdbustest.dir/all] Error 2
Makefile:126: recipe for target 'all' failed
make: *** [all] Error 2

Anonymous comment on 2011-09-26 13:23

Fixed, thanks emericn6k.

emericn6k commented on 2011-09-26 13:14

This package should conflict/provide with akonadi, adding the two following lines would be useful :

conflicts=('akonadi')
provides=('akonadi')

Anonymous comment on 2011-08-13 20:57

Thanks, I forgot about this package completely. I updated the PKGBUILD to install to /usr.

hunger commented on 2011-08-13 20:50

Why does this install into /opt/kde4? Kdepimlibs4-git can not pick it up there.

Other kde4 git aur packages are installing into /usr, so I do not see why this one installs into another place.

Anonymous comment on 2011-02-21 21:45

I removed it from the PKGBUILD. I didn't ship it with the package before, it must have been provided by some other package and it does not seem to be needed for proper build.

Anonymous comment on 2011-02-21 21:37

Could you be more specific about content of the shell script, please?

habarnam commented on 2011-02-21 21:37

I guess it's not needed for regular compile, but maybe it should be commented out.

habarnam commented on 2011-02-21 21:31

Please include /etc/profile.d/kde-git.sh in the package (preferably as an inline shell script).

Anonymous comment on 2011-02-09 07:11

Thanks Sevenseven, I updated the PKGBUILD

Sevenseven commented on 2011-02-09 03:24

For kde-git use this pkgbuild http://aur.pastebin.com/1dMuSYB7