Package Details: all-ada 1.0-1

Git Clone URL: https://aur.archlinux.org/all-ada.git (read-only, click to copy)
Package Base: all-ada
Description: A meta package which installs all Ada tools and components.
Upstream URL: None
Licenses: None
Submitter: charlie5
Maintainer: charlie5
Last Packager: charlie5
Votes: 2
Popularity: 0.001198
First Submitted: 2023-07-08 14:11 (UTC)
Last Updated: 2024-04-28 09:48 (UTC)

Pinned Comments

charlie5 commented on 2023-07-09 16:28 (UTC)

This package is available in the Arch Ada Repository.

https://wiki.archlinux.org/title/Ada

Latest Comments

1 2 Next › Last »

mindbound commented on 2023-07-19 19:59 (UTC)

Yes, works again, thanks!

charlie5 commented on 2023-07-19 19:59 (UTC)

@mindbound

Sorry. Forgot to restart it after a reboot. Should be ok now.

mindbound commented on 2023-07-19 19:54 (UTC)

Also, the Ada repository seems to be down again.

mindbound commented on 2023-07-17 07:11 (UTC)

@charlie5 Didn't help.

charlie5 commented on 2023-07-17 05:58 (UTC) (edited on 2023-07-17 05:58 (UTC) by charlie5)

@mindbound

Hi again,

Could you please try deleting ...

/var/lib/pacman/sync/ada.db
/var/lib/pacman/sync/ada.db.sig

... then ...

$ sudo pacman -Syu

... and let me know if it helps.

Thanks.

charlie5 commented on 2023-07-16 22:45 (UTC)

@mindbound

Very strange. I'm all out of ideas :).

At least, the package appears to work ok. Let me know if you find a way to rid the message.

mindbound commented on 2023-07-16 22:36 (UTC) (edited on 2023-07-16 22:37 (UTC) by mindbound)

@charlie5 Yeah, removed the package, cleaned the cache with pacman -Scc, reinstalled the package. When I run pacman -Syu after all that, it asks again about the replacement. It is just this one package, too, all the others in the all-ada meta don't act this way.

charlie5 commented on 2023-07-16 22:33 (UTC)

@mindbound

That is odd. Have you tried removing the package and reinstalling it ?

mindbound commented on 2023-07-16 22:31 (UTC)

It does keep asking me even after I tell it to do the replacement, yes. Everything seems to work, so technically not a big deal, but it is odd and I don't think I have seen this behaviour before.

charlie5 commented on 2023-07-16 21:23 (UTC)

@mindbound

You're welcome :).

I guess it's asking to replace 'gnatcoll-python', built from the AUR, with the package in the Arch Ada repository. Does it keep asking if you tell it to do the replacement ?

Not entirely sure. I'm pretty new to using a custom user repository.