Package Details: alot-git r3394.4a671186-1

Git Clone URL: https://aur.archlinux.org/alot-git.git (read-only, click to copy)
Package Base: alot-git
Description: terminal-based MUA for the notmuch mail system
Upstream URL: https://github.com/pazz/alot
Licenses: GPL3
Conflicts: alot
Provides: alot
Submitter: jokke
Maintainer: thegala
Last Packager: dcbaker
Votes: 4
Popularity: 0.195643
First Submitted: 2016-05-23 09:35 (UTC)
Last Updated: 2018-10-04 20:38 (UTC)

Latest Comments

aplund commented on 2021-02-14 09:01 (UTC)

python-service-identity should be an optional dep.

hcar commented on 2016-12-16 20:00 (UTC)

Please add python2-requests as a dependency.

Lokaltog commented on 2016-10-29 17:17 (UTC)

It seems the python2-magic package has changed name from Magic-file-extensions to file-magic, which breaks this package. This change resolves the issue for me: --- a/PKGBUILD +++ b/PKGBUILD @@ -33,7 +33,7 @@ build() { # "Magic-file-extensions", as opposed to the python-magic on pypi. The # result is that the alot executable can't find the module, so we patch # setup.py to fix the dependency: - sed -i -e 's/python-magic/Magic-file-extensions/' setup.py + sed -i -e 's/python-magic/file-magic/' setup.py python2 setup.py build make SPHINXBUILD=sphinx-build2 -C docs man html }

wlhlm commented on 2016-09-11 21:36 (UTC)

This also depends on python2-setuptools, otherwise running `alot` from a shell results in: $ alot Traceback (most recent call last): File "/usr/bin/alot", line 6, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources Thanks for packaging alot BTW!