Package Details: alsi 0.4.7-1

Git Clone URL: https://aur.archlinux.org/alsi.git (read-only)
Package Base: alsi
Description: ALSI: a configurable system information tool for Arch Linux. [Inspired by Archey]
Upstream URL: https://github.com/trizen/alsi
Keywords: ascii
Licenses: GPLv3
Submitter: trizen
Maintainer: trizen
Last Packager: trizen
Votes: 165
Popularity: 2.177073
First Submitted: 2010-10-04 18:06
Last Updated: 2016-02-02 13:25

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

trizen commented on 2015-05-31 12:45

Confirmed.

A quick workaround this issue is to replace the {PACKAGES => '...'} line inside ~/.config/alsi/alsi.output with the following line:

{COMMAND => ['%sPackages:%s %s', 'pacman -Q | wc -l']},

Chazza commented on 2015-05-31 12:31

I think there might be a small issue when it comes to finding the number of packages installed. On my main machine, alsi reports 890 packages installed whilst running: "pacman -Q | wc -l" returns 889.

trizen commented on 2014-05-18 23:22

A new version will come in a moment. :)

ddeeds commented on 2014-05-18 23:21

Updated PKGBUILD with RAM Patch included.

http://goo.gl/BazTgm

ddeeds commented on 2014-05-18 23:19

Updated Package with RAM Patch included.

http://goo.gl/BazTgm

Xorg commented on 2014-05-10 21:03

@farnsworth: Thanks for your good job. ;)

Rolinh commented on 2014-05-06 16:54

@trizen: why don't you patch alsi with farnsworth fix? Ram usage gets completely wrong otherwise.

steadybright commented on 2014-04-27 00:58

@farnsworth: It works for me as well (and with colored RAM output!). Thanks for the fix.

steadybright commented on 2014-04-27 00:56

@farnsworth: It works for me as well (and with colored RAM display!). Thanks for the fix.

mohlerm commented on 2014-04-18 15:07

Thanks for the fix, works here

farnsworth commented on 2014-04-13 09:34

In order to have a good used RAM value I've changed this in /usr/bin/alsi, lines 297/298 are now like these :

$freeram += $1 / 1024 if $. > 1 and $. != 3 and $ram_line =~ /$match_ram/o;
last if $. == 5;

I have excluded the 3rd line of meminfo and read one line further
Don't know if this is a good solution but it's working fine ;)
Max

steadybright commented on 2014-04-10 22:41

Thanks for the link. I'll check it out. Thanks for all of your help today.

trizen commented on 2014-04-10 22:15

Ah, I was almost sure that you will ask about this. It's not possible. :)
Well, it is, but you need to hardcode the color inside the alsi.output file.

Here is a working example: https://github.com/trizen/config-files/blob/master/.config/alsi/alsi.output

steadybright commented on 2014-04-10 21:38

Sorry, one more thing: how may I get the percetage color working again for the RAM usage? The "OTHER" case we're presently using for RAM usage does not employ this capability as is. Thanks!

steadybright commented on 2014-04-10 21:27

Thank you for your help! That was not intuitive to me.

trizen commented on 2014-04-10 21:07

Set: green => 50, yellow: 85, red: 100;

alsi does this:

if usage <= value_of(green):
use green
elsif usage <= value_of(yellow):
use yellow
elsif usage <= value_of(red):
use red

steadybright commented on 2014-04-10 20:18

@trizen, thanks, that got me Yellow.
In the alsi.conf, I've set green to => 0, yellow => 65, and red => 90. But all I get for partition usage in alsi is yellow. Could a .bashrc setting mess up these alsi colors?

trizen commented on 2014-04-10 18:45

Try to execute alsi with the argument '-u' or '-ub' (for bold usage colors). To make the option permanent, change the value of 'USAGE_COLORS' (or 'USAGE_COLORS_BOLD') to one (1) in ~/.config/alsi/alsi.conf.

steadybright commented on 2014-04-10 18:41

While I'm thinking of it, alsi's colored output (green, yellow, red) of memory/disk usage has not worked for me since installing. It works in archey and archey3, so I think there's a config issue with alsi. Any ideas?

steadybright commented on 2014-04-10 18:38

@trizen: That did the trick. Thanks.

trizen commented on 2014-04-10 17:43

@graysky: it's hard to add new partitions in alsi. the concept is broken by design, but you can add the following in ~/.config/alsi/alsi.output:
{OTHER => sprintf("%%sSWAP:%%s %dM / %dM (%d%%)",split(' ',`tail -1 /proc/swaps|awk '{print\$4/1024,\$3/1024,\$4/\$3*100}'`))},

@steadybright: you get a negative value for the used RAM because alsi thinks that: MemFree + MemAvailable + Buffers == $free_mem
which results in $free_mem being greater than MemTotal, which is wrong (however, this method used to be true once in the old days).

Using the 'free -m' may be a better solution.
Add the following line (and remove the old line {RAM => '...}) in ~/.config/alsi/alsi.output:
{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3,\$2,\$3/\$2*100}'`))},

To get the used RAM without the cached RAM, use:
{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3-\$7,\$2,(\$3-\$7)/\$2*100}'`))},

trizen commented on 2014-04-10 17:42

@graysky: it's hard to add new partitions in alsi. the concept is broken by design, but you can add the following in ~/.config/alsi/alsi.output:
{OTHER => sprintf("%%sSWAP:%%s %dM / %dM (%d%%)",split(' ',`tail -1 /proc/swaps|awk '{print\$4/1024,\$3/1024,\$4/\$3*100}'`))},

@steadybright: you get a negative value for the used RAM because alsi thinks that: MemFree + MemAvailable + Buffers == $free_mem
which results in $free_mem being greater than MemTotal, which is wrong (however, this method used to be true once in the old days).
Using the 'free -m' may be a better solution.
Add the following line (and remove the old line {RAM => '...}) in ~/.config/alsi/alsi.output:
{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3,\$2,\$3/\$2*100}'`))},

To get the used RAM without the cached RAM, use:
{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3-\$7,\$2,(\$3-\$7)/\$2*100}'`))},

trizen commented on 2014-04-10 17:41

@graysky: it's hard to add new partitions in alsi. the concept is broken by design, but you can add the following in ~/.config/alsi/alsi.output:

{OTHER => sprintf("%%sSWAP:%%s %dM / %dM (%d%%)",split(' ',`tail -1 /proc/swaps|awk '{print\$4/1024,\$3/1024,\$4/\$3*100}'`))},


@steadybright: you get a negative value for the used RAM because alsi thinks that: MemFree + MemAvailable + Buffers == $free_mem, which results in $free_mem being greater than MemTotal, which is wrong (however, this method used to be true once in the old days). Using the 'free -m' may be a better solution.
Add the following line (and remove the old line {RAM => '...}) in ~/.config/alsi/alsi.output:

{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3,\$2,\$3/\$2*100}'`))},

To get the used RAM without the cached RAM, use:

{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3-\$7,\$2,(\$3-\$7)/\$2*100}'`))},

trizen commented on 2014-04-10 17:40

@graysky: it's hard to add new partitions in alsi. the concept it's broken by design, but you can add the following in ~/.config/alsi/alsi.output:

{OTHER => sprintf("%%sSWAP:%%s %dM / %dM (%d%%)",split(' ',`tail -1 /proc/swaps|awk '{print\$4/1024,\$3/1024,\$4/\$3*100}'`))},


@steadybright: you get a negative value for the used RAM because alsi thinks that: MemFree + MemAvailable + Buffers == $free_mem, which results in $free_mem being greater than MemTotal, which is wrong (however, this method used to be true once in the old days). Using the 'free -m' may be a better solution. Add the following line (and remove the old line {RAM => '...}) in ~/.config/alsi/alsi.output:

{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$2,\$3,\$3/\$2*100}'`))},

To get the used RAM without the cached RAM, use:

{OTHER => sprintf('%%sRAM:%%s %dM / %dM (%d%%)', split(' ', `free -m|head -2|tail -1|awk '{print\$3-\$7,\$2,(\$3-\$7)/\$2*100}'`))},

steadybright commented on 2014-04-10 16:19

1st three lines of meminfo:
MemTotal: 3948296 kB
MemFree: 3380892 kB
MemAvailable: 3621028 kB
It looks as I would expect.
htop, archey, and archey3 all agree within a few MB; only alsi differs.
Am I missing something obvious?

steadybright commented on 2014-04-10 16:18

1st three lines of meminfo:
MemTotal: 3948296 kB
MemFree: 3380892 kB
MemAvailable: 3621028 kB
It looks as I would expect.
htop, archey, and archey3 all corroborate with each other.
Am I missing something obvious?

steadybright commented on 2014-04-10 16:17

1st three lines of meminfo:
MemTotal: 3948296 kB
MemFree: 3380892 kB
MemAvailable: 3621028 kB
It looks as I would expect. htop, archey, and archey3 all corroborate with each other.

trizen commented on 2014-04-10 16:12

It may be a kernel bug. See the first three lines of /proc/meminfo.

steadybright commented on 2014-04-10 16:11

alsi is displaying negative RAM usage on two different systems.
1. Arch Linux x86_64 3.14.0-4 (alsi shows -3463 MB / 3855 MB (-89%))
2. Arch Linux armv5tel 3.14.0-2-ARCH (alsi shows -31 MB / 245 MB (-12%))
alsi 0.4.5-1
perl 5.18.2-2
perl-data-dump 1.22-1
It worked fine on both machines until earlier this week.

steadybright commented on 2014-04-10 16:06

alsi is displaying negative RAM usage on two different systems.
1. Arch Linux x86_64 3.14.0-4 (alsi shows -3463 MB / 3855 MB (-89%))
2. Arch Linux armv5tel 3.14.0-2-ARCH (alsi shows -31 MB / 245 MB (-12%))
I'm using alsi 0.4.5-1, and it worked fine on both machines until earlier this week.

graysky commented on 2013-10-10 15:46

Can you an an option to display swap partition usage?

nichdel commented on 2013-10-07 01:09

@tizen bspwm isn't in the alsi.wm file. The process name is simply bspwm. I added it myself, just thought it'd be nice to add it upstream.

acgtyrant commented on 2013-08-18 11:38

@tizen Thank you for your alsi, but could you add terminal info in alsi please? If so, it will be more better than alsi at all!

sergey_klay commented on 2013-07-28 07:16

@fylou You need install 0.4.5 version

trizen commented on 2013-06-24 11:24

alsi doesn't have any other files, so 'rm /bin/alsi' should be enough.

fylou commented on 2013-06-24 09:39

Indeed, it is enough in this particular case.

trizen commented on 2013-06-24 09:35

alsi doesn't have any other files, so 'rm /bin/alsi' should be enough.

fylou commented on 2013-06-24 09:33

@Trizen My version is 0.4.4 and is in /bin/ instead of /usr/bin. Since the command pacman -Rscn alsi didnt remove this version in /bin, how should I proceed to make it in a clean way? Thanks for your help.

trizen commented on 2013-06-24 09:25

@fylou - Make sure you have the latest version installed (0.4.5), and execute 'which alsi'. If it doesn't say '/usr/bin/alsi', then remove the other alsi.

fylou commented on 2013-06-24 09:22

@kr3ck3n I always get these extralines:
Smartmatch is experimental at /usr/bin/alsi line 293.
Smartmatch is experimental at /usr/bin/alsi line 663.
after following your procedure.

trizen commented on 2013-06-08 20:52

@lordmocha - you need to put the exact name of the xmonad process name which appears in output printed by the execution of the PS_COMMAND. If it doesn't appears in 'ps x', change PS_COMMAND to 'ps -A' and add the appropriate 'process name'=>'WM name' into the alsi.wm file.

lordmocha commented on 2013-06-08 04:15

i get "window manager: unknown" i am running xmonad, and i tried putting 'xmonad-x86_64-linux' in the asli.wm file, then alsi --update-config, but it still says unknown

TanaseButcaru commented on 2013-06-01 14:08

@DaBungalow, @graysky I was facing the same problem + arch logo distorted.
Just do a $ pacman -Rscn alsi, delete alsi directory from your home/.config and then reinstall the package.

DaBungalow commented on 2013-05-31 04:59

@graysky

I am having the same trouble. It is rather annoying.

trizen commented on 2013-05-27 03:35

Perl 5.18 is the disappointing reason. Updated.

graysky commented on 2013-05-26 22:00

All of a sudden, I'm getting the following output before the expected:

% alsi -a -ub -b
Smartmatch is experimental at /usr/bin/alsi line 293.
Smartmatch is experimental at /usr/bin/alsi line 663.

...

Seems to be recent (last week for sure). Others?

Anonymous comment on 2013-02-28 20:37

Greetings. For some reason in the latest Gnome release, alsi is reporting that the Window Manager is unknown. Anything I can do on my end to fix that? Or to temporarily just manually insert it?

Thanks. :-)

trizen commented on 2013-02-28 08:29

@kentarch - I will add it, but I would like to know the process name. Thanks

kentarch commented on 2013-02-28 05:36

I'd appreciate it if you could add the MATE desktop environment to alsi.de.

trizen commented on 2013-02-20 06:32

Updated.

KaiSforza commented on 2013-02-20 06:23

This should really be called `alsi-git` if you're going to make it use git. Add tags and make it a stable snapshot, but please follow the AUR naming conventions.

archerix commented on 2013-02-18 00:59

@Trizen thanks man.. :)

trizen commented on 2013-02-17 14:11

@archerix - Ups, sorry about that. Fixed in git.

archerix commented on 2013-02-17 14:00

@Trizen do you know why my alsi became like this?

http://i50.tinypic.com/14cwt3m.png

How can I make it looks like 'normal' again?

sl1pkn07 commented on 2013-01-24 16:02

oh! tanks

/me autoslaps

trizen commented on 2013-01-24 13:43

Hi, sl1pkn07.

There are two solutions:

1. 'alsi -l'
2. Inside the file '~/.config/alsi/alsi.logo' you can specify a longer ascii logo and execute 'alsi -f'.

sl1pkn07 commented on 2013-01-24 13:36

hi. have a little problem

i have +10Hdds/partitions, but only show info for 6. howto show info for all partitions?

http://wstaw.org/m/2013/01/24/plasma-desktopq15414.png

greetings

graysky commented on 2012-12-05 01:06

@Trizen - Nice, both of your suggestions fixed my issues. Perhaps change in upstream code?

trizen commented on 2012-12-04 22:09

@graysky - Not sure, but try to append "&>/dev/stdout" to the DF_COMMAND in ~/.config/alsi/alsi.conf
Something like this:
DF_COMMAND => "df -Th -x sys -x tmpfs -x devtmpfs &>/dev/stdout",

For the second issue, try to change the PS_COMMAND, from "ps xc", to "ps -A". Also, make sure that the LXDE process name is included in ~/.config/alsi/alsi.de .

graysky commented on 2012-12-04 22:02

@Trizen - Also noticed that the 'Desktop Environment' comes up as 'unknown' if the user is not in X. For example, if I come in via ssh to my server, although LXDE is up and running, it is 'unknown' for my ssh user.

graysky commented on 2012-12-04 22:00

@Trizen - I get an odd error (harmless) when using 0.4.4:

% alsi -a
df: ‘/home/facade/.gvfs’: Transport endpoint is not connected
df: ‘/run/user/1001/gvfs’: Permission denied

daimonion commented on 2012-12-03 19:10

Trizen, I did it like this:
{COMMAND => ["%sEmails:%s %s", q(cat /var/spool/mail/user | grep 'From ' | wc -l)]},
Thanks for the hint. I didn't know we can use custom commands.

trizen commented on 2012-12-02 13:56

Thanks maggie. Unfortunately, partitions can't be added, nor customized. Anyway, the newest version should fix your issue. Please let me know if it works for you.

@Demon: I'm not sure how that file looks like. There is a COMMAND option for the .output configuration.
You might want to try something like this:
{COMMAND => ["%s# of recieved emails:%s %s", q(perl -nE'/^From: /&&++$x}{say$x'</var/spool/mail/user)]},

maggie commented on 2012-12-01 23:36

This is a great util. Can someone explain to me how to add partitions to the display?

df -Th -x sys -x tmpfs -x devtmpfs
Filesystem Type Size Used Avail Use% Mounted on
rootfs rootfs 12G 1.3G 9.5G 12% /
/dev/sda3 ext4 12G 1.3G 9.5G 12% /
none vboxsf 1750G 426G 324G 24% /mnt/data
none vboxsf 14G 172K 14G 1% /mnt/inbox

I see in ~/.config/alsi/alsi.output there is a {PARTITIONS => '...'},

I do not understand what to put in there. I want to add:

/mnt/data
/mnt/inbox

Thanks you.

daimonion commented on 2012-10-05 18:22

May I suggest a "# of recieved emails" line? For me it would be enough if alsi could read the number of unread email messages from my /var/spool/mail/user file.

Anonymous comment on 2012-09-09 20:51

This is great, works better than both archey and archey3 for me (in archey the CPU: output wrapping/spacing is all messed up)

chelqo commented on 2012-08-22 20:06

I hope these additions will please you:
https://dl.dropbox.com/s/alg6lsyrrl40a83/alsi-0.4.3-2.src.tar.gz

With these suggestions are incorporated:
* You can use "rc.d {start|stop} alsi" for change the /etc/issue file (now requires "lsb-release")
* root alsi.output file (for /etc/issue)
* /usr/share/licenses/alsi/COPYING file is generated

trizen commented on 2012-08-11 09:49

For configuration help, please see: http://trizenx.blogspot.ro/2012/08/alsi.html

Anonymous comment on 2012-08-11 03:20

Archey has Evolved!!! Thanks a lot works great :D

Anonymous comment on 2012-08-01 15:07

Is there a way that we can have alsi output in more color options?

- Great package btw, love it over archey.

Anonymous comment on 2012-04-17 11:13

That works - thanks!

trizen commented on 2012-04-16 21:09

trizen[~]% cat ~/.config/alsi/alsi.conf | grep -n DF_COMMAND
9: 'DF_COMMAND' => 'df -Th -x sys -x tmpfs -x devtmpfs &>/dev/stdout',

Anonymous comment on 2012-04-16 20:55

OK...I am having problems locating the DF_COMMAND in alsi.conf
Do you have a line number?
Please forive my stupidity but I do not see where to insert '&>/dev/stdout'

trizen commented on 2012-04-16 20:24

Hmm... Try to append '&>/dev/stdout' at the DF_COMMAND into alsi.conf file.

Anonymous comment on 2012-04-16 20:19

df: '/root/.gvfs': Permission denied
How do I fix this?
Otherwise...very nice work.

daimonion commented on 2011-11-06 11:12

Works! Thank you!

trizen commented on 2011-11-06 11:05

No, the problem was comma used instead of point. Fixed.

daimonion commented on 2011-11-06 10:45

$ df -Th
Filesystem Type Size Used Avail Use% Mounted on
udev devtmpfs 10M 0 10M 0% /dev
run tmpfs 10M 260K 9,8M 3% /run
/dev/disk/by-label/arch ext4 9,9G 5,5G 4,0G 59% /
shm tmpfs 1006M 0 1006M 0% /dev/shm
tmpfs tmpfs 1006M 164K 1005M 1% /tmp
/dev/sda1 ext4 54M 10M 44M 19% /boot/grub
/dev/sda3 ext4 19G 7,0G 12G 38% /home
/dev/sda5 xfs 44G 40G 4,4G 91% /mnt/media
/dev/sdb1 xfs 80G 75G 5,3G 94% /mnt/video

I thought it has something to do with my root filesystem designated by label, so I put this in the script:
"df -Th -x sys -x tmpfs -x devtmpfs | grep -v arch|" instead of "df -Th|", but it doesn't change anything.

trizen commented on 2011-11-06 09:37

@Demon - What is the output of 'df -Th'?

daimonion commented on 2011-11-06 00:12

Also, how to display all partitions? Only grub partition is shown.

daimonion commented on 2011-11-05 23:27

Hi!

With processors with two cores this happens: http://pastebin.com/XRTUvBsW (notice extra "model name" line through the middle). I can fix this by commenting line 367:

#$cpu = join('', grep { substr($_, 0, 10) eq 'model name' } <CPU>);

trizen commented on 2011-08-14 17:20

@nankura - by adding 'alsi' to the '~/.bashrc' should fix the problem.

trizen commented on 2011-08-14 17:13

@nankura - adding 'alsi' to the '~/.bashrc' should fix the problem

Anonymous comment on 2011-08-14 17:05

Hey guys

i tried adding this to auto start with KDE Konsole by adding -c alsi to the default profile and it crashs konsole

It starts up then just vanishs

It works fine when its not in the profile and just typing alsi

trizen commented on 2011-08-14 16:54

No problem. The speed has been improved a little bit, too. :)

graysky commented on 2011-08-14 16:37

Nice, trizen. Works again. Thanks for the effort, this util rocks.

trizen commented on 2011-08-14 13:40

Should be fixed now. Doesn't executes anymore the 'uptime' program, but reads the uptime value from '/proc/uptime'.

graysky commented on 2011-08-14 10:25

Now I get, "unknown" for uptime.

> OS: Arch Linux i686
> Hostname: reborn
> Kernel: 2.6.32-lts
> Uptime: Unknown
> Packages: 531
> CPU: AMD Athlon(TM) XP 2100+
> RAM: 232 MB / 499 MB
> Boot: 18M / 61M (31%) (ext2)
> Data: 340G / 439G (79%) (ext4)
> Mnt: 340G / 439G (79%) (ext4)
> Root: 4.0G / 20G (22%) (ext4)

trizen commented on 2011-08-12 15:40

@graysky - please try and tell me if the uptime is working now: http://trizen.googlecode.com/files/alsi-test01

trizen commented on 2011-08-09 07:01

I still don't know where is the problem, but I'll try to fix it soon as I come home from vacation.

graysky commented on 2011-08-09 06:15

Just rebooted...

$ uptime
02:14:41 up 1 min, 3 users, load average: 0.20, 0.07, 0.03

trizen commented on 2011-08-09 05:48

Hmm... Execute 'uptime' and write here the output, please!

graysky commented on 2011-08-08 20:18

...it does work if I comment out the uptime report in the config file but that sucks :)

graysky commented on 2011-08-08 20:14

@trizen - tried that but no change...??

trizen commented on 2011-08-08 06:01

Delete your ~/.alsirc and execute 'alsi' to create a new configuration file.

graysky commented on 2011-08-07 22:43

Use of uninitialized value $uptime in concatenation (.) or string at (eval 17) line 1, <RC> line 58.

trizen commented on 2011-08-01 12:17

Fixed.

Jristz commented on 2011-07-31 19:08

Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 129.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 132.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 135.

for me and I have a ~/.gtkrc-2.0 and gtk1/2/3 installed...

trizen commented on 2011-07-31 15:25

I will fix this issue soon, but a temporary fix is to comment the 'use warnings' line in /usr/bin/alsi.
This is because ~/.gtkrc-2.0 is missing.

trizen commented on 2011-07-31 15:22

I will fix this issue soon, but a couple temporary fixes is to comment the 'use warnings' line in /usr/bin/alsi or comment three lines from ~/.alsirc which contains 'if ${font_name,gtk_theme,icon_theme}'.
This is because ~/.gtkrc-2.0 is missing.

Anonymous comment on 2011-07-31 12:25

http://img845.imageshack.us/img845/8751/screenshot0731201103233.png
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 147.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 150.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 153.

Anonymous comment on 2011-07-13 16:58

Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 129.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 132.
Use of uninitialized value in substitution iterator at /usr/bin/alsi line 546, <RC> line 135.

graysky commented on 2011-05-30 13:25

Small bug report: I don't think the -r switch or the -w switch generates a two-tone output of the logo like other colors (maybe just my monitor)?

Feature requestion: Is there any thing you can do to vertically center the output of the data with respect to the logo displayed? For example, the first data field is displayed at the same level as the first line of the logo below leaving, in this case, an extra 9 lines of "white" space below. Can you make your script center the data block leaving like 4 lines above and 5 lines below or something like that?

+ OS: Arch Linux i686
# Hostname: reborn
### Kernel: 2.6.32-lts
##### Uptime: 1 day & 1:33
###### Packages: 568
; #####; RAM: 171 MB / 499 MB
+##.##### Boot: 15M / 61M (26%) (ext2)
+########## Data: 330G / 439G (76%) (ext4)
#############; Root: 4.1G / 20G (23%) (ext4)
###############+
####### #######
.######; ;###;`".
.#######; ;#####.
#########. .########`
######' '######
;#### ####;
##' '##
#' `#

trizen commented on 2011-05-29 22:32

You're welcome!

graysky commented on 2011-05-29 22:12

Excellent dude! Great job and thanks!

trizen commented on 2011-05-29 21:49

Done... :) (at least I hope so)

graysky commented on 2011-05-29 20:09

Dude, this is killer. Thanks for the rapid implementation - it looks beautiful!

1) Can you center the output vertically around the Arch logo somehow?
2) Can apply the green/orange/red color scheme of the numerator of the RAM (in other words when memory is <50 % = green and 51-85 = orange and >86 red)?
3) I noticed ~/.alsi but it seems to contain the arch logo. I was thinking you could define a set of variables the user can comment or uncomment which correspond to the various data displayed such as OS, hostname, kernel, shell, uptime, packages, etc.

Keep up the great work! I really need to learn perl...

graysky commented on 2011-05-29 19:57

Dude, this is killer. Thanks for the rapid implementation - it looks beautiful!

Two questions:

1) Can you center the output vertically around the Arch logo somehow?
2) I noticed ~/.alsi but it seems to contain the arch logo. I was thinking you could define a set of variables the user can comment or uncomment which correspond to the various data displayed such as OS, hostname, kernel, shell, uptime, packages, etc.

Keep up the great work (I really need to learn perl).

graysky commented on 2011-05-29 19:54

Dude, this is killer. Thanks for the rapid implementation - it looks beautiful.

trizen commented on 2011-05-29 19:08

Thank you graysky!
Here is a screenshot with the newest features: http://i55.tinypic.com/2mdp7dc.jpg
and here is the script for testing: http://trizen.googlecode.com/files/alsi-testing
Let me know if I missed something or something is broke...

graysky commented on 2011-05-29 13:35

Excellent piece of code! Much faster than either archey or archey3 on my systems.

Feature request #1: Red/Yellow/Green colors for RAM, Filesystem readout based on their usage. For example (be creative here this is just food for though):

Green: 0-66 %
Orange: 67-85 %
Red: 86-10 %

Feature request #2: Add a switch that produces the archey logo.
Feature request #3: add support for a custom list of data to be displayed stored in ~/.alsi

Again, GREAT job with this!

trizen commented on 2011-03-28 10:54

Sure Meyithi: http://trizen.googlecode.com/files/alsi-0.1.15.tar.gz

Anonymous comment on 2011-03-28 08:16

Is there a link anywhere to the previous Alsi? I'm not keen on the font/gtk/icon readout as I use a tiling wm and the information is useless, I also miss the cpufreq readout.

Anonymous comment on 2011-02-17 16:12

Works much better than archie and archie3. Thank you.

bendersteed commented on 2011-01-22 02:15

Works fine. Thank you.

trizen commented on 2011-01-20 03:42

Fixed...

trizen commented on 2011-01-20 03:32

@bendersteed - Can you give me the output of 'ps x | grep bash'? Thanks...

bendersteed commented on 2011-01-19 17:23

On the last update my shell is recognised as "jsh"(is this java shell?). Not a major thing but still somehow annoying. I am surely working with bash shell and it was recognised perfectly till I updated.

trizen commented on 2010-11-08 17:15

Pana la urma am lasat ambele logo-uri. Default a ramas tot cel vechi, iar cel nou poate fi activat prin argumentul "-n".

trizen commented on 2010-11-07 17:23

Done...

JokerBoy commented on 2010-11-07 16:52

da, dar si:

-if(`uname -r` =~ /ARCH/){
+if(-e '/etc/arch-release') {

pt cei care folosesc un kernel custom.

trizen commented on 2010-11-07 16:37

Ceva de genu asta? http://trizen.go.ro/files/alsi-test

JokerBoy commented on 2010-11-07 15:50

ar fi ok daca ai aplica asta :p logo-ul l-am luat din screenfetch, mi s-a parut mai ok.

http://punctweb.ro/aur/patches/alsi.diff

Anonymous comment on 2010-10-19 22:54

I just wanted to thank you for this splendid little package. :-)

trizen commented on 2010-10-12 12:43

Added...

Usage: "alsi -s" or "alsi [color] -s" (alsi -r -s)

masterkorp commented on 2010-10-12 12:25

Hello, can you add the functionally to take screenshots ?