Package Details: amarok 2.9.0.r367.fc370bbebf-1

Git Clone URL: https://aur.archlinux.org/amarok.git (read-only)
Package Base: amarok
Description: The powerful music player for KDE
Upstream URL: http://amarok.kde.org/
Licenses: GPL2, FDL, LGPL2.1
Submitter: arojas
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 26
Popularity: 2.142830
First Submitted: 2018-08-28 13:52
Last Updated: 2019-05-10 15:57

Pinned Comments

frealgagu commented on 2019-01-27 21:13

I've removed the dependency with libssh-gnutls and included a patch to found the mariadb database. Thanks to @ideal for this. Please let me know if you continue having issues with this package.

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

nicoadamo commented on 2019-01-24 19:07

I'm suffering a similar (but not the same) message: "The Amarok database reported the following errors: The configured database plugin could not be loaded. In most cases you will need to resolve these errors before Amarok will run properly." It also came up after an overall upgrade, including the mariadb package as mentioned by zebulon. EDIT: I've just built amarok-2.9.0.r351.0362c32b7a-1-x86_64 with mariadb 10.3.12-2 previously installed and Amarok launched alright, without any errors. I also corrected before compiling the file /etc/mysql/my.cnf, which should be based on a much simplified /etc/mysql/my.cnf.pacnew (I don't know from which version it got shorter).

zebulon commented on 2019-01-19 09:17

Hi, since 2019-01-18 amarok does not start, complaining with:

The Amarok database reported the following errors: MySQLe query failed! (0) on Error setting option to use embedded connection MySQLe query failed! (2002) Can't connect to local MySQL server through socket '/run/mysqld/mysqld.sock' (2) on call to mysql_real_connect In most cases you will need to resolve these errors before Amarok will run properly.

I am wondering if this is caused by the mariadb upgrade yesterday. Rebuilding amarok does not fix the issue. Any idea?

billypilgrim commented on 2019-01-18 05:36

Hi maintainer,

Would you mind not bumping the package version for this when there's a new git commit? For one thing this isn't a -git package so it should just be the latest stable version and, for another, you don't need to bump the package version for -git packages either (users can just rebuild when they want a new version).

frealgagu commented on 2018-11-09 17:56

I've included a new package libssh-gnutls which is the same package "libssh" but compiled with gnutls (libgcrypt). This a new dependency to amarok so amarok shouldn't crash at start.

https://bbs.archlinux.org/viewtopic.php?pid=1810619#p1810619

nicoadamo commented on 2018-11-05 00:58

@frealgagu: Thanks for clarifying so quickly!

frealgagu commented on 2018-11-04 21:54

@nicoadamo there is no a stable 2.9.70 yet, so I've been including the last commits in master branch. Version 2.9.0 is the stable one but it only works with qt4 which is no longer supported in Arch. Once the version 2.9.70 is released i'll keep it as the version of this package.

nicoadamo commented on 2018-11-04 21:45

Sorry, but are version names fine inside the package? I compiled today theoretically "amarok 2.9.0.r258.f632617d29-1", but in the Help menu, version line I get the following: Amarok Version 2.9.70 Using KDE Frameworks 5.51.0

Which matches frealgagu's comment below "Looks like a new version of amarok 2.9.70 will be released soon."

I got confused.

Regards,

Nicolás Adamo

Rhinoceros commented on 2018-10-10 01:27

Amarok won't launch, and is crashing with MySQLe something failed! on library initialization failed, return code 1.

To fix this, you need to rebuild libssh with gnutls (libgcrypt) [a]. Have a look at the linked thread, but essentially, just patch the libssh PKGBUILD with the following and install.

--- PKGBUILD    (revision 336084)
+++ PKGBUILD    (working copy)
@@ -12,7 +12,7 @@
 url="http://www.libssh.org/"
 license=(LGPL)
 arch=(x86_64)
-depends=(zlib openssl)
+depends=(libgcrypt zlib)
 makedepends=(cmake cmocka doxygen python)
 source=(https://www.libssh.org/files/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.asc})
 sha256sums=('302f31f606f2368cd3ce77d7a69f7464c18eae176e73e59102e0524401bd29d0'
@@ -33,6 +33,7 @@
   cmake ../$pkgname-$pkgver \
     -DCMAKE_INSTALL_PREFIX=/usr \
     -DWITH_GSSAPI=OFF \
+    -DWITH_GCRYPT=ON \
     -DUNIT_TESTING=ON
   make
   make docs
@@ -40,7 +41,7 @@

 check() {
   cd build
-  make test
+  make test || true # One test failure with libgcrypt
 }

 package_libssh() {

[a] https://bbs.archlinux.org/viewtopic.php?pid=1810619#p1810619

frealgagu commented on 2018-09-28 16:37

Looks like a new version of amarok 2.9.70 will be released soon.

Behem0th commented on 2018-09-22 16:32

Downgrade libssh to 0.8.2 version helps me.