Package Details: amavisd-new 2.11.0-1

Git Clone URL: https://aur.archlinux.org/amavisd-new.git (read-only)
Package Base: amavisd-new
Description: High-performance interface between mailer (MTA) and content checkers
Upstream URL: http://www.ijs.si/software/amavisd/
Licenses: GPL
Submitter: None
Maintainer: yar
Last Packager: yar
Votes: 32
Popularity: 0.793521
First Submitted: 2005-04-22 04:23
Last Updated: 2016-06-07 18:08

Dependencies (24)

Required by (2)

Sources (3)

Latest Comments

Arvedui commented on 2016-06-07 09:56

It's arch, the package should have be rebuild along with the other perl packages that rely on native code, but it was not.

nightah commented on 2016-06-07 09:39

Right you are!

Rebuilt against perl 5.24.0-1 with this PKGBUILD: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/perl-unix-syslog

Thanks for the bug report too, is that upstream perl or somewhere around on Arch? I'll follow that so I can move back to the community release when fixed.

Arvedui commented on 2016-06-07 09:02

The problem is that perl-unix-syslog was not rebuild against perl 5.24.

That package was moved to community so you have use abs to get the PKGBUILD if you want to rebuild it yourself.

Here is the corresponding bug report is FS#49600 btw.

nightah commented on 2016-06-07 07:59

Had the same error post upgrade of perl and some of it's modules on the 5th of June.

For me it was because of razor 2.85-7 having a dependancy of perl 5.24.0-1.

Rolled back to razor 2.85-5, perl 5.22.2-1 and all the modules that also had been been marked as upgrade dependancies listed below (some of the dependancies are for razor and not amavis specifically):

[2016-06-05 22:40] [ALPM] upgraded perl (5.22.2-1 -> 5.24.0-1)
[2016-06-05 22:40] [ALPM] upgraded perl-berkeleydb (0.55-1 -> 0.55-2)
[2016-06-05 22:40] [ALPM] upgraded perl-digest-nilsimsa (0.06-11 -> 0.06-12)
[2016-06-05 22:40] [ALPM] upgraded perl-digest-sha1 (2.13-6 -> 2.13-7)
[2016-06-05 22:40] [ALPM] upgraded perl-net-libidn (0.12-9 -> 0.12-10)
[2016-06-05 22:40] [ALPM] upgraded razor (2.85-5 -> 2.85-7)

I've also tried building the newer version of amavis (2.11.0) with the required razor dependancies and we still receive the Syslog.c binary mismatch error.

BoldForester commented on 2016-06-06 19:00

Package seems to be broken on fresh install:

amavisd[543]: Syslog.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

Also this is not the latest version (amavisd-new-2.11.0.tar.xz).

Arvedui commented on 2015-08-12 21:19

The package was probably lost during aur switch.

But I just uploaded it :)

nougad commented on 2015-08-12 20:52

I can't find package perl-convert-tnef for installation. I think it is not available anymore.

Frnmst commented on 2015-04-25 10:13

I've added documentation on ArchWiki page if someone needs it: https://wiki.archlinux.org/index.php/Amavis

yar commented on 2015-03-15 01:11

@Durag it uses systemd's RunTimeDirectory now. Maybe you forgot to reload the service file?

Durag commented on 2015-03-04 13:22

The start of amavisd fails, because it can't find the pid file.
Full error log: http://pastebin.com/iVh0d3qi

Got it working after creating the directory /run/amavis and chowning it to amavis:amavis

All comments