Package Details: amd-adl-sdk 9.0-1

Git Clone URL: https://aur.archlinux.org/amd-adl-sdk.git (read-only)
Package Base: amd-adl-sdk
Description: API to access display driver functionality for AMD graphics cards.
Upstream URL: http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/
Licenses: AMD-ADL
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 1
Popularity: 0.070095
First Submitted: 2014-04-08 19:03
Last Updated: 2016-01-20 13:20

Latest Comments

Vi0L0 commented on 2016-01-20 12:29

9.0:
Added PX 8.0 support
Introduced APIs to enable SLS middle mode
Introduced APIs to configure Under scan
Introduced APIs to get Graphics Core Information
Introduced APIs to get Current power usage
Introduced APIs to get information cross GPU clone details.
Improved DDC structure to get HDR brightness data.
Bug fixes.

Also thanks to community scripts you don't have to download zip separatelly

Vi0L0 commented on 2015-08-07 13:57

updated to 8.0:
Introduced APIs to get GFX EDC error log.
Introduced APIs to inject GFX EDC error.
Introduced APIs to enable display freeSync feature
Introduced Overlap APIs to adjust SLS overlap offsets.
Bug fixes.

Vi0L0 commented on 2015-01-20 21:25

updated to 7.0:
Introduced EDID Emulation APIs and sample tool
Introduced mixed mode support in SLS
Added new Eyefinity enhanced sample tool
Bug fixes

Departure commented on 2014-11-22 16:45

When installing this package you need to change the nonce in PKGBUILD to "f1b0c84d30" as of 20/11/14, this could change at a later date

Vi0L0 commented on 2014-04-15 21:21

Looks like nonce value is changing every day, so for now still the best way to get ADL_SDK_6.0.zip file is to download it manually and paste next to PKGBUILD...

Vi0L0 commented on 2014-04-14 18:40

It's because amd has changed nonce value. Ive updated pkgbuild without bumping pkgrel, please download pkgbuild again.
Wondering how often amd is changing nonce...

JoZ3 commented on 2014-04-13 22:59

New error:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 84403 0 84263 100 140 39926 66 0:00:02 0:00:02 --:--:-- 39935
==> Validating source files with md5sums...
ADL_SDK_6.0.zip ... FALLÓ
==> ERROR: One or more files did not pass the validity check!

Vi0L0 commented on 2014-04-10 18:55

solved, no mv scream now :)

Vi0L0 commented on 2014-04-10 18:32

thanks mid-kid, nice find :)

I had to modify it a bit, because downloading http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/ADL_SDK_6.0.zip is giving 404

So at source Im downloading http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/ , and telling to makepkg that it is a file, unfortunatelly mv thinks that it's directory and is telling about this inconsistency... anyhow except this little mv scream its working pretty well ;)

mid-kid commented on 2014-04-10 14:26

Downloading the zip with: curl -L http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/ --data 'amd_developer_central_nonce=4f3d450ee5&_wp_http_referer=/tools-and-sdks/graphics-development/display-library-adl-sdk/&f=QURMX1NES182LjAuemlw' -o AMD_ADL.zip
Worked fine, so how about we edit DLAGENTS?
DLAGENTS=('http::/usr/bin/curl -fLC - --data "amd_developer_central_nonce=4f3d450ee5&_wp_http_referer=/tools-and-sdks/graphics-development/display-library-adl-sdk/&f=QURMX1NES182LjAuemlw" --retry 3 --retry-delay 3 -o %o %u')

All comments