Package Details: amdgpu-pro-libdrm 17.10.401251-2

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only)
Package Base: amdgpu-pro-installer
Description: The AMDGPU Pro userspace interface to kernel DRM services
Upstream URL: http://www.amd.com
Licenses: custom:AMD
Conflicts: libdrm
Provides: libdrm
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 53
Popularity: 2.404568
First Submitted: 2016-03-28 22:44
Last Updated: 2017-04-08 22:36

Dependencies (2)

Required by (83)

Sources (6)

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:
https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

*** xorg-server 1.18 required
You will need to downgrade xorg-server to 1.18 for this package to install, due to a video driver ABI change in 1.19.

*** linux 4.8 or 4.9 required
This has been tested with 4.8 and 4.9 kernels. It's not likely to work on 4.10 at the moment.

*** mesa-noglvnd is required
https://aur.archlinux.org/packages/mesa-noglvnd/
The mesa package in Arch now includes the glvnd libGL, which conflicts with the AMDGPU-PRO libGL. You'll need to replace mesa with mesa-noglvnd.

Latest Comments

ranisalt commented on 2017-06-28 02:35

Latest version (17.20) seems to work properly with Linux > 4.9, not sure about Xorg. I couldn't fix the PKGBUILD to work.

marcoms commented on 2017-06-02 23:34

I managed to downgrade xorg using vi0l0's `xorg118` repo, and linux using the `downgrade` utility, but then I realised mesa-noglvnd was required also. Is it expected to compile mesa to install amdgpu-pro each time?

mnovick1988 commented on 2017-05-22 11:11

Issue with mesa-noglvnd- builds against libdrm(2.4.66), one used by AMDGPU-PRO is libdrm(2.4.0), which means compatibility issues with Xorg as well.

znmeb commented on 2017-05-05 21:08

Looks like I need to downgrade the kernel and xorg server first :-( That looks like a nightmare - I couldn't make the AMD GPU stuff work on the Ubuntu 16.04.2 LTS that AMD claims to support either.

Corngood commented on 2017-05-05 18:02

@znmeb Got any more info about which dependencies are failing?

Corngood commented on 2017-05-05 18:01

@gregf Is this consistent? I just ran a build and it pulled down the correct tarball from AMD.

Maybe try removing the file?

gregf commented on 2017-05-05 15:14

:: Retrieving package(s)...
:: Checking amdgpu-pro-dkms integrity...
==> Making package: amdgpu-pro-installer 17.10.401251-2 (Fri May 5 11:13:52 EDT 2017)
==> Retrieving sources...
-> Found amdgpu-pro-17.10-401251.tar.xz
-> Found 0001-disable-firmware-copy.patch
-> Found 0002-linux-4.9-fixes.patch
-> Found 0003-Change-seq_printf-format-for-64-bit-context.patch
-> Found 0004-fix-warnings-for-Werror.patch
-> Found 0005-add-archlinux-as-build-option.patch
==> Validating source files with sha256sums...
amdgpu-pro-17.10-401251.tar.xz ... FAILED
0001-disable-firmware-copy.patch ... Passed
0002-linux-4.9-fixes.patch ... Passed
0003-Change-seq_printf-format-for-64-bit-context.patch ... Passed
0004-fix-warnings-for-Werror.patch ... Passed
0005-add-archlinux-as-build-option.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

znmeb commented on 2017-05-05 09:12

I'm trying to install this on a freshly built Arch system - it's hitting a bunch of unresolved dependencies:

:: The following packages cannot be upgraded due to unresolvable dependencies:
amdgpu-pro amdgpu-pro-libgl amdgpu-pro-vdpau lib32-amdgpu-pro lib32-amdgpu-pro-libgl
lib32-amdgpu-pro-vdpau xf86-video-amdgpu-pro

Corngood commented on 2017-04-08 22:39

I've pushed an update with 17.10. Let me know if you have any problems (preferably with an issue on github).

Unfortunately it still requires xorg 1.18 and linux 4.8/4.9.

laichiaheng commented on 2017-03-30 10:29

Can't wait for it to be available for xorg-server1.19 and linux4.10

All comments