Package Details: amdgpu-pro-mesa-omx 17.40.492261-1

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only)
Package Base: amdgpu-pro-installer
Description: Mesa OpenMAX video drivers for AMDGPU Pro
Upstream URL: http://www.amd.com
Licenses: custom:AMD
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 66
Popularity: 0.220274
First Submitted: 2016-03-28 22:44
Last Updated: 2017-12-24 00:47

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at: https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

*** linux 4.9 with KALLSYMS_ALL=y is required

https://aur.archlinux.org/packages/linux-lts49-kallsyms/

*** mesa-noglvnd is required

https://aur.archlinux.org/packages/mesa-noglvnd/ The mesa package in Arch now includes the glvnd libGL, which conflicts with the AMDGPU-PRO libGL. You'll need to replace mesa with mesa-noglvnd.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ModYokosuka commented on 2018-08-03 23:36

I took a stab at upgrading this package at one point. In the process I determined the open source drivers were good enough and stopped using it.

Enverex commented on 2018-08-03 22:42

I assume this is abandoned given that it's now several versions and over half a year out of date?

parkervcp commented on 2018-06-20 20:04

18.20 was released today. What is the potential on updating?

Charadon commented on 2018-05-15 02:22

18.10 has been released, and the benchmarks have been a little impressive. Any possibility for this to be updated?

Tralen commented on 2018-04-23 19:07

The main file is failing checksum validation.

Necrobuffalo commented on 2018-04-12 21:35

I am not able to install amdgpu-pro because it can not resolve this dependency (binfmt-support).

error: can not find the git package needed to handle git sources

Can someone help me?

rawsh commented on 2018-04-04 17:22

I'm having a binfmt support issue as well. I've installed the git version (which is the only one I could find in the aur) but it does not provide the package this wants

hotaru commented on 2018-01-21 02:30

it looks like binfmt-support (listed as a dependency of the amdgpu-pro package) doesn't exist.

EDIT: binfmt-support doesn't show up on aur.archlinux.org, but I managed to find it at https://aur.archlinux.org/cgit/aur.git/tree/?h=binfmt-support

derdigge commented on 2017-12-30 10:41

I tried the package from aur and git, mentioned in pinned comment. I cant install them. cannot resolve "amdgpu-pro-libdrm=17.40.492261-1", a dependency of "xf86-video-amdgpu-pro"

but the packages are made and there. cant find a typo in PKGBUILD

full paste: https://pastebin.com/66W87zXs

pls help

nathan-osman commented on 2017-12-24 06:27

I tried @Noctivivans PKGBUILD with the other files from the archlinuxcn repo. The amdgpu-pro kernel module wouldn't compile with 4.14 or even 4.13, so I tried downgrading the kernel to 4.10 and it succeeded. However, the system then refused to boot, freezing early in the boot process. Single user mode did the same thing so I was forced to recover with a LiveCD.