Package Details: amdgpu-pro-oglp 23.40_1718238-1

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only, click to copy)
Package Base: amdgpu-pro-installer
Description: AMDGPU Pro OpenGL driver
Upstream URL: https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-22-40
Licenses: custom: AMDGPU-PRO EULA
Groups: Radeon_Software_for_Linux
Provides: libgl
Submitter: LEW21
Maintainer: Ashark (mesmer)
Last Packager: mesmer
Votes: 123
Popularity: 2.37
First Submitted: 2016-03-28 22:44 (UTC)
Last Updated: 2024-02-12 13:57 (UTC)

Dependencies (3)

Required by (727)

Sources (18)

Pinned Comments

mesmer commented on 2022-12-23 04:31 (UTC) (edited on 2023-05-28 19:28 (UTC) by mesmer)

IF PROBLEM HAPPEN

this package is our try to put amdgpu in ARCH, but this could break or have problems as amd update and change their packages for ubuntu

if anything happens you can always download a older tag in https://github.com/Ashark/archlinux-amdgpu-pro/releases and get the PKGBUILD there, and use makepkg with that build while we update or try to fix :)

ALWAYS USE LINUX-FIRMWARE-GIT IF LATEST DRIVER FAIL BEFORE ISSUE SOME ERROR

https://aur.archlinux.org/packages/linux-firmware-git

Ashark commented on 2019-12-09 20:52 (UTC) (edited on 2022-12-06 08:45 (UTC) by Ashark)

PKGBUILD generator is located here: https://github.com/Ashark/archlinux-amdgpu-pro

AMDGPU PRO wiki page: https://wiki.archlinux.org/index.php/AMDGPU_PRO

New versions will appear here: https://repo.radeon.com/amdgpu/.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 .. 57 Next › Last »

mesmer commented on 2023-04-21 17:43 (UTC)

idk if its broken, in my card progl glxinfo works but they changed the openssl to libssl, and i believe that its broken again for 7k series and maybe older cards, i think they are working for the next release and we get this time where cards stop working, @Ashark with older firmware it hangs too for you?

Ashark commented on 2023-04-17 04:04 (UTC) (edited on 2023-04-17 04:33 (UTC) by Ashark)

Seems like amdgpu-pro-oglp 22.40_1538781-1 is broken. I tried progl glxinfo and it hangs. While 22.20.5_1511376-2 (the package was called amdgpu-pro-libgl) works normally.

mesmer commented on 2023-04-09 22:43 (UTC) (edited on 2023-04-09 22:43 (UTC) by mesmer)

@hydrocryo01 @CorvetteCole, please provide more info, if you can raise a issue in the github it`s better to debug too

but anyway:

have you tried to put the firmware workaround? did you mkinitcpio that and reboot? and can you try with another version of this package so we know if the last update generate the issue?

CorvetteCole commented on 2023-04-07 06:16 (UTC)

Unfortunately having the same issue as @hydrocryo01

i.kulagin commented on 2023-03-25 14:39 (UTC)

@hydrocryo01 Did you run mkinitcpio -P after downgrading linux-firmware?

hydrocryo01 commented on 2023-03-25 11:19 (UTC)

@mesmer I got the same result with firmware 20221214 and 20230210. The result of

vk_pro obs-amf-test
is:


0123-02-25 06:16:35 2D2BE740 [AMFVideoCore] Warning: AMFVideoCore::Init() Versions Differ, hostVersion=20003 videoCoreVersion=20002
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/vcn4commandpacker.cpp(90):system VCN FW Encode interface version=1.9, expected version=1.8
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/h264config.cpp(559):H264Config::CheckFirmwareVersion(): FirmwareVersion mismatch!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreH264]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreH264Impl.cpp(185):Assertion failed:Failed to create service!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreH264]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreH264Impl.cpp(345):AMF_ERROR 1 : AMF_FAIL: Failed to create encode service!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreH264] Warning: CreateServices failed.
0123-02-25 06:16:35 2D2BE740 [AMFVideoCore] Warning: AMFVideoCore::Init() Versions Differ, hostVersion=20003 videoCoreVersion=20002
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/vcn4commandpacker.cpp(90):system VCN FW Encode interface version=1.9, expected version=1.8
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/hevcconfig.cpp(387):HevcConfig::CheckFirmwareVersion(): FirmwareVersion mismatch!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreHevc]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreHevcImpl.cpp(167):Assertion failed:Failed to create service!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreHevc]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreHevcImpl.cpp(337):AMF_ERROR 1 : AMF_FAIL: Failed to create encode service!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreHevc] Warning: CreateServices failed.
0123-02-25 06:16:35 2D2BE740 [AMFVideoCore] Warning: AMFVideoCore::Init() Versions Differ, hostVersion=20003 videoCoreVersion=20002
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/vcn4commandpacker.cpp(90):system VCN FW Encode interface version=1.9, expected version=1.8
0123-02-25 06:16:35 2D2BE740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/av1config.cpp(239):Av1Config::CheckFirmwareVersion(): FirmwareVersion mismatch!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreAv1] Warning:  AMFEncoderCoreAv1Impl::CreateEncodeService() not supported VCN instance 0! 
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreAv1]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreAv1Impl.cpp(315):AMF_ERROR 1 : AMF_FAIL: Failed to create encode service!
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreAv1] Warning: CreateServices failed.
0123-02-25 06:16:35 2D2BE740 [AMFEncoderCoreAv1] Warning: *****Failed to create AV1 encoder component.
[0]
is_amd=true
supports_avc=false
supports_hevc=false
supports_av1=false

and the amf options didn't showed up in obs. @i.kulagin Could you share how to make h264 and hevc work? I have an RX 7900 XT and linux-firmware 20221214.f3c283e-1.

mesmer commented on 2023-03-20 00:20 (UTC) (edited on 2023-03-20 00:29 (UTC) by mesmer)

@i.kulagin

as i write in the obs package

hey @hydrocryo01 i help to maintain the amd pro driver here in the arch, i suppose thats is only the amd and driver for 7900 working at all, amd does that all the times, in the beginning of the year we need to use a specific kernel version to amf to work, and stayed like this for like 3 months,
....
and at least i can find this issue for 7900 https://github.com/GPUOpen-LibrariesAndSDKs/AMF/issues/369

this issue says to me thats completly possible, if thats right we need to put that in the wiki again hgahahah but in 6k series everything is fine for now maybe something like https://www.phoronix.com/news/AMDGPU-FW-Avoid-VCN-Multi-Hang https://forums.linuxmint.com/viewtopic.php?t=390113

can you check if previous versions of this package works for newer firmware? its hard to debug without 7k series

i.kulagin commented on 2023-03-17 09:59 (UTC)

Is this package broken again because of the firmware update? I've recently acquired an RX 7900 XTX and when trying to use OBS with AMF patch it says that VCN firmware is version 1.9 but 1.8 is expected. After downgrading linux-firmware to 20221214.f3c283e-1 everything is working perfectly.

mesmer commented on 2023-02-22 18:25 (UTC)

https://github.com/Ashark/archlinux-amdgpu-pro/pull/84 update for 22.40-1538781.22.04 the major change there is to use libssl in the place of openssl

langfingaz commented on 2022-12-26 20:05 (UTC)

@Ashark: You're right, if the package does no longer exists, it doesn't make much sense to add it to conflicts. And I just did the upgrade after uninstalling the old package.