Package Details: amdgpu-pro-vdpau 17.10.401251-2

Git Clone URL: (read-only)
Package Base: amdgpu-pro-installer
Description: The AMDGPU Pro VDPAU driver
Upstream URL:
Licenses: custom:AMD
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 55
Popularity: 2.567628
First Submitted: 2016-03-28 22:44
Last Updated: 2017-04-08 22:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:

Feel free to post issues and send PRs.

*** xorg-server 1.18 required
You will need to downgrade xorg-server to 1.18 for this package to install, due to a video driver ABI change in 1.19.

*** linux 4.8 or 4.9 required
This has been tested with 4.8 and 4.9 kernels. It's not likely to work on 4.10 at the moment.

*** mesa-noglvnd is required
The mesa package in Arch now includes the glvnd libGL, which conflicts with the AMDGPU-PRO libGL. You'll need to replace mesa with mesa-noglvnd.

Latest Comments

nmset commented on 2017-08-18 21:01

Just FYI : AMD released amdgpu-pro 17.30-465504 that works with Xorg 1.19 with kernel 4.12.6 (the DKMS package is ignored).

awkwardtechdude commented on 2017-08-08 04:45

Will this be updated to 17.20?

hollunder commented on 2017-07-11 05:45

Building this stuff is quite a clusterfuck. Does someone have a list of what to build/install and in which order?
pacman -Rdd libglvnd
install mesa-noglvnd
before everything else because building that does not work with the amdpro-libdrm.

Vi0L0 commented on 2017-07-03 18:37

I should update pkgs today, but the workaround is very simple:
pacman -Rdd libglvnd
before installing mesa-noglvnd

nileshmoodley commented on 2017-07-03 17:33

I am unable to install mesa-noglvnd as there are file conflicts which are owned by libglvnd. That's the hang-up for me right now in getting this package to work.

I have posted comments on that AUR package to please resolve this issue.

hollunder commented on 2017-07-02 13:19

When I try to downgrade xorg-server I get the following error:
warning: cannot resolve "xf86-input-driver", a dependency of "xorg-server"

Any idea what to install to provide this?

ranisalt commented on 2017-06-28 02:35

Latest version (17.20) seems to work properly with Linux > 4.9, not sure about Xorg. I couldn't fix the PKGBUILD to work.

marcoms commented on 2017-06-02 23:34

I managed to downgrade xorg using vi0l0's `xorg118` repo, and linux using the `downgrade` utility, but then I realised mesa-noglvnd was required also. Is it expected to compile mesa to install amdgpu-pro each time?

mnovick1988 commented on 2017-05-22 11:11

Issue with mesa-noglvnd- builds against libdrm(2.4.66), one used by AMDGPU-PRO is libdrm(2.4.0), which means compatibility issues with Xorg as well.

znmeb commented on 2017-05-05 21:08

Looks like I need to downgrade the kernel and xorg server first :-( That looks like a nightmare - I couldn't make the AMD GPU stuff work on the Ubuntu 16.04.2 LTS that AMD claims to support either.

All comments