Package Details: amdgpu_top 0.4.0-1

Git Clone URL: (read-only, click to copy)
Package Base: amdgpu_top
Description: Tool that shows AMD GPU utilization
Upstream URL:
Licenses: MIT
Submitter: Teddy-Kun
Maintainer: Teddy-Kun
Last Packager: Teddy-Kun
Votes: 11
Popularity: 1.72
First Submitted: 2023-04-09 17:18 (UTC)
Last Updated: 2023-11-30 20:46 (UTC)

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

1 2 Next › Last »

Hanabishi commented on 2023-12-02 21:12 (UTC) (edited on 2023-12-02 21:15 (UTC) by Hanabishi)

@jahway603, I assume you are using nightly rustc, but AUR packages use stable. So you need to update the stable toolchain.

jahway603 commented on 2023-12-02 20:55 (UTC)

keep getting this strange error, even though I have required rustc version installed

==> Starting build()...
error: package `eframe v0.24.0` cannot be built because it requires rustc 1.72 or newer, while the currently active rustc version is 1.71.1
Either upgrade to rustc 1.72 or newer, or use
cargo update -p eframe@0.24.0 --precise ver
where `ver` is the latest version of `eframe` supporting rustc 1.71.1
==> ERROR: A failure occurred in build().
error: failed to build 'amdgpu_top-0.4.0-1': 
error: packages failed to build: amdgpu_top-0.4.0-1

$ rustc --version
rustc 1.72.1 (d5c2e9c34 2023-09-13)

Hanabishi commented on 2023-06-30 13:02 (UTC)

Thank you.

Hanabishi commented on 2023-06-30 10:40 (UTC) (edited on 2023-06-30 10:41 (UTC) by Hanabishi)

Please, stop messing with the package and keep it according to packaging guidelines. It works totally fine that way.

Problems with non-default flags (target-cpu=native etc) is not a package area of responsibility. Users overriding the defaults are doing it on their own risk.

FabioLolix commented on 2023-06-29 16:50 (UTC)

According to guidelines export RUSTUP_TOOLCHAIN=stable should also in build() , while here is only in prepare()

btw a license like MIT which isn't part of the licenses package need to be installed in "${pkgdir}/usr/share/licenses/${pkgname}"

@HuaHuaY if you don't want to switch toolchain you can also build using devtools (using extra-x86_64-build for convenience)

ArchLinuxARM have dropped arm and armv6h

HuaHuaY commented on 2023-06-29 16:41 (UTC) (edited on 2023-06-29 16:41 (UTC) by HuaHuaY)

I compile amdgpu_top and meet this error:

I found that pkgbuild has installed a stable toolchain. But it use cargo directly and there is a default nightly toolchain in my computer. So it use nightly channel to compile and then fail due to this error. I think pkgbuild can create a rust-toolchain.toml if you don't want to add this in the github repo. Add echo -e "[toolchain]\nchannel = \"stable-$CARCH-unknown-linux-gnu\"" > rust-toolchain.toml in the build section after cd command. Then the required toolchain and the used toolchain are definitely the same.

Teddy-Kun commented on 2023-06-29 13:04 (UTC) (edited on 2023-07-14 08:28 (UTC) by Teddy-Kun)

On the latest version (0.1.10) this package fails to compile when using RUSTFLAGS="-C opt-level=3 -C target-cpu=znver3" (or target-cpu=native on a Ryzen 5000 CPU). This is an issue in the upstream project/rust compiler and has been reported. UPDATE: The issue is fixed with rustc 1.71

Hanabishi commented on 2023-05-21 13:15 (UTC) (edited on 2023-05-21 13:16 (UTC) by Hanabishi)

This is a different error though. Seems like there are problems with your crates index.

First of all, try to remove all caches and make a clean build. Also try to build manually using makepkg -siC, without AUR helper.

blackcatgames commented on 2023-05-21 13:01 (UTC)

@Hanabishi I tried this but I still get an error

error: failed to get anyhow as a dependency of package libamdgpu_top v0.1.7 (/home/nora/.cache/paru/clone/amdgpu_top/src/amdgpu_top-0.1.8/crates/libamdgpu_top)

Caused by: failed to query replaced source registry crates-io

Caused by: attempting to make an HTTP request, but --frozen was specified ==> ERROR: A failure occurred in build(). Aborting... error: failed to build 'amdgpu_top-0.1.8-1': error: packages failed to build: amdgpu_top-0.1.8-1

Hanabishi commented on 2023-05-16 09:39 (UTC) (edited on 2023-05-16 09:43 (UTC) by Hanabishi)

The package builds totally fine. Nothing was removed from upstream or
This is a local problem of some kind.

Fast search gave me the following:

"It looks like your ~/.cargo/registry/index directory is corrupted. Delete it and run cargo update again."