Package Details: amdoverdrivectrl 1.2.7-3

Git Clone URL: https://aur.archlinux.org/amdoverdrivectrl.git (read-only)
Package Base: amdoverdrivectrl
Description: Tool for controling the frequency and fan settings of AMD/ATI video cards.
Upstream URL: http://sourceforge.net/projects/amdovdrvctrl
Licenses: GPL
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 21
Popularity: 0.321199
First Submitted: 2011-01-11 14:10
Last Updated: 2015-06-08 18:59

Latest Comments

bcc commented on 2015-03-27 16:31

==> Validating source files with md5sums...
ADL_SDK.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build amd-adl-sdk.
==> Restart building amd-adl-sdk ? [y/N]
==> ------------------------------------

heitorpb commented on 2014-11-10 22:08

I'm also getting "failed to get fan speed information" with a Radeon HD 5670 and catalyst-total 14.9-1 on a 64bit system.

Vi0L0 commented on 2014-04-08 19:21

oh, forgot to mention - im also having problems, with fan speed and overdrive on 290x
hd 7850 works fine.

Vi0L0 commented on 2014-04-08 19:13

I can see that it should use adl, ie src/adl_functions.h has #include "adl_sdk.h".
So i created amd-adl-sdk package, added it to makedeps, and modified your, mid-kid, PKGBUILD a bit.

There's only one "little" problem - i686 package fails to build with "cfanspeedpanel.o file not recognize" error. It could be error on my virt system side, can some i686 user confirm or decline it?

mid-kid commented on 2014-04-08 06:44

I have no idea, but I can't help but notice some files named after adl in the src directory.
I can't find adl_sdk.h anywhere else on my computer, so I think it isn't being used in the code.
Anyway, neither the binary nor the source version can get my fan speed settings, which is why I wanted this program in the first place. :/

Vi0L0 commented on 2014-04-07 16:54

mid-kid your build seems to work fine.
Does it mean that adl is not needed? I must admit that last time I checked this was years ago, and it was not working at all without adl.
Could this be true and even author doesn't know about it? (basic on project' website)

Vi0L0 commented on 2014-04-07 16:38

uses bins cuz its the only non-manual way
(not to mention that adl sdk is using its own license)

mid-kid commented on 2014-04-07 16:34

Try this PKGBUILD: http://pastie.org/pastes/9001089/text?key=bxo6ddl7jo8roeswnrovnq

mid-kid commented on 2014-04-07 15:45

Also, there is no package() function and $debarch doesn't have an underscore in it's name.

mid-kid commented on 2014-04-07 15:41

> Source is available.
> Uses binaries.

There goes one reason why I don't like the AUR. (Don't get me wrong, there are tons of reasons why I love it)

Vi0L0 commented on 2014-01-15 16:55

done

Vi0L0 commented on 2014-01-15 16:47

i should probably update dep list...

Vi0L0 commented on 2014-01-15 16:47

install wxgtk2.8 package, should help

C8483 commented on 2014-01-15 14:07

AMDOverdriveCtrl: error while loading shared libraries: libwx_gtk2u_adv-2.8.so.0: cannot open shared object file: No such file or directory

Anyone else having this problem?

PhotonX commented on 2013-12-18 21:23

Thanks for updating, now I can finally put it into autostart. A little script to make the fan silent after starting it for the case that fan speeds cannot be read, if anybody is interested (be careful if your card gets hot, the fan speed is very low):

#!/bin/bash

AMDOverdriveCtrl -n -m && aticonfig --pplib-cmd "set fanspeed 0 5" &
sleep 0.5
aticonfig --pplib-cmd "set fanspeed 0 5"

parched commented on 2013-12-14 21:40

Here's a PKGBUILD that compiles it, if it is any use to anyone. Should work for getting latest version for 32bit, requires a manual dl of adl sdk http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/
http://pastie.org/8552716

Vi0L0 commented on 2013-12-10 07:56

@PhotonX: i can see that you are a contributor to 1.2.5 version :)

The day after 1.2.5 release, 1.2.6 version has arrived but it contains the bug.
I wrote about this to the author a couple of days ago.
Let's say if there will be no response I will update this package to 1.2.5

PhotonX commented on 2013-12-03 19:31

New version 1.2.5 is out. :)

Vi0L0 commented on 2013-04-09 20:04

updated, thanks, looks like the author did update the deb package

HACKhalo2 commented on 2013-04-09 15:29

For version 1.2.3, the MD5 sum doesn't match up. The one you provide is c02ec0964cabbe0344affaa561bedd78 (for x86_64), whereas I get e41c44d3908891643dfdd6b63fe1f7e7 (for x86_64) with md5sum.

Vi0L0 commented on 2013-03-09 17:27

updated x86_64 version to 1.2.3:
- new command line switch "--no-warnings" to suppress warning message box at startup
- patch included (detect if card supports fan speed setting by percentage)

Vi0L0 commented on 2011-07-09 10:52

udpate
V1.2.1 : Bugfix: correct segfault if no perf levels reported

Vi0L0 commented on 2011-06-01 13:53

update 1.1.3 -> 1.2.0 :
V1.2.0 : added (yet) undocumented 'AMD Powertune' setting - needs testing!
V1.1.4 : "save default" button added by SourceForge Member 'logion'

Vi0L0 commented on 2011-04-25 09:09

Your DE should find the shortcut automatically, it is located in /usr/share/applications/AMDOverdriveCtrl.desktop

You can also run it from console with AMDOverdriveCtrl command - at least for me it appears in window.

Anonymous comment on 2011-04-24 13:30

How enable GUI mode?

Vi0L0 commented on 2011-04-08 19:06

update 1.1.1 -> 1.1.3:

V1.1.3 : card ident string was wrong in multi GPU setup
V1.1.2 : choose GPU through command line switch (--adapter-index)