Package Details: amf-amdgpu-pro 23.40_1718238-1

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only, click to copy)
Package Base: amdgpu-pro-installer
Description: AMDGPU Pro Advanced Multimedia Framework
Upstream URL: https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-22-40
Licenses: custom: AMDGPU-PRO EULA
Groups: Radeon_Software_for_Linux
Submitter: LEW21
Maintainer: Ashark (mesmer)
Last Packager: mesmer
Votes: 123
Popularity: 2.32
First Submitted: 2016-03-28 22:44 (UTC)
Last Updated: 2024-02-12 13:57 (UTC)

Dependencies (4)

Required by (1)

Sources (18)

Pinned Comments

mesmer commented on 2022-12-23 04:31 (UTC) (edited on 2023-05-28 19:28 (UTC) by mesmer)

IF PROBLEM HAPPEN

this package is our try to put amdgpu in ARCH, but this could break or have problems as amd update and change their packages for ubuntu

if anything happens you can always download a older tag in https://github.com/Ashark/archlinux-amdgpu-pro/releases and get the PKGBUILD there, and use makepkg with that build while we update or try to fix :)

ALWAYS USE LINUX-FIRMWARE-GIT IF LATEST DRIVER FAIL BEFORE ISSUE SOME ERROR

https://aur.archlinux.org/packages/linux-firmware-git

Ashark commented on 2019-12-09 20:52 (UTC) (edited on 2022-12-06 08:45 (UTC) by Ashark)

PKGBUILD generator is located here: https://github.com/Ashark/archlinux-amdgpu-pro

AMDGPU PRO wiki page: https://wiki.archlinux.org/index.php/AMDGPU_PRO

New versions will appear here: https://repo.radeon.com/amdgpu/.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 .. 57 Next › Last »

Lulzagna commented on 2023-11-22 00:38 (UTC) (edited on 2023-11-22 20:47 (UTC) by Lulzagna)

For obs-amf, rolling back my linux-firmware to version 20230804.7be2766d-2 works for me - I still have the old ZST file on my system that I installed.

I don't know why but my error message said the version was 1.21 and expected 1.20 even though my system is completely up to date except for the firmware.

Edit: Uploaded here in case anyone wanted it. Install with sudo pacman -U <.zst file> and make sure to sudo mkinitcpio -P

EnSER commented on 2023-11-14 10:24 (UTC)

Comments from AMD for latest VCN firmware on linux-firmware: update VCN 4.0.X firmware from 5.7 branch I didn't have any luck with current 5.7 and 5.7.1, but maybe somebody else could try?

mesmer commented on 2023-11-13 22:02 (UTC) (edited on 2023-11-13 22:02 (UTC) by mesmer)

@firastom great work, this package is a nightmare to control and make work, as the firmware is always a problem, and we dont have a way of controlling that without breaking the firmware packages :(

from time to time the amd create a update and or change the version completly, or replace a package , remove a package or just use a version of firmware that i cannot put to work with the arch at all

please fell free to open a branch and a PR int he git so we can try to get a solution for this, but to be fair i am getting tired of controlling the caos of AMD haha

i thought of creating a linux-firmware for amd itself, but it seems to be so much trouble for that driver alone

firastom commented on 2023-11-12 00:09 (UTC)

please read this massage till the end. note: i only care about getting obs-amf working on my machine and i'm not a developer.

man this driver must be synced with certain firmware component but i can't figure it out,any way you have to find that part and make sure to merge it into this package,

when i first installed this firmware i got this error: Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.27

so i blived that the driver is bleeding edge and rolled back to the tag you mentioned below v22.10.15... and the i got this error:

Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.26

so i realized the newer driver is the one in the linux firmware so i went to the archlinux-amdgpu-pro git repo and found out theres newer versions of this driver (5.7.1) , i followed the instructions and built that certain version and installed it. even though i still got the error:

Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.28

at least i'm more closer :) but still the linux firmware is more up to date and you must find the certain parts of the linux-firmware that requires certain version of the software and make sure you put those files on with the package, i know that the package manager can't replace existing packages but i figured one way around it is by downloading the original linux-firmware package modifying it then reinstalling it(don't forget to regenerate kernel) , i hope you can solve this issue , any solution of controling versions independently won't last for too long until it breaks so its really important to consider downloading the firmware version thats already installed and modify it and maybe you can uninstall the original and rename the package you modify so the linux-firmware won't be updated without an update for this package.

mesmer commented on 2023-10-20 21:55 (UTC)

if your amf is not working i advice in usage of https://github.com/Ashark/archlinux-amdgpu-pro/releases/tag/v22.40_1577631-1 this tag that is the one before the 23.20 release, working in trying to make the others work correct

mesmer commented on 2023-10-20 04:20 (UTC) (edited on 2023-10-20 22:09 (UTC) by mesmer)

about versions,

5.6 and 5.6.1 was skiped by amd itself

5.7 and 5.7.1(even its not listed you can find) is already released, but that versions seems to need a specific linux-firmware version that i cannot found easily

linux-firmware-20230804.7be2766d-2

gives

0123-09-20 01:18:45 B1304740 [EncodeCore] Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.27, expected version=1.28

and

linux-firmware-git 20230814.0e048b06-1

gives 1.29 instead 1.28

till i found a solution for this, or it solves itself i'll not upgrade, but i'll create a branch in the git with the makepkg updated to this version if anyone wanna try

mesmer commented on 2023-08-09 01:13 (UTC)

@rokero i cant reproduce the same error, can you give more info, in the git is the best place to open a issue for this