Package Details: amnesia-tdd 1.2.1-4

Git Clone URL: https://aur.archlinux.org/amnesia-tdd.git (read-only)
Package Base: amnesia-tdd
Description: Amnesia: The Dark Descent is a first person survival horror game.
Upstream URL: http://www.amnesiagame.com/
Licenses: custom
Conflicts: amnesia-tdd-hib
Submitter: Ideka
Maintainer: None
Last Packager: postblue
Votes: 15
Popularity: 0.000000
First Submitted: 2011-07-23 03:04
Last Updated: 2017-06-01 08:32

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

postblue commented on 2017-10-16 18:24

1.3.1 is out but I'm unable to make a working PKGBUILD, disowning the package.

postblue commented on 2015-06-08 18:15

Adopted the package and reworked it so it's easier to maintain.

ainola commented on 2015-02-01 08:42

I will say to anyone trying to install any non-Humble-bundle versions that you have a decent chance of being able to install if you just edit my humble-bundle version. This one will very likely not work anymore due to a total restructure of the game files.

https://aur.archlinux.org/packages/amnesia-tdd-hib/

ainola commented on 2015-02-01 08:40

Hi!

So I've fixed up all the issues with this PKGBUILD and (hopefully) future-proofed it. Thing is, I only have access to the Humble Bundle version so I've made a separate package here:

https://aur.archlinux.org/packages/amnesia-tdd-hib/

I think it's best to have them separated anyway since they're kinda two different packages and most other games are separated like this. I wrote the PKGBUILD to be nearly interchangeable so anyone that wants to update this package could very easily base it off of mine:

1) update the sha256sum for the .sh installer
2) rename the pkgname/accompanying files to match this package name (amnesia-ttd)

If my memory serves, I think that's all that it would take.

Ideka commented on 2013-10-04 23:04

Not sure why was this flagged out-of-date.
There are currently two versions of this game that I know of: the original version sold by frictional games on their website, which is 1.2, and the humble indie bundle version, which is 1.2.1-3. This PKGBUILD supports both.
By default it's prepared to build for the 1.2.1-3 version. If you have the 1.2 version, just change the value of pkgver.
Anyway, I'm unflagging it.

Ideka commented on 2012-08-09 03:16

And you aren't doing anything fancy like, say, skipping checksum verification?

Anonymous comment on 2012-08-09 02:27

The most recent 1.2.1-3 freshly downloaded from Frictional

Ideka commented on 2012-08-08 03:06

Eh, that's weird. What version are you trying to make?

Anonymous comment on 2012-08-07 13:36

Getting the following error:

==> Extracting subarchive...
tar (child): subarch: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

Ideka commented on 2012-06-30 02:25

Thanks, I didn't know about that. Really useful for big packages, like this one.

All comments