Search Criteria
Package Details: ampache 8.1.0-1
Package Actions
| Git Clone URL: | https://aur.archlinux.org/ampache.git (read-only, click to copy) |
|---|---|
| Package Base: | ampache |
| Description: | PHP web based audio/video streaming application and file manager |
| Upstream URL: | http://www.ampache.org/ |
| Licenses: | GPL |
| Conflicts: | ampache-development, ampache-git |
| Submitter: | gishten |
| Maintainer: | BoBeR182 (slip) |
| Last Packager: | slip |
| Votes: | 70 |
| Popularity: | 0.000225 |
| First Submitted: | 2009-01-13 01:03 (UTC) |
| Last Updated: | 2026-09-11 03:08 (UTC) |
Dependencies (7)
- mariadb (mysql81AUR, mysql80AUR, mysql84AUR, mysqlAUR, mariadb-lts, percona-server)
- php
- faad2 (faad2-gitAUR) (optional) – m4a transcoding/downsampling
- flac (flac-gitAUR) (optional) – flac transcoding/downsampling
- lame (lame-altivecAUR, lame-svnAUR) (optional) – all transcoding/downsampling
- mp3spltAUR (mp3splt-binAUR) (optional) – mp3 and ogg transcoding/downsampling
- vorbis-tools (vorbis-tools-gitAUR, vorbis-tools-gitAUR) (optional) – all transcoding
Latest Comments
1 2 3 Next › Last »
slip commented on 2026-08-11 21:57 (UTC) (edited on 2026-08-11 21:57 (UTC) by slip)
The latest 8.0.0 upgrade has been released shortly before this comment. It is a major update that does NOT allow rollback to Ampache 7 unless you first update to 7.10. Since the AUR has been down for maintenance and only just opened back up today as well, I think it might be prudent to leave this package on 7.10 for a bit first to avoid sending people past the point of no return. You can always manually adjust the PKGBUILD if you want to go ahead with 8.0.0 ahead of time.
Documentation for this update can be found here.
https://ampache.org/docs/help/troubleshooting/ampache8-for-admins/
https://ampache.org/docs/help/troubleshooting/ampache8-for-users
Behem0th commented on 2025-06-01 13:58 (UTC)
I try build and get this error
Change string
unlink "${_targetdir}/${pkgname}-${pkgver}_all_php8.3_squashed.zip"
to
unlink "${_targetdir}/${pkgname}-${pkgver}_all_php8.4_squashed.zip"
solve problem
slip commented on 2024-09-02 09:01 (UTC)
With
phpas a depend being version 8.3 presently, should the source package be updated to the 8.3 version as well for continuity?IncredibleLaser commented on 2018-12-09 13:04 (UTC)
The sha256sum for the zip file is not correct.
berturion commented on 2018-09-07 05:09 (UTC) (edited on 2018-09-11 14:37 (UTC) by berturion)
Hello, when trying to install ampache it fails with:
curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading https://github.com/ampache/ampache/releases/download/3.8.9/ampache-3.8.9_all.zip Aborting...
EDIT: Ampache 3.8.9 zip is now online again, problem solved.
Bubbel commented on 2017-12-10 22:24 (UTC)
@DrWaluigi: Your fix worked. Thank you. As I see the package being updated through pacman, the permissions error is all over the place in the package. I assume the vendor directory is the only one that is newly created, since 3.8.4, so it gets 700 permissions.
Anyway, @max-k: I think you can fix this in the package quite easily. So, if you can find the time, please do. Thank you in advance. :)
DrWaluigi commented on 2017-12-09 10:01 (UTC) (edited on 2017-12-09 10:02 (UTC) by DrWaluigi)
There are permission issues on /usr/share/webapps/ampache/lib/vendor/. Some folders are not readable by non-root users. To fix these issues:
chmod u=rwX,g=rX,o=rX -R /usr/share/webapps/ampache/lib/vendor/
Bubbel commented on 2017-12-08 21:44 (UTC)
Well, my upgrade to 3.8.4 doesn't go quite as expected. When I installed 3.8.4, all I got was a blank screen in y webbrowser. Downgrade to 3.8.3 resolved the issue.
I haven't looked into it very deeply, but I don't see any errors in the logs.
I'm using nginx with a nginx reverse-proxy in front of it. Doe anyone experience the same issue?
max-k commented on 2017-05-17 11:16 (UTC)
<deleted-account> commented on 2017-05-08 03:46 (UTC)
1 2 3 Next › Last »