Package Details: amule-adnza 2012.1-12

Git Clone URL: https://aur.archlinux.org/amule-adnza.git (read-only, click to copy)
Package Base: amule-adnza
Description: aMule patched for Fastweb Network (Italy) by Adunanza forum
Upstream URL: http://amule-adunanza.sourceforge.net/
Licenses: GPL
Conflicts: amule, amule-adnza-svn, amule-adunanza
Provides: amule
Submitter: bardo
Maintainer: volalto
Last Packager: volalto
Votes: 17
Popularity: 0.000000
First Submitted: 2005-09-24 16:53 (UTC)
Last Updated: 2018-04-17 18:06 (UTC)

Latest Comments

ThePayne commented on 2019-06-27 18:00 (UTC)

Looks like a but in Crypto++7 to me. Not sure if it does not recognize the compiler version correctly or something like that.

Found no elegant way to do it, so I just commented out the whole stanza in /usr/include/cryptopp/secblock.h

//#if defined(CRYPTOPP_CXX11_VARIADIC_TEMPLATES) || defined(CRYPTOPP_DOXYGEN_PROCESSING)
//
//      /// \brief Constructs a new V using variadic arguments
//      /// \tparam V the type to be forwarded
//      /// \tparam Args the arguments to be forwarded
//      /// \param ptr pointer to type V
//      /// \param args variadic arguments
//      /// \details This is a C++11 feature. It is available when CRYPTOPP_CXX11_VARIADIC_TEMPLATES
//      ///   is defined. The define is controlled by compiler versions detected in config.h.
//    template<typename V, typename... Args>
//    void construct(V* ptr, Args&&... args) {::new ((void*)ptr) V(std::forward<Args>(args)...);}
//
//      /// \brief Destroys an V constructed with variadic arguments
//      /// \tparam V the type to be forwarded
//      /// \details This is a C++11 feature. It is available when CRYPTOPP_CXX11_VARIADIC_TEMPLATES
//      ///   is defined. The define is controlled by compiler versions detected in config.h.
//    template<typename V>
//    void destroy(V* ptr) {if (ptr) ptr->~V();}
//
//#endif

I also needed to apply this patch to the code in src/ClientCreditsList.cpp: https://github.com/amule-project/amule/pull/120

lviggiani commented on 2018-11-30 08:45 (UTC)

I have the same issue. I've also tried installing amule-adnza-svn instead but I get another compile error. :(

gizas commented on 2018-08-31 19:32 (UTC)

anche io ho lo stesso errore di agrim. Sapete come riuscire a compilarlo lo stesso? Grazie

agrim commented on 2018-06-12 12:42 (UTC) (edited on 2018-06-12 12:48 (UTC) by agrim)

In file included from /usr/include/cryptopp/iterhash.h:7,
             from /usr/include/cryptopp/md4.h:4,
             from CryptoPP_Inc.h:51,
             from EncryptedStreamSocket.h:41,
             from EMSocket.h:29,
             from ClientTCPSocket.h:33,
             from BaseClient.cpp:70:
/usr/include/cryptopp/secblock.h:82:93: error: macro "V" requires 2 arguments, but only 1 given
 void construct(V* ptr, Args&&... args) {::new ((void*)ptr) V(std::forward<Args>(args)...);}
                                                                                         ^
/usr/include/cryptopp/secblock.h:89:44: error: macro "V" requires 2 arguments, but only 1 given
 void destroy(V* ptr) {if (ptr) ptr->~V();}
                                        ^
make[3]: *** [Makefile:1703: amule-BaseClient.o] Error 1
make[2]: *** [Makefile:3334: all-recursive] Error 1
make[1]: *** [Makefile:519: all-recursive] Error 1
make: *** [Makefile:423: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...`

Guidobelix commented on 2015-06-16 18:26 (UTC)

I hae adopted the package and moved it to Aur4. I have also added the systemd files (taken from amule package).

nTia89 commented on 2015-06-02 09:08 (UTC)

I can't be no more the maintainer of this (and all of mine) package, so I disown it. In the hope this package will be adopted by someone who will take care as I do it, goodbye

nTia89 commented on 2014-03-29 13:22 (UTC)

grazie x la segnalazione Bfg. aggiornerò il pacchetto

bfg commented on 2014-03-28 22:59 (UTC)

Se a qualcuno può interessare il pacchetto compila senza modifiche anche sotto ARM ('armv7h', un google nexus 7 con archlinuxarm).

nTia89 commented on 2014-01-15 22:36 (UTC)

there are two solutions: °with --with-wx-config=/usr/bin/wx-config-2.8 you need only wxgtk2.8 as dep °with --with-wxversion=2.8 you need both wxgtk and wxgtk2.8 as deps I choose the first solution because force you to have less deps

tago commented on 2014-01-15 21:40 (UTC)

Tutto sistemato, ho dovuto re-installare wxgtk2.8, forse era stato sostituito da wxgtk3.0... Comunque ora compila e funziona alla grande... Ciao e grazie :)

nTia89 commented on 2014-01-15 21:16 (UTC)

il problema è che a me compila e funziona.... se nessun altro ha questo problema in comincio a pensare che il problema è solo tuo....io nel mio sistema ho installato sia "wxgtk" che "wxgtk2.8" prova ad installarli anche te entrambi

tago commented on 2014-01-15 21:12 (UTC)

Ciao continua a darmi il seguente errore: checking for wx-config... /usr/bin/wx-config checking for wxWidgets version >= 2.8.12 (--unicode=yes --version=2.8)... no configure: error: The requested wxWidgets build couldn't be found. The configuration you asked for aMuleAdunanzA requires a wxWidgets build with the following settings: --unicode=yes --version=2.8 but such build is not available. To see the wxWidgets builds available on this system, please use 'wx-config --list' command. To use the default build, returned by 'wx-config --selected-config', use the options with their 'auto' default values. If you still get this error, then check that 'wx-config' is in path, the directory where wxWidgets libraries are installed (returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH or equivalent variable and wxWidgets version is 2.8.12 or above. ==> ERRORE: Si è verificato un errore in build().

nTia89 commented on 2014-01-15 20:02 (UTC)

now should really works! try it again

tago commented on 2014-01-15 14:25 (UTC)

Ciao, ho provato ma non funziona, mi dice che manca la dipendenza a wxgtk 2.8... :/

nTia89 commented on 2014-01-14 23:13 (UTC)

package is now fixed! added in ./configure the further switch "--with-wxversion=2.8" (although with "--with-wx-config=/usr/bin/wx-config-2.8" works as well...)

snoomerz commented on 2014-01-13 20:38 (UTC)

Now the package needs wxgtk2.8 that it's different from wxgtk.

nTia89 commented on 2012-12-01 11:28 (UTC)

updated the package. i've modified the launcher icon, name and added a comment (.desktop)

nTia89 commented on 2012-11-29 22:04 (UTC)

updated!

lantuin commented on 2012-11-29 21:53 (UTC)

==> Validazione dei sorgenti con md5sums in corso... aMule-AdunanzA-2012.1-2.3.1.tar.bz2 ... NON RIUSCITO ==> ERRORE: Uno o più file non hanno superato il controllo di validità! ==> ERRORE: Makepkg non è riuscito a compilare amule-adnza. Correggi l'md5sum del pacchetto!

nTia89 commented on 2012-11-28 18:00 (UTC)

i've adopt the package, now it works!

zukka commented on 2012-09-09 07:57 (UTC)

adding this patch makes compilation work --- aMule-AdunanzA-2010.1-2.2.6/src/ObservableQueue.h 2010-02-03 18:14:39.000000000 +0100 +++ aMule-AdunanzA-2010.1-2.2.6_patched/src/ObservableQueue.h 2012-09-09 09:37:58.019977161 +0200 @@ -331,14 +331,14 @@ template <typename ValueType> void CObservableQueue<ValueType>::ObserverAdded( ObserverType* o ) { - NotifyObservers( EventType( EventType::STARTING ), o ); + this->NotifyObservers( EventType( EventType::STARTING ), o ); } template <typename ValueType> void CObservableQueue<ValueType>::ObserverRemoved( ObserverType* o ) { - NotifyObservers( EventType( EventType::STOPPING ), o ); + this->NotifyObservers( EventType( EventType::STOPPING ), o ); }

kiodo1981 commented on 2012-09-09 07:00 (UTC)

make[3]: *** [amule-DownloadQueue.o] Errore 1 make[2]: *** [all-recursive] Errore 1 make[1]: *** [all-recursive] Errore 1 make: *** [all] Errore 2 ==> ERRORE: Si è verificato un errore in build(). L'operazione sta per essere interrotta... Ho risolto usando il pacchetto CCR di chakra. Non la trovo la migliore soluzione.

lantuin commented on 2012-08-16 09:52 (UTC)

amule-adnza is a package that differs from amule, it must be used only by Fastweb users. This is the last available version so it's the most update.

hepha commented on 2012-07-10 15:08 (UTC)

will add this patch fix make bug http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=10;bug=674375 i use to amule-dlp cat work

alexiobash commented on 2012-06-09 10:33 (UTC)

very good pkg!!!

barchiesi commented on 2012-05-24 20:01 (UTC)

In file included from DownloadQueue.h:30:0, from DownloadQueue.cpp:26: ObservableQueue.h: In instantiation of ‘void CObservableQueue<ValueType>::ObserverAdded(CObservableQueue<ValueType>::ObserverType*) [with ValueType = CPartFile*; CObservableQueue<ValueType>::ObserverType = CObserver<CQueueEvent<CPartFile*> >]’: DownloadQueue.cpp:1597:32: required from here ObservableQueue.h:334:2: error: ‘NotifyObservers’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] ObservableQueue.h:334:2: note: declarations in dependent base ‘CObservable<CQueueEvent<CPartFile*> >’ are not found by unqualified lookup ObservableQueue.h:334:2: note: use ‘this->NotifyObservers’ instead ObservableQueue.h: In instantiation of ‘void CObservableQueue<ValueType>::ObserverRemoved(CObservableQueue<ValueType>::ObserverType*) [with ValueType = CPartFile*; CObservableQueue<ValueType>::ObserverType = CObserver<CQueueEvent<CPartFile*> >]’: DownloadQueue.cpp:1753:1: required from here ObservableQueue.h:341:2: error: ‘NotifyObservers’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] ObservableQueue.h:341:2: note: declarations in dependent base ‘CObservable<CQueueEvent<CPartFile*> >’ are not found by unqualified lookup ObservableQueue.h:341:2: note: use ‘this->NotifyObservers’ instead make[3]: *** [amule-DownloadQueue.o] Error 1 make[3]: *** Waiting for unfinished jobs.... make[2]: *** [all-recursive] Error 1 make[1]: *** [all-recursive] Error 1 make: *** [all] Error 2

commented on 2011-04-18 18:48 (UTC)

Hi gborzi, thanks for reporting. I removed cvs and perl (it's required by gd yet) from makedeps and moved crypto++ to deps (I can't start amule without it). I didn't bump pkgrel, no need to force a rebuild here I think. Sorry for late response.

gborzi commented on 2011-04-08 15:44 (UTC)

Please remove cvs from makedepends, it isn't needed to compile the package.

commented on 2010-10-30 11:04 (UTC)

@ garrett You have to rebuild amule-adnza, latest libupnp pkg provides libupnp.so.4. I already did it a few days ago. Maintaining aur pkgs is up to users who install them.

Garret commented on 2010-10-29 20:27 (UTC)

I updated the system and now, when I try to start amule-adunanza, I receive this error: amule: error while loading shared libraries: libupnp.so.3: cannot open shared object file: No such file or director I have the latest libupnp package installed.

commented on 2010-06-02 08:31 (UTC)

ld terminated with signal 11 [Segmentation fault] It's not package related, ld segfaults on your system. You should really report a bug on http://bugs.archlinux.org/ .

commented on 2010-06-02 05:09 (UTC)

Compiling wxcasframe.cpp Linking wxcas collect2: ld terminated with signal 11 [Segmentation fault] make[5]: *** [wxcas] Error 1 make[4]: *** [all-recursive] Error 1 make[3]: *** [all-recursive] Error 1 make[2]: *** [all-recursive] Error 1 make[1]: *** [all-recursive] Error 1 make: *** [all] Error 2

commented on 2010-05-01 13:46 (UTC)

Hi gborzi, thanks for reporting. I added your patch + other svn fixes from the new development branch. Tested and everything works properly here. Bye.

gborzi commented on 2010-05-01 12:40 (UTC)

This package needs another small patch to compile with the latest wxgtk library. It's here http://aur.pastebin.com/msiTkAiR it is applied as follows patch -Np0 -i $srcdir/wxfont.patch