Package Details: android-sdk-cmdline-tools-latest-dummy 6.0-1

Git Clone URL: https://aur.archlinux.org/android-sdk-cmdline-tools-latest-dummy.git (read-only, click to copy)
Package Base: android-sdk-cmdline-tools-latest-dummy
Description: Android SDK Command-line Tools (latest), dummy package
Upstream URL: https://developer.android.com/studio
Keywords: android development
Licenses: custom
Conflicts: android-sdk-cmdline-tools-latest
Provides: android-sdk, android-sdk-cmdline-tools-latest
Submitter: dreamingincode
Maintainer: dreamingincode
Last Packager: dreamingincode
Votes: 1
Popularity: 0.000000
First Submitted: 2020-03-11 09:02 (UTC)
Last Updated: 2022-03-22 21:08 (UTC)

Dependencies (4)

Required by (59)

Sources (2)

Latest Comments

saya commented on 2022-03-23 09:56 (UTC)

@dreamingincode Yep, a cleanBuild fixed it. Thank you very much, sorry for bothering you with such a trivial error!

dreamingincode commented on 2022-03-23 09:54 (UTC)

@saya I did confirm that the package builds before push, and I just did another install with yay and it still built fine. Maybe you need to do a clean build for the package?

saya commented on 2022-03-23 08:37 (UTC)

Hi, some files (namely android-sdk-cmdline-tools-latest.sh and android-sdk-cmdline-tools-latest.csh didn't pass the checksum, therefore making the package impossible to install. Did I mess something up?

Full log below:

:: Searching AUR for updates...
:: 1 Packages to upgrade.
1  aur/android-sdk-cmdline-tools-latest-dummy  1.0-1 -> 6.0-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> 
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  android-sdk-cmdline-tools-latest-dummy-6.0-1

  1 android-sdk-cmdline-tools-latest-dummy (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/0): android-sdk-cmdline-tools-latest-dummy
  1 android-sdk-cmdline-tools-latest-dummy (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/1) Parsing SRCINFO: android-sdk-cmdline-tools-latest-dummy
==> Making package: android-sdk-cmdline-tools-latest-dummy 6.0-1 (Wed 23 Mar 2022 09:29:02 CET)
==> Retrieving sources...
  -> Found android-sdk-cmdline-tools-latest.sh
  -> Found android-sdk-cmdline-tools-latest.csh
==> Validating source files with sha1sums...
    android-sdk-cmdline-tools-latest.sh ... FAILED
    android-sdk-cmdline-tools-latest.csh ... FAILED
==> ERROR: One or more files did not pass the validity check!
 -> error downloading sources: android-sdk-cmdline-tools-latest-dummy 
     context: exit status 1


==> Making package: android-sdk-cmdline-tools-latest-dummy 6.0-1 (Wed 23 Mar 2022 09:29:04 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found android-sdk-cmdline-tools-latest.sh
  -> Found android-sdk-cmdline-tools-latest.csh
==> Validating source files with sha1sums...
    android-sdk-cmdline-tools-latest.sh ... FAILED
    android-sdk-cmdline-tools-latest.csh ... FAILED
==> ERROR: One or more files did not pass the validity check!
 -> error making: android-sdk-cmdline-tools-latest-dummy