Package Details: android-studio 3.2.1.0-1

Git Clone URL: https://aur.archlinux.org/android-studio.git (read-only)
Package Base: android-studio
Description: The official Android IDE (Stable branch)
Upstream URL: http://tools.android.com/
Keywords: android
Licenses: Apache
Submitter: TamCore
Maintainer: kordianbruck
Last Packager: kordianbruck
Votes: 827
Popularity: 12.359721
First Submitted: 2013-05-15 19:45
Last Updated: 2018-10-11 21:43

Pinned Comments

meribold commented on 2018-09-26 04:57

I ran into an issue with UI scaling after upgrading to 3.2.0.26-1: all the icons were huge. I fixed this by going to "Help" -> "Edit Custom VM Options..." and adding -Dhidpi=false. Maybe this will help someone.

Anonymous comment on 2013-05-16 06:18

Upon starting Android Studio it checks the file size of fsnotifier64 (like IntelliJ). Since makepkg strips it, it changes the filesize. The result is that I get a warning by Android Studio that the "Native file watcher executable is outdated".

Please add a options=('!strip') to the PKGBUILD, which fixes this issue.

billybigrigger commented on 2013-05-16 05:38

getting an error when starting a new project...

Your Android SDK is out of date or is missing templates. Please ensure you are using SDK version 22 or later.

anyone else getting this?

billybigrigger commented on 2013-05-16 05:33

getting an error when starting a new project...

Your Android SDK is out of date or is missing templates. Please ensure you are using SDK version 22 or later.

anyone else getting this?

billybigrigger commented on 2013-05-16 05:27

==> Installing missing dependencies...
error: target not found: android-platform-17
==> ERROR: 'pacman' failed to install missing dependencies.
:: android-studio cleaned
billybigrigger@arch ~ » pacaur -s android-platform-17
aur/android-platform-17 4.2.2_r02-1 (21)
Android SDK Platform, API-17

why is pacman looking for something in the aur? :D

xgdgsc commented on 2013-05-16 04:55

I don't know if many people use those platform packages from AUR. I guess many might be only use android-sdk android-sdk-platform-tools and manage platform there (judging from votes of those android-platform-* packages). So I suggest moving android-platform-17 to optdepends and add some post-install warning to install file to let users know platform 17 should be installed.

billybigrigger commented on 2013-05-16 04:43

==> Installing missing dependencies...
error: target not found: android-platform-17
==> ERROR: 'pacman' failed to install missing dependencies.
:: android-studio cleaned
billybigrigger@arch ~ » pacaur -s android-platform-17
aur/android-platform-17 4.2.2_r02-1 (21)
Android SDK Platform, API-17

why is pacman looking for something in the aur? :D

donniezazen commented on 2013-05-16 04:30

Also it shouldn't require android-sdk-platform-tools if platform tools are provided by android-sdk.

billybigrigger commented on 2013-05-16 04:28

==> Installing missing dependencies...
error: target not found: android-platform-17
==> ERROR: 'pacman' failed to install missing dependencies.
:: android-studio cleaned
billybigrigger@arch ~ » pacaur -s android-platform-17
aur/android-platform-17 4.2.2_r02-1 (21)
Android SDK Platform, API-17

why is pacman looking for something in the aur? :D

billybigrigger commented on 2013-05-16 04:27

==> Installing missing dependencies...
error: target not found: android-platform-17
==> ERROR: 'pacman' failed to install missing dependencies.
:: android-studio cleaned
billybigrigger@arch ~ » pacaur -s android-platform-17
aur/android-platform-17 4.2.2_r02-1 (21)
Android SDK Platform, API-17

fixman commented on 2013-05-15 22:06

That was fast.